]> git.pld-linux.org Git - packages/banshee.git/blob - banshee.spec
- enable JukeBox support
[packages/banshee.git] / banshee.spec
1 # ToDo:
2 #       - make some proper bconds for other it
3 #
4 %include /usr/lib/rpm/macros.mono
5 #
6
7 Summary:        A Mono/GStreamer Based Music Player
8 Summary(pl.UTF-8):      Oparty na Mono/GStreamerze odtwarzacz muzyki
9 Name:           banshee
10 Version:        0.12.1
11 Release:        0.3
12 License:        GPL
13 Group:          Applications/Multimedia
14 Source0:        http://banshee-project.org/files/banshee/%{name}-%{version}.tar.gz
15 # Source0-md5:  6bcfe0a4ca92e6cce86244938f004b8c
16 Patch0:         %{name}-spurious_trailing_comma.patch
17 URL:            http://banshee-project.org/
18 BuildRequires:  GConf2-devel
19 BuildRequires:  autoconf >= 2.13
20 BuildRequires:  automake
21 BuildRequires:  dbus-devel >= 0.93
22 BuildRequires:  dbus-glib-devel >= 0.71
23 BuildRequires:  dotnet-avahi-devel
24 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
25 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
26 BuildRequires:  dotnet-ipod-sharp
27 BuildRequires:  dotnet-libgphoto2-sharp-devel
28 BuildRequires:  dotnet-njb-sharp
29 BuildRequires:  gnome-desktop-devel >= 2.16.0
30 BuildRequires:  gstreamer-cdparanoia
31 BuildRequires:  gstreamer-devel >= 0.10.3
32 BuildRequires:  gstreamer-gnomevfs
33 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.3
34 BuildRequires:  gtk+2-devel >= 2.10.3
35 BuildRequires:  hal-devel >= 0.5.2
36 BuildRequires:  intltool >= 0.35
37 BuildRequires:  libmusicbrainz-devel >= 2.1.1
38 BuildRequires:  libtool
39 BuildRequires:  mono-csharp >= 1.1.13
40 BuildRequires:  monodoc
41 BuildRequires:  nautilus-cd-burner-devel >= 2.16.0
42 BuildRequires:  pkgconfig
43 BuildRequires:  sqlite3-devel
44 Requires:       gstreamer-cdparanoia >= 0.10.3
45 Requires:       gstreamer-gnomevfs >= 0.10.3
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Banshee is a brand spankin' new audio player based on the GStreamer
50 media library and is developed on the Open Source Mono .NET Platform,
51 written in C#.
52
53 %description -l pl.UTF-8
54 Banshee to nowy odtwarzacz dźwięku oparty na bibliotece odtwarzacza
55 multimediów GStreamer, rozwijany na platformie .NET Mono, napisany w
56 C#.
57
58 %prep
59 %setup -q
60 %patch -p1
61
62 %build
63 %{__aclocal} -I build/m4/banshee -I build/m4/shamrock
64 %{__libtoolize}
65 %{__automake}
66 %{__autoconf}
67 %configure \
68         --disable-dev-tests \
69         --disable-helix \
70         --enable-ipod \
71         --enable-njb \
72         --disable-vlc \
73         --enable-gstreamer \
74         --enable-avahi \
75         --disable-schemas-install \
76         --disable-docs
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 #mv $RPM_BUILD_ROOT%{_docdir}/%{name}/* $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
87
88 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{la,a}
89
90 %find_lang %{name}
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post
96 %update_desktop_database_post
97 SCHEMAS="banshee-core.schemas banshee-interface.schemas banshee-plugin-audioscrobbler.schemas banshee-plugin-daap.schemas banshee-plugin-metadatasearcher.schemas banshee-plugin-minimode.schemas banshee-plugin-mmkeys.schemas banshee-plugin-notificationarea.schemas banshee-plugin-podcast.schemas banshee-plugin-radio.schemas banshee-plugin-recommendation.schemas"
98 for S in $SCHEMAS; do
99         %gconf_schema_install $S
100 done
101
102 %preun
103 SCHEMAS="banshee-core.schemas banshee-interface.schemas banshee-plugin-audioscrobbler.schemas banshee-plugin-daap.schemas banshee-plugin-metadatasearcher.schemas banshee-plugin-minimode.schemas banshee-plugin-mmkeys.schemas banshee-plugin-notificationarea.schemas banshee-plugin-podcast.schemas banshee-plugin-radio.schemas banshee-plugin-recommendation.schemas"
104 for S in $SCHEMAS; do
105         %gconf_schema_install $S
106 done
107
108 %postun
109 %update_desktop_database_postun
110
111 %files -f %{name}.lang
112 %defattr(644,root,root,755)
113 %doc AUTHORS COPYING ChangeLog NEWS README
114 %{_sysconfdir}/gconf/schemas/*.schemas
115 %attr(755,root,root) %{_bindir}/banshee
116 %{_datadir}/banshee
117 %{_pkgconfigdir}/banshee.pc
118 %dir %{_libdir}/banshee
119 %{_libdir}/banshee/*.dll
120 %attr(755,root,root) %{_libdir}/banshee/*.so
121 %{_libdir}/banshee/*.exe
122 %{_libdir}/banshee/*.mdb
123 %{_libdir}/banshee/*.config
124 %{_libdir}/banshee/Banshee.Dap
125 %{_libdir}/banshee/Banshee.MediaEngine
126 %{_libdir}/banshee/Banshee.Plugins
127 #%{_libdir}/monodoc/sources/*
128 %{_desktopdir}/banshee.desktop
129 %{_iconsdir}/hicolor/*/*/*
130 %{_datadir}/dbus-1/services/org.gnome.Banshee.service
This page took 0.043128 seconds and 4 git commands to generate.