]> git.pld-linux.org Git - packages/banshee.git/blob - banshee.spec
265708bb6b23c35f7034d4a4a60cf85b0f560f41
[packages/banshee.git] / banshee.spec
1 #
2 %include /usr/lib/rpm/macros.mono
3 #
4 Summary:        A Mono/GStreamer Based Music Player
5 Summary(pl.UTF-8):      Oparty na Mono/GStreamerze odtwarzacz muzyki
6 Name:           banshee
7 Version:        1.4.0
8 Release:        1
9 License:        GPL
10 Group:          Applications/Multimedia
11 Source0:        http://download.banshee-project.org/banshee/%{name}-1-%{version}.tar.bz2
12 # Source0-md5:  0779dba8e0608d19fa1f4424fc26a557
13 URL:            http://banshee-project.org/
14 BuildRequires:  GConf2-devel
15 BuildRequires:  dbus-devel >= 0.93
16 BuildRequires:  dbus-glib-devel >= 0.71
17 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
18 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
19 BuildRequires:  dotnet-ipod-sharp-devel >= 0.8.1
20 BuildRequires:  dotnet-libgphoto2-sharp-devel
21 BuildRequires:  dotnet-mono-zeroconf-devel
22 BuildRequires:  dotnet-njb-sharp
23 BuildRequires:  gnome-desktop-devel >= 2.16.0
24 BuildRequires:  gstreamer-GConf >= 0.10.3
25 BuildRequires:  gstreamer-cdparanoia
26 BuildRequires:  gstreamer-devel >= 0.10.3
27 BuildRequires:  gstreamer-gnomevfs
28 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.3
29 BuildRequires:  gtk+2-devel >= 2:2.10.3
30 BuildRequires:  hal-devel >= 0.5.2
31 BuildRequires:  intltool >= 0.35
32 BuildRequires:  libmtp-devel >= 0.2.0
33 BuildRequires:  libmusicbrainz-devel >= 2.1.1
34 BuildRequires:  mono-addins-devel >= 0.3.1-2
35 BuildRequires:  mono-csharp >= 1.1.13
36 BuildRequires:  monodoc
37 BuildRequires:  nautilus-cd-burner-devel >= 2.16.0
38 BuildRequires:  pkgconfig
39 BuildRequires:  sqlite3-devel
40 BuildRequires:  taglib-sharp-devel
41 Requires:       dotnet-ipod-sharp >= 0.8.0
42 Requires:       gstreamer-GConf >= 0.10.3
43 Requires:       gstreamer-cdparanoia >= 0.10.3
44 Requires:       gstreamer-gnomevfs >= 0.10.3
45 Obsoletes:      banshee-official-plugins <= 0.11.3
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Banshee is a brand spankin' new audio player based on the GStreamer
50 media library and is developed on the Open Source Mono .NET Platform,
51 written in C#.
52
53 %description -l pl.UTF-8
54 Banshee to nowy odtwarzacz dźwięku oparty na bibliotece odtwarzacza
55 multimediów GStreamer, rozwijany na platformie .NET Mono, napisany w
56 C#.
57
58 %prep
59 %setup -q -n %{name}-1-%{version}
60
61 %build
62 %{__intltoolize}
63 %{__aclocal} -I build/m4/banshee -I build/m4/shamrock
64 %configure \
65         --disable-boo \
66         --disable-dev-tests \
67         --disable-helix \
68         --enable-ipod \
69         --enable-njb \
70         --disable-vlc \
71         --enable-gstreamer \
72         --enable-avahi \
73         --disable-docs
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 #mv $RPM_BUILD_ROOT%{_docdir}/%{name}/* $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
84
85 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-1/*.{la,a}
86 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-1/Backends/*.{la,a}
87 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-1/gstreamer-0.10/*.{la,a}
88
89 %find_lang %{name}-1
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post
95 %update_desktop_database_post
96 %update_icon_cache hicolor
97
98 %postun
99 %update_desktop_database_postun
100 %update_icon_cache hicolor
101
102 %files -f %{name}-1.lang
103 %defattr(644,root,root,755)
104 %doc AUTHORS COPYING ChangeLog NEWS README
105 %attr(755,root,root) %{_bindir}/banshee-1
106 %{_datadir}/banshee-1
107 %{_pkgconfigdir}/banshee-1*.pc
108 %dir %{_libdir}/banshee-1
109 %{_libdir}/banshee-1/*.dll
110 %attr(755,root,root) %{_libdir}/banshee-1/*.so
111 %{_libdir}/banshee-1/*.exe
112 %{_libdir}/banshee-1/*.mdb
113 %{_libdir}/banshee-1/*.config
114 %dir %{_libdir}/banshee-1/Extensions
115 %{_libdir}/banshee-1/Extensions/*.dll
116 %{_libdir}/banshee-1/Extensions/*.mdb
117 %{_libdir}/banshee-1/Extensions/Banshee.NotificationArea.dll.config
118 %dir %{_libdir}/banshee-1/Backends
119 %{_libdir}/banshee-1/Backends/*.config
120 %{_libdir}/banshee-1/Backends/*.dll
121 %{_libdir}/banshee-1/Backends/*.mdb
122 %{_libdir}/banshee-1/Backends/*.so
123 %{_libdir}/banshee-1/Banshee.Services.addins
124 %dir %{_libdir}/banshee-1/gstreamer-0.10
125 %{_libdir}/banshee-1/gstreamer-0.10/*.so
126 #%{_libdir}/banshee-1/libbanshee.a
127 #%{_libdir}/banshee-1/libbanshee.la
128 #%{_libdir}/monodoc/sources/*
129 %{_desktopdir}/banshee-1.desktop
130 %{_iconsdir}/hicolor/*/*/*
131 %{_datadir}/dbus-1/services/org.bansheeproject.Banshee.service
132 %{_datadir}/dbus-1/services/org.bansheeproject.CollectionIndexer.service
This page took 0.059734 seconds and 3 git commands to generate.