]> git.pld-linux.org Git - packages/banshee.git/blame - banshee.spec
- enable ipod support
[packages/banshee.git] / banshee.spec
CommitLineData
6a2b92cf 1# ToDo:
6a2b92cf 2# - make some proper bconds for other it
3#
4%include /usr/lib/rpm/macros.mono
5#
9bfc9d4c 6
7Summary: A Mono/GStreamer Based Music Player
d3491af3 8Summary(pl.UTF-8): Oparty na Mono/GStreamerze odtwarzacz muzyki
993a23b2 9Name: banshee
10Version: 0.12.1
519d628e 11Release: 0.3
993a23b2 12License: GPL
deaf5725 13Group: Applications/Multimedia
993a23b2 14Source0: http://banshee-project.org/files/banshee/%{name}-%{version}.tar.gz
15# Source0-md5: 6bcfe0a4ca92e6cce86244938f004b8c
96943633 16Patch0: %{name}-spurious_trailing_comma.patch
993a23b2 17URL: http://banshee-project.org/
46e669d5 18BuildRequires: GConf2-devel
19BuildRequires: autoconf >= 2.13
6a2b92cf 20BuildRequires: automake
df580da3 21BuildRequires: dbus-devel >= 0.93
22BuildRequires: dbus-glib-devel >= 0.71
6a2b92cf 23BuildRequires: dotnet-avahi-devel
df580da3 24BuildRequires: dotnet-gnome-sharp-devel >= 2.16.0
993a23b2 25BuildRequires: dotnet-gtk-sharp2-devel >= 2.10.0
519d628e 26BuildRequires: dotnet-ipod-sharp
df580da3 27BuildRequires: gnome-desktop-devel >= 2.16.0
cef649e0 28BuildRequires: gstreamer-cdparanoia
46e669d5 29BuildRequires: gstreamer-devel >= 0.10.3
cef649e0 30BuildRequires: gstreamer-gnomevfs
46e669d5 31BuildRequires: gstreamer-plugins-base-devel >= 0.10.3
df580da3 32BuildRequires: gtk+2-devel >= 2.10.3
6a2b92cf 33BuildRequires: hal-devel >= 0.5.2
df580da3 34BuildRequires: intltool >= 0.35
46e669d5 35BuildRequires: libmusicbrainz-devel >= 2.1.1
df580da3 36BuildRequires: libtool
cef649e0 37BuildRequires: mono-csharp >= 1.1.13
c4237635 38BuildRequires: monodoc
df580da3 39BuildRequires: nautilus-cd-burner-devel >= 2.16.0
6a2b92cf 40BuildRequires: pkgconfig
41BuildRequires: sqlite3-devel
46e669d5 42Requires: gstreamer-cdparanoia >= 0.10.3
43Requires: gstreamer-gnomevfs >= 0.10.3
c4237635 44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9bfc9d4c 45
46%description
c4237635
JB
47Banshee is a brand spankin' new audio player based on the GStreamer
48media library and is developed on the Open Source Mono .NET Platform,
9bfc9d4c 49written in C#.
50
55c7d2aa
JR
51%description -l pl.UTF-8
52Banshee to nowy odtwarzacz dźwięku oparty na bibliotece odtwarzacza
53multimediów GStreamer, rozwijany na platformie .NET Mono, napisany w
c4237635
JB
54C#.
55
9bfc9d4c 56%prep
57%setup -q
96943633 58%patch -p1
9bfc9d4c 59
60%build
993a23b2 61%{__aclocal} -I build/m4/banshee -I build/m4/shamrock
46e669d5 62%{__libtoolize}
63%{__automake}
64%{__autoconf}
c4237635 65%configure \
c4237635 66 --disable-dev-tests \
6a2b92cf 67 --disable-helix \
519d628e 68 --enable-ipod \
c4237635
JB
69 --disable-njb \
70 --disable-vlc \
46e669d5 71 --enable-gstreamer \
72 --enable-avahi \
df580da3 73 --disable-schemas-install \
74 --disable-docs
9bfc9d4c 75%{__make}
76
77%install
78rm -rf $RPM_BUILD_ROOT
46e669d5 79install -d $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
9bfc9d4c 80
9bfc9d4c 81%{__make} install \
82 DESTDIR=$RPM_BUILD_ROOT
46e669d5 83
df580da3 84#mv $RPM_BUILD_ROOT%{_docdir}/%{name}/* $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
46e669d5 85
86rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{la,a}
87
9bfc9d4c 88%find_lang %{name}
89
c4237635
JB
90%clean
91rm -rf $RPM_BUILD_ROOT
92
9bfc9d4c 93%post
993a23b2 94%update_desktop_database_post
95SCHEMAS="banshee-core.schemas banshee-interface.schemas banshee-plugin-audioscrobbler.schemas banshee-plugin-daap.schemas banshee-plugin-metadatasearcher.schemas banshee-plugin-minimode.schemas banshee-plugin-mmkeys.schemas banshee-plugin-notificationarea.schemas banshee-plugin-podcast.schemas banshee-plugin-radio.schemas banshee-plugin-recommendation.schemas"
6a2b92cf 96for S in $SCHEMAS; do
97 %gconf_schema_install $S
98done
99
100%preun
993a23b2 101SCHEMAS="banshee-core.schemas banshee-interface.schemas banshee-plugin-audioscrobbler.schemas banshee-plugin-daap.schemas banshee-plugin-metadatasearcher.schemas banshee-plugin-minimode.schemas banshee-plugin-mmkeys.schemas banshee-plugin-notificationarea.schemas banshee-plugin-podcast.schemas banshee-plugin-radio.schemas banshee-plugin-recommendation.schemas"
9bfc9d4c 102for S in $SCHEMAS; do
6a2b92cf 103 %gconf_schema_install $S
9bfc9d4c 104done
105
106%postun
993a23b2 107%update_desktop_database_postun
9bfc9d4c 108
109%files -f %{name}.lang
c4237635 110%defattr(644,root,root,755)
993a23b2 111%doc AUTHORS COPYING ChangeLog NEWS README
112%{_sysconfdir}/gconf/schemas/*.schemas
c4237635 113%attr(755,root,root) %{_bindir}/banshee
993a23b2 114%{_datadir}/banshee
c4237635
JB
115%{_pkgconfigdir}/banshee.pc
116%dir %{_libdir}/banshee
9bfc9d4c 117%{_libdir}/banshee/*.dll
c4237635 118%attr(755,root,root) %{_libdir}/banshee/*.so
9bfc9d4c 119%{_libdir}/banshee/*.exe
120%{_libdir}/banshee/*.mdb
121%{_libdir}/banshee/*.config
df580da3 122%{_libdir}/banshee/Banshee.Dap
c4237635
JB
123%{_libdir}/banshee/Banshee.MediaEngine
124%{_libdir}/banshee/Banshee.Plugins
df580da3 125#%{_libdir}/monodoc/sources/*
c4237635
JB
126%{_desktopdir}/banshee.desktop
127%{_iconsdir}/hicolor/*/*/*
9bfc9d4c 128%{_datadir}/dbus-1/services/org.gnome.Banshee.service
This page took 0.084546 seconds and 4 git commands to generate.