]> git.pld-linux.org Git - packages/banshee.git/blob - banshee.spec
- enable ipod support
[packages/banshee.git] / banshee.spec
1 # ToDo:
2 #       - make some proper bconds for other it
3 #
4 %include /usr/lib/rpm/macros.mono
5 #
6
7 Summary:        A Mono/GStreamer Based Music Player
8 Summary(pl.UTF-8):      Oparty na Mono/GStreamerze odtwarzacz muzyki
9 Name:           banshee
10 Version:        0.12.1
11 Release:        0.3
12 License:        GPL
13 Group:          Applications/Multimedia
14 Source0:        http://banshee-project.org/files/banshee/%{name}-%{version}.tar.gz
15 # Source0-md5:  6bcfe0a4ca92e6cce86244938f004b8c
16 Patch0:         %{name}-spurious_trailing_comma.patch
17 URL:            http://banshee-project.org/
18 BuildRequires:  GConf2-devel
19 BuildRequires:  autoconf >= 2.13
20 BuildRequires:  automake
21 BuildRequires:  dbus-devel >= 0.93
22 BuildRequires:  dbus-glib-devel >= 0.71
23 BuildRequires:  dotnet-avahi-devel
24 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
25 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10.0
26 BuildRequires:  dotnet-ipod-sharp
27 BuildRequires:  gnome-desktop-devel >= 2.16.0
28 BuildRequires:  gstreamer-cdparanoia
29 BuildRequires:  gstreamer-devel >= 0.10.3
30 BuildRequires:  gstreamer-gnomevfs
31 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.3
32 BuildRequires:  gtk+2-devel >= 2.10.3
33 BuildRequires:  hal-devel >= 0.5.2
34 BuildRequires:  intltool >= 0.35
35 BuildRequires:  libmusicbrainz-devel >= 2.1.1
36 BuildRequires:  libtool
37 BuildRequires:  mono-csharp >= 1.1.13
38 BuildRequires:  monodoc
39 BuildRequires:  nautilus-cd-burner-devel >= 2.16.0
40 BuildRequires:  pkgconfig
41 BuildRequires:  sqlite3-devel
42 Requires:       gstreamer-cdparanoia >= 0.10.3
43 Requires:       gstreamer-gnomevfs >= 0.10.3
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Banshee is a brand spankin' new audio player based on the GStreamer
48 media library and is developed on the Open Source Mono .NET Platform,
49 written in C#.
50
51 %description -l pl.UTF-8
52 Banshee to nowy odtwarzacz dźwięku oparty na bibliotece odtwarzacza
53 multimediów GStreamer, rozwijany na platformie .NET Mono, napisany w
54 C#.
55
56 %prep
57 %setup -q
58 %patch -p1
59
60 %build
61 %{__aclocal} -I build/m4/banshee -I build/m4/shamrock
62 %{__libtoolize}
63 %{__automake}
64 %{__autoconf}
65 %configure \
66         --disable-dev-tests \
67         --disable-helix \
68         --enable-ipod \
69         --disable-njb \
70         --disable-vlc \
71         --enable-gstreamer \
72         --enable-avahi \
73         --disable-schemas-install \
74         --disable-docs
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 #mv $RPM_BUILD_ROOT%{_docdir}/%{name}/* $RPM_BUILD_ROOT%{_libdir}/monodoc/sources
85
86 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{la,a}
87
88 %find_lang %{name}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 %update_desktop_database_post
95 SCHEMAS="banshee-core.schemas banshee-interface.schemas banshee-plugin-audioscrobbler.schemas banshee-plugin-daap.schemas banshee-plugin-metadatasearcher.schemas banshee-plugin-minimode.schemas banshee-plugin-mmkeys.schemas banshee-plugin-notificationarea.schemas banshee-plugin-podcast.schemas banshee-plugin-radio.schemas banshee-plugin-recommendation.schemas"
96 for S in $SCHEMAS; do
97         %gconf_schema_install $S
98 done
99
100 %preun
101 SCHEMAS="banshee-core.schemas banshee-interface.schemas banshee-plugin-audioscrobbler.schemas banshee-plugin-daap.schemas banshee-plugin-metadatasearcher.schemas banshee-plugin-minimode.schemas banshee-plugin-mmkeys.schemas banshee-plugin-notificationarea.schemas banshee-plugin-podcast.schemas banshee-plugin-radio.schemas banshee-plugin-recommendation.schemas"
102 for S in $SCHEMAS; do
103         %gconf_schema_install $S
104 done
105
106 %postun
107 %update_desktop_database_postun
108
109 %files -f %{name}.lang
110 %defattr(644,root,root,755)
111 %doc AUTHORS COPYING ChangeLog NEWS README
112 %{_sysconfdir}/gconf/schemas/*.schemas
113 %attr(755,root,root) %{_bindir}/banshee
114 %{_datadir}/banshee
115 %{_pkgconfigdir}/banshee.pc
116 %dir %{_libdir}/banshee
117 %{_libdir}/banshee/*.dll
118 %attr(755,root,root) %{_libdir}/banshee/*.so
119 %{_libdir}/banshee/*.exe
120 %{_libdir}/banshee/*.mdb
121 %{_libdir}/banshee/*.config
122 %{_libdir}/banshee/Banshee.Dap
123 %{_libdir}/banshee/Banshee.MediaEngine
124 %{_libdir}/banshee/Banshee.Plugins
125 #%{_libdir}/monodoc/sources/*
126 %{_desktopdir}/banshee.desktop
127 %{_iconsdir}/hicolor/*/*/*
128 %{_datadir}/dbus-1/services/org.gnome.Banshee.service
This page took 0.063263 seconds and 4 git commands to generate.