]> git.pld-linux.org Git - packages/bacula.git/commitdiff
- patch to build with openssl-1.0.0 auto/th/bacula-5_0_1-3
authorJacek Konieczny <jajcus@pld-linux.org>
Wed, 21 Apr 2010 19:38:47 +0000 (19:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- Release: 3

Changed files:
    bacula-openssl1.patch -> 1.1
    bacula.spec -> 1.135

bacula-openssl1.patch [new file with mode: 0644]
bacula.spec

diff --git a/bacula-openssl1.patch b/bacula-openssl1.patch
new file mode 100644 (file)
index 0000000..be40335
--- /dev/null
@@ -0,0 +1,38 @@
+diff -durN bacula-5.0.1.orig/src/lib/crypto.c bacula-5.0.1/src/lib/crypto.c
+--- bacula-5.0.1.orig/src/lib/crypto.c 2010-02-24 16:33:48.000000000 +0100
++++ bacula-5.0.1/src/lib/crypto.c      2010-04-21 20:50:32.587691290 +0200
+@@ -49,6 +47,13 @@
+ #include "jcr.h"
+ #include <assert.h>
++/**
++ * For OpenSSL version 1.x, EVP_PKEY_encrypt no longer
++ *  exists.  It was not an official API.
++ */
++#define EVP_PKEY_encrypt EVP_PKEY_encrypt_old
++#define EVP_PKEY_decrypt EVP_PKEY_decrypt_old
++
+ /*
+  * Bacula ASN.1 Syntax
+  *
+@@ -309,7 +316,7 @@
+  */
+ static ASN1_OCTET_STRING *openssl_cert_keyid(X509 *cert) {
+    X509_EXTENSION *ext;
+-   X509V3_EXT_METHOD *method;
++   const X509V3_EXT_METHOD *method;
+    ASN1_OCTET_STRING *keyid;
+    int i;
+ #if (OPENSSL_VERSION_NUMBER >= 0x0090800FL)
+diff -durN bacula-5.0.1.orig/src/lib/tls.c bacula-5.0.1/src/lib/tls.c
+--- bacula-5.0.1.orig/src/lib/tls.c    2010-02-24 16:33:48.000000000 +0100
++++ bacula-5.0.1/src/lib/tls.c 2010-04-21 20:50:32.589983312 +0200
+@@ -315,7 +315,7 @@
+          extname = OBJ_nid2sn(OBJ_obj2nid(X509_EXTENSION_get_object(ext)));
+          if (strcmp(extname, "subjectAltName") == 0) {
+-            X509V3_EXT_METHOD *method;
++            const X509V3_EXT_METHOD *method;
+             STACK_OF(CONF_VALUE) *val;
+             CONF_VALUE *nval;
+             void *extstr = NULL;
index fdc497df4a691a4c13db38c596dd4b1c47a26d75..b3fbbdcd58f257f34b7843937e911ad326e114e9 100644 (file)
@@ -22,7 +22,7 @@ Summary:      Bacula - The Network Backup Solution
 Summary(pl.UTF-8):     Bacula - rozwiązanie do wykonywania kopii zapasowych po sieci
 Name:          bacula
 Version:       5.0.1
-Release:       2
+Release:       3
 Epoch:         0
 License:       extended GPL v2
 Group:         Networking/Utilities
@@ -48,6 +48,7 @@ Patch5:               %{name}-desktop.patch
 Patch6:                %{name}-64bitbuild_fix.patch
 Patch7:                %{name}-dbi_fixes.patch
 Patch8:                %{name}-dbi_dbcheck.patch
+Patch9:                %{name}-openssl1.patch
 URL:           http://www.bacula.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf
@@ -450,6 +451,7 @@ ratunkowe do odtwarzania systemu od zera.
 #%patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 
 tar -xf %{SOURCE2} && ln -s bacula-rescue-* rescue
 
This page took 0.036839 seconds and 4 git commands to generate.