]> git.pld-linux.org Git - packages/babychess.git/commitdiff
- fix build issue
authorMarcin Krzyżanowski <marcin.krzyzanowski@hakore.com>
Thu, 9 Oct 2003 22:10:54 +0000 (22:10 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix desktop entries
- fix destination dir installation

Changed files:
    babychess-buildfix.patch -> 1.1
    babychess-desktop.patch -> 1.1
    babychess-destdir.patch -> 1.1

babychess-buildfix.patch [new file with mode: 0644]
babychess-desktop.patch [new file with mode: 0644]
babychess-destdir.patch [new file with mode: 0644]

diff --git a/babychess-buildfix.patch b/babychess-buildfix.patch
new file mode 100644 (file)
index 0000000..a5e38c0
--- /dev/null
@@ -0,0 +1,16 @@
+diff -Nuard babychess-14.1.orig/src/evaluator_widget.cc babychess-14.1/src/evaluator_widget.cc
+--- babychess-14.1.orig/src/evaluator_widget.cc        2003-03-16 14:10:55.000000000 +0100
++++ babychess-14.1/src/evaluator_widget.cc     2003-10-09 23:52:26.000000000 +0200
+@@ -169,10 +169,12 @@
+ {
+       Dbg_Function();
++/*
+       if (IO_Child_Process::Is())
+               Terminate();
+       if (Timer::Is())
+               Timer::Stop();
++*/
+       Evaluator::Close();
+       settings_editor.Close();
diff --git a/babychess-desktop.patch b/babychess-desktop.patch
new file mode 100644 (file)
index 0000000..f494228
--- /dev/null
@@ -0,0 +1,59 @@
+diff -Nuard babychess-14.1.orig/sh/install babychess-14.1/sh/install
+--- babychess-14.1.orig/sh/install     2003-03-16 14:10:54.000000000 +0100
++++ babychess-14.1/sh/install  2003-10-09 23:32:09.000000000 +0200
+@@ -111,8 +111,9 @@
+               echo "Name=$prog_name"
+               echo "Comment=`grep '/\* *Comment: *[^\*]*\*/' < src/$program.cc | $sed 's/\/\* *Comment: *\([^\*]*\) *\*\//\1/'`"
+               echo "Exec=$install_dir/bin/baby_$program"
+-              echo "Terminal=0"
++              echo "Terminal=false"
+               echo "Type=Application"
++              echo "Categories=Application;Game;BoardGame;"
+               icon_name=`grep '/\* *Icon: *[^\*]*\*/' < src/$program.cc | \
+                           $sed 's/\/\* *Icon: *\([^\* ]*\) *\*\//\1/'`
+               if [ -z "$icon" ] ; then icon=baby ; fi
+diff -Nuard babychess-14.1.orig/src/gui_about.cc babychess-14.1/src/gui_about.cc
+--- babychess-14.1.orig/src/gui_about.cc       2003-03-16 14:10:58.000000000 +0100
++++ babychess-14.1/src/gui_about.cc    2003-10-09 23:46:29.000000000 +0200
+@@ -1,4 +1,4 @@
+-/* Name:     About Baby               */
++/* Name:     About BabyChess               */
+ /* Comment:  Info about Baby programs */
+ /* Icon:     chess                    */
+diff -Nuard babychess-14.1.orig/src/gui_game_archive.cc babychess-14.1/src/gui_game_archive.cc
+--- babychess-14.1.orig/src/gui_game_archive.cc        2003-03-16 14:10:54.000000000 +0100
++++ babychess-14.1/src/gui_game_archive.cc     2003-10-09 23:46:03.000000000 +0200
+@@ -1,4 +1,4 @@
+-/* Name:     New Chess Game Archive   */
++/* Name:     BabyChess Game Archive   */
+ /* Comment:  Edit chess game archives */
+ /* Icon:     chess                    */
+ /* MimeType:   application/x-pgn      */
+diff -Nuard babychess-14.1.orig/src/gui_game.cc babychess-14.1/src/gui_game.cc
+--- babychess-14.1.orig/src/gui_game.cc        2003-03-16 14:10:54.000000000 +0100
++++ babychess-14.1/src/gui_game.cc     2003-10-09 23:46:17.000000000 +0200
+@@ -1,4 +1,4 @@
+-/* Name:       New Chess Game      */
++/* Name:       BabyChess Game      */
+ /* Comment:    Edit chess games    */
+ /* Icon:       chess               */
+diff -Nuard babychess-14.1.orig/src/gui_ics.cc babychess-14.1/src/gui_ics.cc
+--- babychess-14.1.orig/src/gui_ics.cc 2003-03-16 14:10:54.000000000 +0100
++++ babychess-14.1/src/gui_ics.cc      2003-10-09 23:46:40.000000000 +0200
+@@ -1,4 +1,4 @@
+-/* Name:     Internet Chess Server   */
++/* Name:     BabyChess Server   */
+ /* Comment:  Play chess over the net */
+ /* Icon:     ics                     */
+diff -Nuard babychess-14.1.orig/src/gui_position.cc babychess-14.1/src/gui_position.cc
+--- babychess-14.1.orig/src/gui_position.cc    2003-03-16 14:10:54.000000000 +0100
++++ babychess-14.1/src/gui_position.cc 2003-10-09 23:45:55.000000000 +0200
+@@ -1,4 +1,4 @@
+-/* Name:        New Chess Position   */
++/* Name:        BabyChess Position   */
+ /* Comment:     Edit chess positions */
+ /* MimeType:    application/x-fen    */
+ /* Icon:        chess                */
diff --git a/babychess-destdir.patch b/babychess-destdir.patch
new file mode 100644 (file)
index 0000000..877b8cf
--- /dev/null
@@ -0,0 +1,9 @@
+diff -Nuard babychess-14.1.orig/Makefile babychess-14.1/Makefile
+--- babychess-14.1.orig/Makefile       2003-03-16 14:11:00.000000000 +0100
++++ babychess-14.1/Makefile    2003-10-09 23:01:21.000000000 +0200
+@@ -72,4 +72,4 @@
+ clean:
+       sh/clean
+ install:
+-      groups=chess install_dir=$(install_dir) skip_home=$(skip_home) sh/install
++      groups=chess install_dir=$(install_dir) install_root=$(DESTDIR) skip_home=$(skip_home) sh/install
This page took 0.14063 seconds and 4 git commands to generate.