]> git.pld-linux.org Git - packages/babeltrace2.git/blob - babeltrace2.spec
- updated to 2.0.6
[packages/babeltrace2.git] / babeltrace2.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 %bcond_without  python  # Python binding
5 #
6 Summary:        Trace Format Babel Tower
7 Summary(pl.UTF-8):      Wieża Babel formatów narzędzi śledzących
8 Name:           babeltrace2
9 Version:        2.0.6
10 Release:        1
11 License:        MIT
12 Group:          Applications/System
13 Source0:        https://www.efficios.com/files/babeltrace/%{name}-%{version}.tar.bz2
14 # Source0-md5:  cb3685e60672d014148e3337eeb6ef8d
15 Patch0:         %{name}-python.patch
16 URL:            https://babeltrace.org/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1:1.12
19 %{?with_apidocs:BuildRequires:  doxygen}
20 BuildRequires:  elfutils-devel >= 0.154
21 BuildRequires:  glib2-devel >= 1:2.28.0
22 BuildRequires:  libtool >= 2:2
23 BuildRequires:  libuuid-devel
24 BuildRequires:  pkgconfig
25 BuildRequires:  popt-devel
26 %{?with_python:BuildRequires:   python3-devel >= 1:3.2}
27 BuildRequires:  rpm-build >= 4.6
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.507
30 BuildRequires:  swig-python >= 2.0.0
31 Requires:       elfutils >= 0.154
32 Requires:       glib2 >= 1:2.28.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This project provides trace read and write libraries, as well as a
37 trace converter. A plugin can be created for any trace format to allow
38 its conversion to/from another trace format.
39
40 %description -l pl.UTF-8
41 Ten projekt udostępnia biblioteki do odczytu i zapisu śladów, a także
42 konwerter śladów. Można tworzyć wtyczki dla dowolnego formatu śladów,
43 aby umożliwić konwersję do/z innego formatu.
44
45 %package devel
46 Summary:        Header files for Babeltrace libraries
47 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Babeltrace
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       elfutils-devel >= 0.154
51 Requires:       glib2-devel >= 1:2.28.0
52 Requires:       libuuid-devel
53 Requires:       popt-devel
54
55 %description devel
56 Header files for Babeltrace libraries.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe bibliotek Babeltrace.
60
61 %package static
62 Summary:        Static Babeltrace 2 libraries
63 Summary(pl.UTF-8):      Statyczne biblioteki Babeltrace 2
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static Babeltrace 2 libraries.
69
70 %description static -l pl.UTF-8
71 Statyczne biblioteki Babeltrace 2.
72
73 %package apidocs
74 Summary:        API documentation for Babeltrace 2 libraries
75 Summary(pl.UTF-8):      Dokumentacja API bibliotek Babeltrace 2
76 Group:          Documentation
77 BuildArch:      noarch
78
79 %description apidocs
80 API documentation for Babeltrace 2 libraries.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API bibliotek Babeltrace 2.
84
85 %package -n python3-babeltrace2
86 Summary:        Python 3 binding to Babeltrace 2 library
87 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki Babeltrace 2
88 Group:          Libraries/Python
89 Requires:       %{name} = %{version}-%{release}
90
91 %description -n python3-babeltrace2
92 Python 3 binding to Babeltrace 2 library.
93
94 %description -n python3-babeltrace2 -l pl.UTF-8
95 Wiązanie Pythona 3 do biblioteki Babeltrace 2.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100
101 %build
102 %{__libtoolize}
103 %{__aclocal} -I m4
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         %{?with_apidocs:--enable-api-doc} \
109         %{?with_python:--enable-python-bindings} \
110         --disable-silent-rules
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %{__rm} $RPM_BUILD_ROOT%{_libdir}/babeltrace2/plugins/*.{la,a}
120 # obsoleted by pkg-config
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
122
123 # packaged as %doc
124 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/babeltrace2
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc ChangeLog LICENSE README.adoc mit-license.txt std-ext-lib.txt
135 %attr(755,root,root) %{_bindir}/babeltrace2
136 %attr(755,root,root) %{_libdir}/libbabeltrace2.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace2.so.0
138 %attr(755,root,root) %{_libdir}/libbabeltrace2-ctf-writer.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace2-ctf-writer.so.0
140 %dir %{_libdir}/babeltrace2
141 %dir %{_libdir}/babeltrace2/plugins
142 %attr(755,root,root) %{_libdir}/babeltrace2/plugins/babeltrace-plugin-ctf.so
143 %attr(755,root,root) %{_libdir}/babeltrace2/plugins/babeltrace-plugin-lttng-utils.so
144 %attr(755,root,root) %{_libdir}/babeltrace2/plugins/babeltrace-plugin-text.so
145 %attr(755,root,root) %{_libdir}/babeltrace2/plugins/babeltrace-plugin-utils.so
146 %{_mandir}/man1/babeltrace2.1*
147 %{_mandir}/man1/babeltrace2-convert.1*
148 %{_mandir}/man1/babeltrace2-help.1*
149 %{_mandir}/man1/babeltrace2-list-plugins.1*
150 %{_mandir}/man1/babeltrace2-query.1*
151 %{_mandir}/man1/babeltrace2-run.1*
152 %{_mandir}/man7/babeltrace2*.7*
153
154 %files devel
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/libbabeltrace2.so
157 %attr(755,root,root) %{_libdir}/libbabeltrace2-ctf-writer.so
158 %{_includedir}/babeltrace2
159 %{_includedir}/babeltrace2-ctf-writer
160 %{_pkgconfigdir}/babeltrace2.pc
161 %{_pkgconfigdir}/babeltrace2-ctf-writer.pc
162
163 %files static
164 %defattr(644,root,root,755)
165 %{_libdir}/libbabeltrace2.a
166 %{_libdir}/libbabeltrace2-ctf-writer.a
167
168 %if %{with apidocs}
169 %files apidocs
170 %defattr(644,root,root,755)
171 %doc doc/api/libbabeltrace2/output/html/{search,*.css,*.html,*.js,*.png}
172 %endif
173
174 %if %{with python}
175 %files -n python3-babeltrace2
176 %defattr(644,root,root,755)
177 %dir %{py3_sitedir}/bt2
178 %attr(755,root,root) %{py3_sitedir}/bt2/_native_bt.cpython-*.so
179 %{py3_sitedir}/bt2/*.py
180 %{py3_sitedir}/bt2/__pycache__
181 %{py3_sitedir}/bt2-%{version}-py*.egg-info
182 %endif
This page took 0.194805 seconds and 4 git commands to generate.