]> git.pld-linux.org Git - packages/babeltrace.git/blob - babeltrace.spec
BR: swig-python for python bindings
[packages/babeltrace.git] / babeltrace.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # Python binding
4 #
5 Summary:        Trace Format Babel Tower
6 Summary(pl.UTF-8):      Wieża Babel formatów narzędzi śledzących
7 Name:           babeltrace
8 # keep 1.x here, babeltrace2 is separate project (see babeltrace2.spec)
9 Version:        1.5.11
10 Release:        1
11 License:        MIT
12 Group:          Applications/System
13 Source0:        https://www.efficios.com/files/babeltrace/%{name}-%{version}.tar.bz2
14 # Source0-md5:  ca6b23633a78d3dbcc2aec2cbdc99838
15 Patch0:         %{name}-python.patch
16 URL:            https://babeltrace.org/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  elfutils-devel >= 0.154
20 BuildRequires:  glib2-devel >= 1:2.22.0
21 BuildRequires:  libtool >= 2:2
22 BuildRequires:  libuuid-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  popt-devel
25 %{?with_python:BuildRequires:   python3-devel >= 1:3.2}
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.507
28 %{?with_python:BuildRequires:   swig-python >= 2.0.0}
29 Requires:       elfutils >= 0.154
30 Requires:       glib2 >= 1:2.22.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This project provides trace read and write libraries, as well as a
35 trace converter. A plugin can be created for any trace format to allow
36 its conversion to/from another trace format.
37
38 %description -l pl.UTF-8
39 Ten projekt udostępnia biblioteki do odczytu i zapisu śladów, a także
40 konwerter śladów. Można tworzyć wtyczki dla dowolnego formatu śladów,
41 aby umożliwić konwersję do/z innego formatu.
42
43 %package devel
44 Summary:        Header files for Babeltrace libraries
45 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Babeltrace
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       elfutils-devel >= 0.154
49 Requires:       glib2-devel >= 1:2.22.0
50 Requires:       libuuid-devel
51 Requires:       popt-devel
52
53 %description devel
54 Header files for Babeltrace libraries.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe bibliotek Babeltrace.
58
59 %package static
60 Summary:        Static Babeltrace libraries
61 Summary(pl.UTF-8):      Statyczne biblioteki Babeltrace
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static Babeltrace libraries.
67
68 %description static -l pl.UTF-8
69 Statyczne biblioteki Babeltrace.
70
71 %package -n python3-babeltrace
72 Summary:        Python 3 binding to Babeltrace library
73 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki Babeltrace
74 Group:          Libraries/Python
75 Requires:       %{name} = %{version}-%{release}
76 Obsoletes:      python-babeltrace < 1.5.3
77
78 %description -n python3-babeltrace
79 Python 3 binding to Babeltrace library.
80
81 %description -n python3-babeltrace -l pl.UTF-8
82 Wiązanie Pythona 3 do biblioteki Babeltrace.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I m4
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         %{?with_python:--enable-python-bindings} \
96         --disable-silent-rules
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 # lib*.la kept - no .pc files for individual libraries
106
107 # packaged as %doc
108 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/babeltrace
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc ChangeLog LICENSE README std-ext-lib.txt
119 %attr(755,root,root) %{_bindir}/babeltrace
120 %attr(755,root,root) %{_bindir}/babeltrace-log
121 %attr(755,root,root) %{_libdir}/libbabeltrace.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace.so.1
123 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-ctf.so.1
125 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf-metadata.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-ctf-metadata.so.1
127 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf-text.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-ctf-text.so.1
129 %attr(755,root,root) %{_libdir}/libbabeltrace-dummy.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-dummy.so.1
131 %attr(755,root,root) %{_libdir}/libbabeltrace-lttng-live.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-lttng-live.so.1
133 %{_mandir}/man1/babeltrace.1*
134 %{_mandir}/man1/babeltrace-log.1*
135
136 %files devel
137 %defattr(644,root,root,755)
138 %doc doc/{API,development}.txt
139 %attr(755,root,root) %{_libdir}/libbabeltrace.so
140 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf.so
141 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf-metadata.so
142 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf-text.so
143 %attr(755,root,root) %{_libdir}/libbabeltrace-dummy.so
144 %attr(755,root,root) %{_libdir}/libbabeltrace-lttng-live.so
145 %{_libdir}/libbabeltrace.la
146 %{_libdir}/libbabeltrace-ctf.la
147 %{_libdir}/libbabeltrace-ctf-metadata.la
148 %{_libdir}/libbabeltrace-ctf-text.la
149 %{_libdir}/libbabeltrace-dummy.la
150 %{_libdir}/libbabeltrace-lttng-live.la
151 %{_includedir}/babeltrace
152 %{_pkgconfigdir}/babeltrace.pc
153 %{_pkgconfigdir}/babeltrace-ctf.pc
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libbabeltrace.a
158 %{_libdir}/libbabeltrace-ctf.a
159 %{_libdir}/libbabeltrace-ctf-metadata.a
160 %{_libdir}/libbabeltrace-ctf-text.a
161 %{_libdir}/libbabeltrace-dummy.a
162 %{_libdir}/libbabeltrace-lttng-live.a
163
164 %if %{with python}
165 %files -n python3-babeltrace
166 %defattr(644,root,root,755)
167 %dir %{py3_sitedir}/babeltrace
168 %attr(755,root,root) %{py3_sitedir}/babeltrace/_babeltrace.cpython-*.so
169 %{py3_sitedir}/babeltrace/*.py
170 %{py3_sitedir}/babeltrace/__pycache__
171 %{py3_sitedir}/babeltrace-%{version}-py*.egg-info
172 %endif
This page took 0.149323 seconds and 4 git commands to generate.