]> git.pld-linux.org Git - packages/axis.git/blob - axis.spec
- save (old)
[packages/axis.git] / axis.spec
1 # TODO
2 #  - castor is needed by axis-1.2.1-0.2jpp.1.noarch
3 %define archivever %(echo %{version} | tr . _)
4 Summary:        A SOAP implementation in Java
5 Summary(pl.UTF-8):      Implementacja SOAP w Javie
6 Name:           axis
7 Version:        1.2.1
8 Release:        0.3
9 License:        Apache Software License
10 Group:          Development/Languages/Java
11 Source0:        http://ws.apache.org/axis//dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
12 # Source0-md5:  157ad070accf373565bce80de1204a4d
13 URL:            http://ws.apache.org/axis/
14 BuildRequires:  ant >= 1.6
15 #BuildRequires: ant-nodeps
16 BuildRequires:  jdk
17 # Mandatory requires
18 BuildRequires:  jaf
19 BuildRequires:  jakarta-commons-discovery
20 BuildRequires:  jakarta-commons-httpclient3
21 BuildRequires:  jakarta-commons-logging
22 BuildRequires:  javamail
23 BuildRequires:  jaxp_parser_impl
24 BuildRequires:  jpackage-utils
25 BuildRequires:  logging-log4j
26 BuildRequires:  rpmbuild(macros) >= 1.300
27 BuildRequires:  servletapi5
28 BuildRequires:  wsdl4j
29 # optional requires
30 BuildRequires:  castor
31 BuildRequires:  httpunit
32 BuildRequires:  jakarta-oro
33 BuildRequires:  jimi
34 BuildRequires:  jms
35 BuildRequires:  jsse
36 BuildRequires:  junit
37 Requires:       jaf
38 Requires:       jakarta-commons-discovery
39 Requires:       jakarta-commons-httpclient3
40 Requires:       jakarta-commons-logging
41 Requires:       java
42 Requires:       javamail
43 Requires:       jaxp_parser_impl
44 Requires:       logging-log4j
45 Requires:       jpackage-utils
46 Requires:       log4j
47 Requires:       wsdl4j
48 BuildArch:      noarch
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Apache AXIS is an implementation of the SOAP ("Simple Object Access
53 Protocol") submission to W3C.
54
55 From the draft W3C specification:
56
57 SOAP is a lightweight protocol for exchange of information in a
58 decentralized, distributed environment. It is an XML based protocol
59 that consists of three parts: an envelope that defines a framework for
60 describing what is in a message and how to process it, a set of
61 encoding rules for expressing instances of application-defined
62 datatypes, and a convention for representing remote procedure calls
63 and responses.
64
65 This project is a follow-on to the Apache SOAP project.
66
67 %description -l pl.UTF-8
68 Apache AXIS to implementacja SOAP ("Simple Object Access Protocol")
69 przekazanego do W3C.
70
71 Z projektu specyfikacji W3C:
72
73 SOAP to lekki protokół do wymiany informacji w scentralizowanym,
74 rozproszonym środowisku. Jest to protokół oparty na XML-u, składający
75 się z trzech części: koperty definiującej szkielet do opisu zawartości
76 i sposobu przetwarzania komunikatu, zbioru reguł kodowania do
77 wyrażania instancji typów danych zdefiniowanych w aplikacji oraz
78 konwencji reprezentowania zdalnych wywołań procedur i odpowiedzi.
79
80 Ten projekt jest następcą projektu Apache SOAP.
81
82 %package javadoc
83 Summary:        Javadoc for %{name}
84 Summary(pl.UTF-8):      Dokumentacja javadoc dla pakietu %{name}
85 Group:          Documentation
86 Requires:       jpackage-utils
87
88 %description javadoc
89 Javadoc for %{name}.
90
91 %description javadoc -l pl.UTF-8
92 Dokumentacja javadoc dla pakietu %{name}.
93
94 %package manual
95 Summary:        Manual for %{name}
96 Summary(pl.UTF-8):      Podręcznik do pakietu %{name}
97 Group:          Development/Languages/Java
98
99 %description manual
100 Documentation for %{name}.
101
102 %description manual -l pl.UTF-8
103 Podręcznik do pakietu %{name}.
104
105 %prep
106 %setup -q -n %{name}-%{archivever}
107
108 # Remove provided binaries
109 find -name '*.jar' | xargs rm -v
110 find -name '*.zip' | xargs rm -v
111 find -name '*.class' | xargs rm -v
112
113 %build
114 export JAVA_HOME=%{java_home}
115
116 CLASSPATH=$(build-classpath wsdl4j jakarta-commons-discovery jakarta-commons-httpclient3 jakarta-commons-logging log4j jaf javamail/mailapi servletapi5)
117 export CLASSPATH=$CLASSPATH:$(build-classpath oro junit jimi xml-security jsse httpunit jms castor 2>/dev/null)
118
119 export OPT_JAR_LIST="ant/ant-nodeps"
120 %ant \
121         -Dcompile.ime=true \
122         -Dwsdl4j.jar=$(find-jar wsdl4j) \
123         -Dcommons-discovery.jar=$(find-jar jakarta-commons-discovery) \
124         -Dcommons-logging.jar=$(find-jar jakarta-commons-logging) \
125         -Dcommons-httpclient.jar=$(find-jar jakarta-commons-httpclient3) \
126         -Dlog4j-core.jar=$(find-jar log4j) \
127         -Dactivation.jar=$(find-jar jaf) \
128         -Dmailapi.jar=$(find-jar javamail/mailapi) \
129         -Dxerces.jar=$(find-jar jaxp_parser_impl) \
130         -Dservlet.jar=$(find-jar servletapi5) \
131         -Dregexp.jar=$(find-jar oro) \
132         -Djunit.jar=$(find-jar junit) \
133         -Djimi.jar=$(find-jar jimi) \
134         -Djsse.jar=$(find-jar jsse/jsse) \
135         clean compile javadocs
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 ### Jar files
140 install -d $RPM_BUILD_ROOT%{_javadir}/%{name}
141
142 cd build/lib
143 install axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
144         $RPM_BUILD_ROOT%{_javadir}/%{name}
145 cd -
146
147 cd $RPM_BUILD_ROOT%{_javadir}/%{name}
148 for jar in *.jar ; do
149         vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
150         mv $jar $vjar
151         ln -fs $vjar $jar
152 done
153 cd -
154
155 ### Javadoc
156 install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
157 cp -a build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
158 ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post javadoc
164 ln -nfs %{name}-%{version} %{_javadocdir}/%{name}
165
166 %files
167 %defattr(644,root,root,755)
168 %doc LICENSE README release-notes.html changelog.html
169 %dir %{_javadir}/%{name}
170 %{_javadir}/%{name}/*.jar
171
172 %files javadoc
173 %defattr(644,root,root,755)
174 %{_javadocdir}/%{name}-%{version}
175 %ghost %{_javadocdir}/%{name}
176
177 %files manual
178 %defattr(644,root,root,755)
179 %doc docs/*
This page took 0.11644 seconds and 3 git commands to generate.