]> git.pld-linux.org Git - packages/axis.git/blob - axis.spec
- s/jakarta-ant/ant/ in BR
[packages/axis.git] / axis.spec
1 # TODO
2 #  - servletapi5 is needed by axis-1.2.1-0.2jpp.1.noarch
3 #  - castor is needed by axis-1.2.1-0.2jpp.1.noarch
4 %define archivever %(echo %{version} | tr . _)
5 Summary:        A SOAP implementation in Java
6 Summary(pl):    Implementacja SOAP w Javie
7 Name:           axis
8 Version:        1.2.1
9 Release:        0.3
10 License:        Apache Software License
11 Group:          Development/Languages/Java
12 Source0:        http://ws.apache.org/axis//dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
13 # Source0-md5:  157ad070accf373565bce80de1204a4d
14 URL:            http://ws.apache.org/axis/
15 #BuildRequires: ant-nodeps
16 BuildRequires:  ant >= 1.6
17 BuildRequires:  jdk
18 # Mandatory requires
19 BuildRequires:  jaf
20 BuildRequires:  jakarta-commons-discovery
21 BuildRequires:  jakarta-commons-httpclient3
22 BuildRequires:  jakarta-commons-logging
23 BuildRequires:  jakarta-log4j
24 BuildRequires:  javamail
25 BuildRequires:  jaxp_parser_impl
26 BuildRequires:  servletapi5
27 BuildRequires:  wsdl4j
28 # optional requires
29 BuildRequires:  castor
30 BuildRequires:  httpunit
31 BuildRequires:  jakarta-oro
32 BuildRequires:  jimi
33 BuildRequires:  jms
34 BuildRequires:  jsse
35 BuildRequires:  junit
36 #BuildRequires: xml-security
37 Requires:       jaf
38 Requires:       jakarta-commons-discovery
39 Requires:       jakarta-commons-httpclient3
40 Requires:       jakarta-commons-logging
41 Requires:       java
42 Requires:       javamail
43 Requires:       jaxp_parser_impl
44 #Requires:      jpackage-utils >= 0:1.5
45 Requires:       log4j
46 Requires:       wsdl4j
47 BuildArch:      noarch
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Apache AXIS is an implementation of the SOAP ("Simple Object Access
52 Protocol") submission to W3C.
53
54 From the draft W3C specification:
55
56 SOAP is a lightweight protocol for exchange of information in a
57 decentralized, distributed environment. It is an XML based protocol
58 that consists of three parts: an envelope that defines a framework for
59 describing what is in a message and how to process it, a set of
60 encoding rules for expressing instances of application-defined
61 datatypes, and a convention for representing remote procedure calls
62 and responses.
63
64 This project is a follow-on to the Apache SOAP project.
65
66 %description -l pl
67 Apache AXIS to implementacja SOAP ("Simple Object Access Protocol")
68 przekazanego do W3C.
69
70 Z projektu specyfikacji W3C:
71
72 SOAP to lekki protokó³ do wymiany informacji w scentralizowanym,
73 rozproszonym ¶rodowisku. Jest to protokó³ oparty na XML-u, sk³adaj±cy
74 siê z trzech czê¶ci: koperty definiuj±cej szkielet do opisu zawarto¶ci
75 i sposobu przetwarzania komunikatu, zbioru regu³ kodowania do
76 wyra¿ania instancji typów danych zdefiniowanych w aplikacji oraz
77 konwencji reprezentowania zdalnych wywo³añ procedur i odpowiedzi.
78
79 Ten projekt jest nastêpc± projektu Apache SOAP.
80
81 %package javadoc
82 Summary:        Javadoc for %{name}
83 Summary(pl):    Dokumentacja javadoc dla pakietu %{name}
84 Group:          Development/Languages/Java
85
86 %description javadoc
87 Javadoc for %{name}.
88
89 %description javadoc -l pl
90 Dokumentacja javadoc dla pakietu %{name}.
91
92 %package manual
93 Summary:        Manual for %{name}
94 Summary(pl):    Podrêcznik do pakietu %{name}
95 Group:          Development/Languages/Java
96
97 %description manual
98 Documentation for %{name}.
99
100 %description manual -l pl
101 Podrêcznik do pakietu %{name}.
102
103 %prep
104 %setup -q -n %{name}-%{archivever}
105
106 # Remove provided binaries
107 find . -name "*.jar" -exec rm -f {} \;
108 find . -name "*.zip" -exec rm -f {} \;
109 find . -name "*.class" -exec rm -f {} \;
110
111 %build
112
113 [ -z "$JAVA_HOME" ] && export JAVA_HOME=%{_jvmdir}/java
114
115 CLASSPATH=$(build-classpath wsdl4j jakarta-commons-discovery jakarta-commons-httpclient3 jakarta-commons-logging log4j jaf javamail/mailapi servletapi5)
116 export CLASSPATH=$CLASSPATH:$(build-classpath oro junit jimi xml-security jsse httpunit jms castor 2>/dev/null)
117
118 export OPT_JAR_LIST="ant/ant-nodeps"
119 ant \
120         -Dcompile.ime=true \
121         -Dwsdl4j.jar=$(build-classpath wsdl4j) \
122         -Dcommons-discovery.jar=$(build-classpath jakarta-commons-discovery) \
123         -Dcommons-logging.jar=$(build-classpath jakarta-commons-logging) \
124         -Dcommons-httpclient.jar=$(build-classpath jakarta-commons-httpclient3) \
125         -Dlog4j-core.jar=$(build-classpath log4j) \
126         -Dactivation.jar=$(build-classpath jaf) \
127         -Dmailapi.jar=$(build-classpath javamail/mailapi) \
128         -Dxerces.jar=$(build-classpath jaxp_parser_impl) \
129         -Dservlet.jar=$(build-classpath servletapi5) \
130         -Dregexp.jar=$(build-classpath oro 2>/dev/null) \
131         -Djunit.jar=$(build-classpath junit 2>/dev/null) \
132         -Djimi.jar=$(build-classpath jimi 2>/dev/null) \
133         -Djsse.jar=$(build-classpath jsse/jsse 2>/dev/null) \
134         clean compile javadocs
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 ### Jar files
139
140 install -d $RPM_BUILD_ROOT%{_javadir}/%{name}
141
142 cd build/lib
143 install -m 644 axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
144         $RPM_BUILD_ROOT%{_javadir}/%{name}
145 cd -
146
147 cd $RPM_BUILD_ROOT%{_javadir}/%{name}
148 for jar in *.jar ; do
149         vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
150         mv $jar $vjar
151         ln -fs $vjar $jar
152 done
153 cd -
154
155 ### Javadoc
156
157 install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
158 cp -pr build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
159
160 cd docs
161 rm -fr apiDocs
162 ln -fs %{_javadocdir}/%{name} apiDocs
163 cd -
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post javadoc
169 rm -f %{_javadocdir}/%{name}
170 ln -s %{name}-%{version} %{_javadocdir}/%{name}
171
172 %postun javadoc
173 if [ "$1" = "0" ]; then
174         rm -f %{_javadocdir}/%{name}
175 fi
176
177 %files
178 %defattr(644,root,root,755)
179 %doc LICENSE README release-notes.html changelog.html
180 %dir %{_javadir}/%{name}
181 %{_javadir}/%{name}/*.jar
182
183 %files javadoc
184 %defattr(644,root,root,755)
185 %dir %{_javadocdir}/%{name}-%{version}
186 %{_javadocdir}/%{name}-%{version}/*
187
188 %files manual
189 %defattr(644,root,root,755)
190 %doc docs/*
This page took 0.086772 seconds and 3 git commands to generate.