]> git.pld-linux.org Git - packages/axel.git/commitdiff
- remove silly stripping,
authorkloczek <kloczek@pld-linux.org>
Tue, 6 Nov 2001 10:33:17 +0000 (10:33 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- use $(CC) instead directly gcc.

Changed files:
    axel-Makefile.patch -> 1.1

axel-Makefile.patch [new file with mode: 0644]

diff --git a/axel-Makefile.patch b/axel-Makefile.patch
new file mode 100644 (file)
index 0000000..5eda4e8
--- /dev/null
@@ -0,0 +1,31 @@
+--- axel-0.98/Makefile.orig    Sat Nov  3 19:28:39 2001
++++ axel-0.98/Makefile Tue Nov  6 11:32:21 2001
+@@ -12,6 +12,8 @@
+ include Makefile.settings
++CC=gcc
++
+ ifdef DEBUG
+ CFLAGS = -DDEBUG -g
+ else
+@@ -60,17 +62,10 @@
+ ### MAIN PROGRAM
+ axel: axel.o conf.o conn.o ftp.o http.o search.o tcp.o text.o
+-      gcc axel.o conf.o conn.o ftp.o http.o search.o tcp.o text.o -o axel $(LFLAGS)
+-ifndef DEBUG
+-ifeq ($(HOSTTYPE),Darwin)
+-      strip axel
+-else
+-      strip -R .comment -R .note -s axel
+-endif
+-endif
++      $(CC) axel.o conf.o conn.o ftp.o http.o search.o tcp.o text.o -o axel $(LFLAGS)
+ .c.o:
+-      gcc -c $*.c -o $*.o -Wall $(CFLAGS)
++      $(CC) -c $*.c -o $*.o -Wall $(CFLAGS)
+ install-bin:
+       mkdir -p $(DESTDIR)$(BINDIR)/
This page took 0.075913 seconds and 4 git commands to generate.