]> git.pld-linux.org Git - packages/avr_simulator.git/blob - avr_simulator.spec
- xpm path patch
[packages/avr_simulator.git] / avr_simulator.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        avr simulator
7 Name:           avr_simulator
8 Version:        1.3.0
9 Release:        0.3
10 License:        GPL v2+
11 Group:          Applications
12 Source0:        http://dl.sourceforge.net/avr/%{name}-%{version}.tar.gz
13 # Source0-md5:  2a73a98db3bf97013acc75324eb005f7
14 Patch0:         %{name}-quick.patch
15 Patch1:         %{name}-DESTDIR.patch
16 Patch2:         %{name}-install.patch
17 Patch3:         %{name}-xpm.patch
18 URL:            http://sourceforge.net/projects/avr/
19 BuildRequires:  motif-devel
20 #BuildRequires: autoconf
21 #BuildRequires: automake
22 #BuildRequires: intltool
23 #BuildRequires: libtool
24 #Requires(postun):      -
25 #Requires(pre,post):    -
26 #Requires(preun):       -
27 #Requires:      -
28 #Provides:      -
29 #Provides:      group(foo)
30 #Provides:      user(foo)
31 #Obsoletes:     -
32 #Conflicts:     -
33 #BuildArch:     noarch
34 #ExclusiveArch: %{ix86}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38
39 %prep
40 %setup -q -n %{name}
41 %patch0 -p1
42 %patch1 -p1
43 %patch2 -p1
44 %patch3 -p1
45
46 # undos the source
47 #find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
48
49 # remove CVS control files
50 #find -name CVS -print0 | xargs -0 rm -rf
51
52 # you'll need this if you cp -a complete dir in source
53 # cleanup backups after patching
54 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
55
56 %build
57 # if ac/am/* rebuilding is necessary, do it in this order and add
58 # appropriate BuildRequires
59 #%%{__intltoolize}
60 #%%{__gettextize}
61 #%%{__libtoolize}
62 #%%{__aclocal}
63 #%%{__autoconf}
64 #%%{__autoheader}
65 #%%{__automake}
66 # if not running libtool or automake, but config.sub is too old:
67 #cp -f /usr/share/automake/config.sub .
68 #%%configure
69 %{__make} \
70         CFLAGS="%{rpmcflags}" \
71         LDFLAGS="%{rpmldflags}"
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 # create directories if necessary
76 #install -d $RPM_BUILD_ROOT
77 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78 install -d $RPM_BUILD_ROOT%{_bindir}
79 install -d $RPM_BUILD_ROOT%{_datadir}
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc README doc/*
90 %attr(755,root,root) %{_bindir}/%{name}
91 %{_datadir}/%{name}
92
93 #%{_examplesdir}/%{name}-%{version}
This page took 0.039948 seconds and 3 git commands to generate.