]> git.pld-linux.org Git - packages/avidemux.git/commitdiff
- workaround for gcc/gas fuckup with MMX movq on x86
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 29 Apr 2010 19:33:31 +0000 (19:33 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    avidemux-gcc-bug-mmx-x86.patch -> 1.1
    avidemux.spec -> 1.86

avidemux-gcc-bug-mmx-x86.patch [new file with mode: 0644]
avidemux.spec

diff --git a/avidemux-gcc-bug-mmx-x86.patch b/avidemux-gcc-bug-mmx-x86.patch
new file mode 100644 (file)
index 0000000..276badc
--- /dev/null
@@ -0,0 +1,31 @@
+--- avidemux_2.5.2/avidemux/ADM_coreImage/src/ADM_vidFieldASM.cpp~     2010-04-29 20:25:15.862622029 +0200
++++ avidemux_2.5.2/avidemux/ADM_coreImage/src/ADM_vidFieldASM.cpp      2010-04-29 21:30:35.374874733 +0200
+@@ -25,7 +25,7 @@
+ #include"ADM_vidField.h"
+-#ifdef ADM_CPU_X86
++#ifdef ADM_CPU_X86_64
+ //    #define DEBUG_DEINT 1
+ //    #define MMX_TRACE 1
+       #include "ADM_mmxMacros.h"
+@@ -81,7 +81,7 @@
+                       }
+            }
+ }
+-#ifdef ADM_CPU_X86
++#ifdef ADM_CPU_X86_64
+ void ADMVideoFields::hasMotion_MMX(uint8_t *p,uint8_t *c,
+                                                                       uint8_t *n,
+                                                                       uint8_t *e,
+--- avidemux_2.5.2/avidemux/ADM_coreImage/src/ADM_vidFields.cpp~       2010-04-29 20:25:15.871621667 +0200
++++ avidemux_2.5.2/avidemux/ADM_coreImage/src/ADM_vidFields.cpp        2010-04-29 21:31:24.857871769 +0200
+@@ -103,7 +103,7 @@
+            e2=_motionmask2+w;         
+   //___________________ C version of motion detection ________________________
+        // other line
+-#if defined(ADM_CPU_X86) && defined(ASM_DEINT)
++#if defined(ADM_CPU_X86_64) && defined(ASM_DEINT)
+        if(CpuCaps::hasMMX())  
+               hasMotion_MMX(p,c,n,e,e2);
+        else
index 81ddc4e1a83362636a6564b952512e8b0aef7b4a..770e3589f71b6863250c5040b50b4e12b21e4c3a 100644 (file)
@@ -18,7 +18,7 @@ Summary:      A small audio/video editing software for Linux
 Summary(pl.UTF-8):     Mały edytor audio/wideo dla Linuksa
 Name:          avidemux
 Version:       2.5.2
-Release:       2
+Release:       2.1
 License:       GPL v2+
 Group:         X11/Applications/Multimedia
 Source0:       http://downloads.sourceforge.net/avidemux/%{name}_%{version}.tar.gz
@@ -28,6 +28,7 @@ Source2:      %{name}-qt4.desktop
 Patch0:                gcc44.patch
 Patch1:                types.patch
 Patch2:                qtlocale.patch
+Patch3:                %{name}-gcc-bug-mmx-x86.patch
 #Patch1:       %{name}-dts_internal.patch
 #Patch2:       %{name}-sparc64.patch
 URL:           http://fixounet.free.fr/avidemux/
@@ -103,6 +104,7 @@ find '(' -name '*.js' -o -name '*.cpp' -o -name '*.h' -o -name '*.cmake' -o -nam
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 echo 'pt_BR' >> po/LINGUAS
 
This page took 0.151363 seconds and 4 git commands to generate.