]> git.pld-linux.org Git - packages/avidemux.git/commitdiff
add binutils 2.41 patch for embedded ffmpeg
authorJan Palus <atler@pld-linux.org>
Sun, 1 Oct 2023 06:54:03 +0000 (08:54 +0200)
committerJan Palus <atler@pld-linux.org>
Sun, 1 Oct 2023 06:54:03 +0000 (08:54 +0200)
avidemux.spec
binutils2.41.patch [new file with mode: 0644]

index c3a84043424cc8e22899e9fc8a0ef68094316efb..884698271d2b593e239fbca0f5ed373db98dabc5 100644 (file)
@@ -37,6 +37,7 @@ Patch1:               no-qt-in-gtk.patch
 Patch2:                %{name}-ffmpeg-make.patch
 Patch3:                %{name}-x32.patch
 Patch4:                qt4.patch
+Patch5:                binutils2.41.patch
 URL:           http://fixounet.free.fr/avidemux/
 %{?with_qt5:BuildRequires:     Qt5Core-devel >= %{qt5_version}}
 %{?with_qt5:BuildRequires:     Qt5Gui-devel >= %{qt5_version}}
@@ -173,6 +174,8 @@ find '(' -name '*.js' -o -name '*.cpp' -o -name '*.h' -o -name '*.cmake' -o -nam
 %patch2 -p1
 %patch4 -p1
 
+cp -p %{PATCH5} avidemux_core/ffmpeg_package/patches
+
 %build
 install -d buildCore buildCli buildQt4 buildQt5 buildGtk buildPluginsCommon buildPluginsCLI buildPluginsSettings buildPluginsQt4 buildPluginsQt5 buildPluginsGtk
 
diff --git a/binutils2.41.patch b/binutils2.41.patch
new file mode 100644 (file)
index 0000000..c5f7499
--- /dev/null
@@ -0,0 +1,76 @@
+From effadce6c756247ea8bae32dc13bb3e6f464f0eb Mon Sep 17 00:00:00 2001
+From: =?utf8?q?R=C3=A9mi=20Denis-Courmont?= <remi@remlab.net>
+Date: Sun, 16 Jul 2023 18:18:02 +0300
+Subject: [PATCH] avcodec/x86/mathops: clip constants used with shift
+ instructions within inline assembly
+
+Fixes assembling with binutil as >= 2.41
+
+Signed-off-by: James Almer <jamrial@gmail.com>
+---
+ libavcodec/x86/mathops.h | 26 +++++++++++++++++++++++---
+ 1 file changed, 23 insertions(+), 3 deletions(-)
+
+diff --git a/libavcodec/x86/mathops.h b/libavcodec/x86/mathops.h
+index 6298f5ed19..ca7e2dffc1 100644
+--- libavcodec/x86/mathops.h
++++ libavcodec/x86/mathops.h
+@@ -35,12 +35,20 @@
+ static av_always_inline av_const int MULL(int a, int b, unsigned shift)
+ {
+     int rt, dummy;
++    if (__builtin_constant_p(shift))
+     __asm__ (
+         "imull %3               \n\t"
+         "shrdl %4, %%edx, %%eax \n\t"
+         :"=a"(rt), "=d"(dummy)
+-        :"a"(a), "rm"(b), "ci"((uint8_t)shift)
++        :"a"(a), "rm"(b), "i"(shift & 0x1F)
+     );
++    else
++        __asm__ (
++            "imull %3               \n\t"
++            "shrdl %4, %%edx, %%eax \n\t"
++            :"=a"(rt), "=d"(dummy)
++            :"a"(a), "rm"(b), "c"((uint8_t)shift)
++        );
+     return rt;
+ }
+@@ -113,19 +121,31 @@ __asm__ volatile(\
+ // avoid +32 for shift optimization (gcc should do that ...)
+ #define NEG_SSR32 NEG_SSR32
+ static inline  int32_t NEG_SSR32( int32_t a, int8_t s){
++    if (__builtin_constant_p(s))
+     __asm__ ("sarl %1, %0\n\t"
+          : "+r" (a)
+-         : "ic" ((uint8_t)(-s))
++         : "i" (-s & 0x1F)
+     );
++    else
++        __asm__ ("sarl %1, %0\n\t"
++               : "+r" (a)
++               : "c" ((uint8_t)(-s))
++        );
+     return a;
+ }
+ #define NEG_USR32 NEG_USR32
+ static inline uint32_t NEG_USR32(uint32_t a, int8_t s){
++    if (__builtin_constant_p(s))
+     __asm__ ("shrl %1, %0\n\t"
+          : "+r" (a)
+-         : "ic" ((uint8_t)(-s))
++         : "i" (-s & 0x1F)
+     );
++    else
++        __asm__ ("shrl %1, %0\n\t"
++               : "+r" (a)
++               : "c" ((uint8_t)(-s))
++        );
+     return a;
+ }
+-- 
+2.25.1
+
This page took 0.090132 seconds and 4 git commands to generate.