]> git.pld-linux.org Git - packages/avahi.git/commitdiff
- missing patches auto/th/avahi-0.8-1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 28 Feb 2020 14:59:32 +0000 (15:59 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 28 Feb 2020 14:59:32 +0000 (15:59 +0100)
avahi-libevent.patch [new file with mode: 0644]
avahi-localedir.patch [new file with mode: 0644]
avahi-man-conditions.patch [new file with mode: 0644]
avahi-missing.patch [new file with mode: 0644]
avahi-qt3.patch [new file with mode: 0644]

diff --git a/avahi-libevent.patch b/avahi-libevent.patch
new file mode 100644 (file)
index 0000000..55fdc74
--- /dev/null
@@ -0,0 +1,10 @@
+--- avahi-0.8/avahi-libevent.pc.in.orig        2018-09-14 07:31:35.089936663 +0200
++++ avahi-0.8/avahi-libevent.pc.in     2020-02-27 20:47:50.760954424 +0100
+@@ -6,6 +6,6 @@
+ Name: avahi-libevent
+ Description: Avahi Multicast DNS Responder (libevent Support)
+ Version: @PACKAGE_VERSION@
+-Requires: libevent-2.1.5
++Requires: libevent
+ Libs: -L${libdir} -lavahi-libevent
+ Cflags: -D_REENTRANT -I${includedir}
diff --git a/avahi-localedir.patch b/avahi-localedir.patch
new file mode 100644 (file)
index 0000000..827d2ca
--- /dev/null
@@ -0,0 +1,11 @@
+--- avahi-0.8/configure.ac.orig        2020-02-27 21:01:37.216477131 +0100
++++ avahi-0.8/configure.ac     2020-02-27 21:01:41.553120304 +0100
+@@ -421,7 +421,7 @@
+ AM_GNU_GETTEXT_VERSION([0.19.8])
+ AM_GNU_GETTEXT([external])
+-avahilocaledir='${prefix}/${DATADIRNAME}/locale'
++avahilocaledir='${localedir}'
+ AC_SUBST(avahilocaledir)
+ # Check for pkg-config manually first, as if its not installed the
diff --git a/avahi-man-conditions.patch b/avahi-man-conditions.patch
new file mode 100644 (file)
index 0000000..c32edde
--- /dev/null
@@ -0,0 +1,36 @@
+--- avahi-0.8/man/Makefile.am.orig     2015-04-01 06:58:14.161726826 +0200
++++ avahi-0.8/man/Makefile.am  2020-02-27 16:14:12.743231790 +0100
+@@ -56,7 +56,7 @@
+       avahi-publish.1 \
+       avahi-set-host-name.1
+-if HAVE_GTK
++if HAVE_GTK2OR3
+ man_MANS += \
+       bssh.1
+ endif
+@@ -64,12 +64,14 @@
+ if HAVE_PYTHON
+ man_MANS += \
+       avahi-bookmarks.1
+-if HAVE_GTK
++if HAVE_PYTHON_DBUS
++if HAVE_PYGOBJECT
+ man_MANS += \
+       avahi-discover.1
+ endif
+ endif
+ endif
++endif
+ if ENABLE_AUTOIPD
+ if HAVE_LIBDAEMON
+@@ -134,7 +136,7 @@
+ if HAVE_DBUS
+ BSSH_LN =
+-if HAVE_GTK
++if HAVE_GTK2OR3
+ if HAVE_GLIB
+ BSSH_LN += $(LN_S) bssh.1 bvnc.1 &&
+ endif
diff --git a/avahi-missing.patch b/avahi-missing.patch
new file mode 100644 (file)
index 0000000..0646799
--- /dev/null
@@ -0,0 +1,52 @@
+--- avahi-0.8/service-type-database/build-db.orig      1970-01-01 01:00:00.000000000 +0100
++++ avahi-0.8/service-type-database/build-db   2020-02-26 21:30:46.708401608 +0100
+@@ -0,0 +1,49 @@
++#!/usr/bin/env python
++# -*-python-*-
++# This file is part of avahi.
++#
++# avahi is free software; you can redistribute it and/or modify it
++# under the terms of the GNU Lesser General Public License as
++# published by the Free Software Foundation; either version 2 of the
++# License, or (at your option) any later version.
++#
++# avahi is distributed in the hope that it will be useful, but WITHOUT
++# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
++# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
++# License for more details.
++#
++# You should have received a copy of the GNU Lesser General Public
++# License along with avahi; if not, write to the Free Software
++# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
++# USA.
++
++try:
++    import anydbm as dbm
++except ImportError:
++    import dbm
++
++import sys
++
++if len(sys.argv) > 1:
++    infn = sys.argv[1]
++else:
++    infn = "service-types"
++
++if len(sys.argv) > 2:
++    outfn = sys.argv[2]
++else:
++    outfn = infn + ".db"
++
++db = dbm.open(outfn, "n")
++
++for ln in open(infn, "r"):
++    ln = ln.strip(" \r\n\t")
++    
++    if ln == "" or ln.startswith("#"):
++        continue
++
++    t, n = ln.split(":", 1)
++
++    db[t.strip()] = n.strip()
++
++db.close()
diff --git a/avahi-qt3.patch b/avahi-qt3.patch
new file mode 100644 (file)
index 0000000..847cc28
--- /dev/null
@@ -0,0 +1,11 @@
+Makefile defines QT5 for qt5, QT4 for qt4 and nothing for qt3.
+--- avahi-0.8/avahi-qt/qt-watch.cpp.orig       2018-09-14 07:31:28.490023071 +0200
++++ avahi-0.8/avahi-qt/qt-watch.cpp    2020-02-27 19:04:41.371151893 +0100
+@@ -195,6 +195,6 @@
+ #include "qt-watch.moc5"
+ #elif defined(QT4)
+ #include "qt-watch.moc4"
+-#elif defined(QT3)
++#else
+ #include "qt-watch.moc3"
+ #endif
This page took 0.037848 seconds and 4 git commands to generate.