]> git.pld-linux.org Git - packages/avahi.git/commitdiff
- updated for 0.6.26 auto/th/avahi-0_6_26-0_1
authorlisu <lisu@pld-linux.org>
Wed, 7 Jul 2010 10:21:51 +0000 (10:21 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    avahi-autoipd-sbin_ip.patch -> 1.2
    avahi-destdir.patch -> 1.4
    avahi-dhclient_hooks.patch -> 1.2
    avahi-glade.patch -> 1.2

avahi-autoipd-sbin_ip.patch
avahi-destdir.patch
avahi-dhclient_hooks.patch
avahi-glade.patch

index 5ce63fed33ca2deb67aea114aefc2f4163e4bbc4..256d39a217e825533060b3395ed0be12a76629dc 100644 (file)
@@ -1,8 +1,8 @@
---- avahi-0.6.25/avahi-autoipd/avahi-autoipd.action.linux.orig 2010-05-02 15:05:38.000000000 +0200
-+++ avahi-0.6.25/avahi-autoipd/avahi-autoipd.action.linux      2010-05-02 15:14:46.000000000 +0200
-@@ -30,17 +30,17 @@
- #   $2 interface name
- #   $3 IP adddress
+--- avahi-0.6.26/avahi-autoipd/avahi-autoipd.action.linux~     2010-06-25 20:50:59.000000000 +0200
++++ avahi-0.6.26/avahi-autoipd/avahi-autoipd.action.linux      2010-07-07 11:18:35.704019843 +0200
+@@ -35,19 +35,19 @@
+ METRIC=$((1000 + `cat "/sys/class/net/$2/ifindex" 2>/dev/null || echo 0`))
  
 -if [ -x /bin/ip -o -x /sbin/ip ] ; then
 +if [ -x /sbin/ip ] ; then
  
      case "$1" in
          BIND)
--            ip addr add "$3"/16 brd 169.254.255.255 label "$2:avahi" scope link dev "$2" 
-+            /sbin/ip addr add "$3"/16 brd 169.254.255.255 label "$2:avahi" scope link dev "$2" 
+-            ip addr add "$3"/16 brd 169.254.255.255 label "$2:avahi" scope link dev "$2"
+-            ip route add default dev "$2" metric "$METRIC" scope link ||:
++            /sbin/ip addr add "$3"/16 brd 169.254.255.255 label "$2:avahi" scope link dev "$2"
++            /sbin/ip route add default dev "$2" metric "$METRIC" scope link ||:
              ;;
  
          CONFLICT|UNBIND|STOP)
--            ip addr del "$3"/16 brd 169.254.255.255 label "$2:avahi" scope link dev "$2" 
-+            /sbin/ip addr del "$3"/16 brd 169.254.255.255 label "$2:avahi" scope link dev "$2" 
+-            ip route del default dev "$2" metric "$METRIC" scope link ||:
+-            ip addr del "$3"/16 brd 169.254.255.255 label "$2:avahi" scope link dev "$2"
++            /sbin/ip route del default dev "$2" metric "$METRIC" scope link ||:
++            /sbin/ip addr del "$3"/16 brd 169.254.255.255 label "$2:avahi" scope link dev "$2"
              ;;
  
          *)
index 620c8e96b7a869a0d8b9545b5efabed2b2100df2..c2b7fb7eafa85f3b9d86a8281743bf151bc80179 100644 (file)
@@ -1,19 +1,3 @@
-diff -urN avahi-0.6.19/avahi-sharp/Makefile.am avahi-0.6.19.new/avahi-sharp/Makefile.am
---- avahi-0.6.19/avahi-sharp/Makefile.am       2006-08-22 01:31:59.000000000 +0200
-+++ avahi-0.6.19.new/avahi-sharp/Makefile.am   2007-06-18 16:51:04.095104810 +0200
-@@ -75,10 +75,10 @@
- endif
- install-data-hook: $(ASSEMBLY)
--      $(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
-+      $(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(prefix)/lib
- uninstall-hook: $(ASSEMBLY)
--      $(GACUTIL) /u avahi-sharp /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
-+      $(GACUTIL) /u avahi-sharp /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(prefix)/lib
- endif
- endif
 diff -urN avahi-0.6.19/avahi-ui-sharp/Makefile.am avahi-0.6.19.new/avahi-ui-sharp/Makefile.am
 --- avahi-0.6.19/avahi-ui-sharp/Makefile.am    2007-04-21 20:47:16.000000000 +0200
 +++ avahi-0.6.19.new/avahi-ui-sharp/Makefile.am        2007-06-18 17:27:08.498654208 +0200
@@ -30,3 +14,18 @@ diff -urN avahi-0.6.19/avahi-ui-sharp/Makefile.am avahi-0.6.19.new/avahi-ui-shar
  
  endif
  endif
+--- avahi-0.6.26/avahi-sharp/Makefile.am~      2010-06-25 20:45:23.000000000 +0200
++++ avahi-0.6.26/avahi-sharp/Makefile.am       2010-07-07 11:12:57.330099139 +0200
+@@ -73,10 +73,10 @@
+ endif
+ install-data-hook: $(ASSEMBLY)
+-      $(AM_V_GEN)MONO_SHARED_DIR=. $(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
++      $(AM_V_GEN)MONO_SHARED_DIR=. $(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(prefix)/lib
+ uninstall-hook: $(ASSEMBLY)
+-      $(AM_V_GEN)MONO_SHARED_DIR=. $(GACUTIL) /u avahi-sharp /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
++      $(AM_V_GEN)MONO_SHARED_DIR=. $(GACUTIL) /u avahi-sharp /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(prefix)/lib
+ endif
+ endif
index 194917f7829ce731777d106b3321004cdf38217b..ee36d3d12722493d9b9b93327a67bfe9383f20c3 100644 (file)
@@ -1,7 +1,7 @@
---- avahi-0.6.25/avahi-autoipd/Makefile.am.orig        2008-06-18 01:13:44.000000000 +0200
-+++ avahi-0.6.25/avahi-autoipd/Makefile.am     2010-05-02 15:03:02.000000000 +0200
-@@ -60,8 +60,6 @@
-       cp $< $@
+--- avahi-0.6.26/avahi-autoipd/Makefile.am~    2010-06-28 18:23:15.000000000 +0200
++++ avahi-0.6.26/avahi-autoipd/Makefile.am     2010-07-07 11:15:32.407583823 +0200
+@@ -58,8 +58,6 @@
+       $(AM_V_GEN)cp $< $@
  endif
  
 -if TARGET_DEBIAN
@@ -9,18 +9,18 @@
  noinst_SCRIPTS = dhclient-enter-hook dhclient-exit-hook
  
  dhclient-enter-hook: dhclient-enter-hook.in
-@@ -74,8 +72,8 @@
+@@ -72,8 +70,8 @@
  
  BUILD = dhclient-exit-hook dhclient-enter-hook
  
--dhcliententerdir = $(sysconfdir)/dhcp3/dhclient-enter-hooks.d
--dhclientexitdir = $(sysconfdir)/dhcp3/dhclient-exit-hooks.d
+-dhcliententerdir = $(sysconfdir)/dhcp/dhclient-enter-hooks.d
+-dhclientexitdir = $(sysconfdir)/dhcp/dhclient-exit-hooks.d
 +dhcliententerdir = $(sysconfdir)/dhclient-enter-hooks.d
 +dhclientexitdir = $(sysconfdir)/dhclient-exit-hooks.d
  
  install-exec-hook: dhclient-exit-hook dhclient-enter-hook
        $(mkdir_p) $(DESTDIR)$(dhcliententerdir) $(DESTDIR)$(dhclientexitdir)
-@@ -85,7 +83,6 @@
+@@ -83,7 +81,6 @@
  uninstall-hook:
        rm -f $(DESTDIR)$(dhcliententerdir)/avahi-autoipd $(DESTDIR)$(dhclientexitdir)/avahi-autoipd
  
index 9d837bc16a49ac9d7d577ff2b41000cfb552bade..02b2aae5c7c4fe6fceab071d2d4664293e3135ce 100644 (file)
@@ -1,14 +1,13 @@
-diff -aurN avahi-0.6.5.orig/avahi-discover-standalone/Makefile.am avahi-0.6.5/avahi-discover-standalone/Makefile.am
---- avahi-0.6.5.orig/avahi-discover-standalone/Makefile.am     2005-09-25 22:34:48.000000000 +0200
-+++ avahi-0.6.5/avahi-discover-standalone/Makefile.am  2006-01-26 16:41:42.000341000 +0100
-@@ -20,7 +20,8 @@
+--- avahi-0.6.26/avahi-discover-standalone/Makefile.am~ 2010-06-25 05:25:11.000000000 +0200
++++ avahi-0.6.26/avahi-discover-standalone/Makefile.am  2010-07-07 11:03:44.306813189 +0200
+@@ -18,7 +18,8 @@
  AM_CFLAGS=-I$(top_srcdir)
+
  interfaces = \
--        avahi-discover.glade
-+      avahi-discover.glade \
-+      avahi-discover-standalone.glade
+-        avahi-discover.ui
++        avahi-discover.ui \
++       avahi-discover-standalone.glade
+
  # This cool debug trap works on i386/gcc only
  AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
 diff -aurN avahi-0.6.5.orig/avahi-discover-standalone/avahi-discover-standalone.glade avahi-0.6.5/avahi-discover-standalone/avahi-discover-standalone.glade
@@ -106,15 +105,13 @@ diff -aurN avahi-0.6.5.orig/avahi-discover-standalone/avahi-discover-standalone.
 +</widget>
 +
 +</glade-interface>
-diff -aurN avahi-0.6.5.orig/avahi-discover-standalone/main.c avahi-0.6.5/avahi-discover-standalone/main.c
---- avahi-0.6.5.orig/avahi-discover-standalone/main.c  2005-11-04 00:36:41.000000000 +0100
-+++ avahi-0.6.5/avahi-discover-standalone/main.c       2006-01-26 16:35:46.100341000 +0100
-@@ -333,7 +333,7 @@
+--- avahi-0.6.26/avahi-discover-standalone/main.c~      2010-06-25 02:41:25.000000000 +0200
++++ avahi-0.6.26/avahi-discover-standalone/main.c       2010-07-07 11:06:22.006805326 +0200
+@@ -330,7 +330,7 @@
      poll_api = avahi_glib_poll_new(NULL, G_PRIORITY_DEFAULT);
--    xml = glade_xml_new(AVAHI_INTERFACES_DIR"avahi-discover.glade", NULL, NULL);
-+    xml = glade_xml_new(AVAHI_INTERFACES_DIR"avahi-discover-standalone.glade", NULL, NULL);
-     main_window = glade_xml_get_widget(xml, "main_window");
+
+     ui = gtk_builder_new();
+-    gtk_builder_add_from_file(ui, AVAHI_INTERFACES_DIR"avahi-discover.ui", NULL);
++    gtk_builder_add_from_file(ui, AVAHI_INTERFACES_DIR"avahi-discover-standalone.glade", NULL);
+     main_window = GTK_WIDGET(gtk_builder_get_object(ui, "main_window"));
      g_signal_connect(main_window, "delete-event", (GCallback) main_window_on_delete_event, NULL);
-     
This page took 0.05218 seconds and 4 git commands to generate.