]> git.pld-linux.org Git - packages/avahi.git/commitdiff
- use nss_mdns when referring to nss-mdns as that is our package name; rel 3 auto/th/avahi-0_6_25-3 auto/ti/avahi-0_6_25-3
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 27 Feb 2010 23:40:13 +0000 (23:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    avahi.spec -> 1.101
    nss-mdns-package.patch -> 1.1

avahi.spec
nss-mdns-package.patch [new file with mode: 0644]

index 0aa2193b452e02d0755bb5b1f56a573cf9881edd..d3c08fa8886c2e08c2e2c713c31b6d2d50cda86b 100644 (file)
@@ -1,4 +1,3 @@
-#
 # TODO:
 # - autoip subpackage ?
 # - autoip start script ?
@@ -8,7 +7,7 @@
 %bcond_without qt              # build without (any) qt bindings
 %bcond_without qt3             # build without qt3 bindings
 %bcond_without qt4             # build without qt4 bindings
-#
+
 %ifnarch %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
 %undefine with_dotnet
 %endif
 %undefine with_dotnet
 %endif
 
-%if !%{with qt}
+%if %{without qt}
 %undefine      with_qt3
 %undefine      with_qt4
 %endif
+
 %{?with_dotnet:%include /usr/lib/rpm/macros.mono}
-#
 Summary:       Free mDNS/DNS-SD implementation
 Summary(pl.UTF-8):     Wolna implementacja mDNS/DNS-SD
 Name:          avahi
 Version:       0.6.25
-Release:       2
+Release:       3
 License:       LGPL v2.1+
 Group:         Applications
 Source0:       http://avahi.org/download/%{name}-%{version}.tar.gz
@@ -38,6 +37,7 @@ Patch0:               %{name}-desktop.patch
 Patch1:                %{name}-glade.patch
 Patch2:                %{name}-destdir.patch
 Patch3:                %{name}-mono-dir.patch
+Patch4:                nss-mdns-package.patch
 URL:           http://avahi.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -527,6 +527,7 @@ Narzędzia linii poleceń korzystające z avahi-client.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__intltoolize}
@@ -553,8 +554,8 @@ install -d $RPM_BUILD_ROOT{%{_pixmapsdir},/etc/rc.d/init.d}
        DESTDIR=$RPM_BUILD_ROOT \
        pythondir=%{py_sitedir}
 
-install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d
-install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
+install -p %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d
+cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
 
 ln -sf %{_includedir}/avahi-compat-libdns_sd/dns_sd.h \
        $RPM_BUILD_ROOT%{_includedir}/dns_sd.h
diff --git a/nss-mdns-package.patch b/nss-mdns-package.patch
new file mode 100644 (file)
index 0000000..9a975b1
--- /dev/null
@@ -0,0 +1,55 @@
+--- avahi-0.6.25/avahi-daemon/main.c~  2008-12-12 23:36:15.000000000 +0200
++++ avahi-0.6.25/avahi-daemon/main.c   2010-02-28 00:58:01.846880027 +0200
+@@ -986,7 +986,7 @@
+     assert(c);
+     if (!(nss_support = avahi_nss_support()))
+-        avahi_log_warn("WARNING: No NSS support for mDNS detected, consider installing nss-mdns!");
++        avahi_log_warn("WARNING: No NSS support for mDNS detected, consider installing nss_mdns!");
+     if (!(simple_poll_api = avahi_simple_poll_new())) {
+         avahi_log_error("Failed to create main loop object.");
+--- avahi-0.6.25/man/avahi-daemon.8.xml.in~    2008-06-18 02:13:44.000000000 +0300
++++ avahi-0.6.25/man/avahi-daemon.8.xml.in     2010-02-28 00:58:25.183544394 +0200
+@@ -40,7 +40,7 @@
+       use of the mDNS record cache the avahi-daemon maintains. First
+       there is the so called "simple protocol" which is used
+       exclusively by avahi-dnsconfd (a daemon which configures unicast
+-      DNS servers using server info published via mDNS) and nss-mdns
++      DNS servers using server info published via mDNS) and nss_mdns
+       (a libc NSS plugin, providing name resolution via mDNS). Finally
+       there is the D-Bus interface which provides a rich object
+       oriented interface to D-Bus enabled applications.</p>
+--- avahi-0.6.25/man/avahi-daemon.8~   2009-04-14 04:57:47.000000000 +0300
++++ avahi-0.6.25/man/avahi-daemon.8    2010-02-28 00:58:37.027084926 +0200
+@@ -11,7 +11,7 @@
+ avahi-daemon --check\fB
+ \f1
+ .SH DESCRIPTION
+-The Avahi mDNS/DNS-SD daemon implements Apple's Zeroconf architecture (also known as "Rendezvous" or "Bonjour"). The daemon registers local IP addresses and static services using mDNS/DNS-SD and provides two IPC APIs for local programs to make use of the mDNS record cache the avahi-daemon maintains. First there is the so called "simple protocol" which is used exclusively by avahi-dnsconfd (a daemon which configures unicast DNS servers using server info published via mDNS) and nss-mdns (a libc NSS plugin, providing name resolution via mDNS). Finally there is the D-Bus interface which provides a rich object oriented interface to D-Bus enabled applications.
++The Avahi mDNS/DNS-SD daemon implements Apple's Zeroconf architecture (also known as "Rendezvous" or "Bonjour"). The daemon registers local IP addresses and static services using mDNS/DNS-SD and provides two IPC APIs for local programs to make use of the mDNS record cache the avahi-daemon maintains. First there is the so called "simple protocol" which is used exclusively by avahi-dnsconfd (a daemon which configures unicast DNS servers using server info published via mDNS) and nss_mdns (a libc NSS plugin, providing name resolution via mDNS). Finally there is the D-Bus interface which provides a rich object oriented interface to D-Bus enabled applications.
+ Upon startup avahi-daemon interprets its configuration file \fI/etc/avahi/avahi-daemon.conf\f1 and reads XML fragments from \fI/etc/avahi/services/*.service\f1 which may define static DNS-SD services. If you enable \fBpublish-resolv-conf-dns-servers\f1 in \fIavahi-daemon.conf\f1 the file \fI/etc/resolv.conf\f1 will be read, too.
+ .SH OPTIONS
+--- avahi-0.6.25/man/avahi-bookmarks.1.xml.in~ 2008-06-18 02:13:44.000000000 +0300
++++ avahi-0.6.25/man/avahi-bookmarks.1.xml.in  2010-02-28 00:58:45.089793513 +0200
+@@ -55,7 +55,7 @@
+         <optdesc><p>Create links pointing to mDNS host names instead
+         of resolved IP addreses. This is only compatible with your
+         browser if you run some kind of local NSS module to resolve
+-        mDNS host names (e.g. nss-mdns). If both -A and -H are ommited
++        mDNS host names (e.g. nss_mdns). If both -A and -H are ommited
+         avahi-bookmarks detects whether NSS support is available
+         locally. This option conflicts with -A.</p></optdesc>
+       </option>
+--- avahi-0.6.25/man/avahi-bookmarks.1~        2009-04-14 04:57:48.000000000 +0300
++++ avahi-0.6.25/man/avahi-bookmarks.1 2010-02-28 00:58:54.383125793 +0200
+@@ -15,7 +15,7 @@
+ Specify an IP address to listen on. If omitted defaults to 127.0.0.1. Specify 0.0.0.0 if you want to allow remote access.
+ .TP
+ \fB-H | --host-names\f1
+-Create links pointing to mDNS host names instead of resolved IP addreses. This is only compatible with your browser if you run some kind of local NSS module to resolve mDNS host names (e.g. nss-mdns). If both -A and -H are ommited avahi-bookmarks detects whether NSS support is available locally. This option conflicts with -A.
++Create links pointing to mDNS host names instead of resolved IP addreses. This is only compatible with your browser if you run some kind of local NSS module to resolve mDNS host names (e.g. nss_mdns). If both -A and -H are ommited avahi-bookmarks detects whether NSS support is available locally. This option conflicts with -A.
+ .TP
+ \fB-A | --addresses\f1
+ Create links pointing to numeric IP addresses instead of mDNS host names. This will break access to hosts running virtual servers. If both -A and -H are ommited avahi-bookmarks detects whether NSS support is available locally. This option conflicts with -H.
This page took 0.047101 seconds and 4 git commands to generate.