]> git.pld-linux.org Git - packages/avahi.git/blob - avahi.spec
42efb77a8b587edac4357cd2a14c28f191038a8d
[packages/avahi.git] / avahi.spec
1 #
2 # TODO:
3 #       - finish with_apidocs
4 #       - check BRs for gtk+3
5 #       - make gtk3 bcond enabled by default when gtk+3 will be stable
6 #       - introspection files
7 #       - dbus files
8 #
9 # Conditional build:
10 %bcond_with     apidocs         # build API documentation
11 %bcond_without  dotnet          # build without dotnet bindings
12 %bcond_without  gtk             # build without GTK+
13 %bcond_with     gtk3            # build without GTK+3
14 %bcond_without  pygtk           # build without PyGTK
15 %bcond_without  qt              # build without (any) qt bindings
16 %bcond_without  qt3             # build without qt3 bindings
17 %bcond_without  qt4             # build without qt4 bindings
18
19 %ifnarch %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
20 %undefine with_dotnet
21 %endif
22 %ifarch i386
23 %undefine with_dotnet
24 %endif
25
26 %if %{without qt}
27 %undefine       with_qt3
28 %undefine       with_qt4
29 %endif
30
31 %{?with_dotnet:%include /usr/lib/rpm/macros.mono}
32 Summary:        Free mDNS/DNS-SD/Zeroconf implementation
33 Summary(pl.UTF-8):      Wolna implementacja mDNS/DNS-SD/Zeroconf
34 Name:           avahi
35 Version:        0.6.27
36 Release:        2
37 License:        LGPL v2.1+
38 Group:          Applications
39 Source0:        http://avahi.org/download/%{name}-%{version}.tar.gz
40 # Source0-md5:  74b40f87aeab07fc77af25f725b32f04
41 Source1:        %{name}-daemon
42 Source2:        %{name}-dnsconfd
43 Source3:        %{name}.png
44 Source4:        %{name}-daemon.upstart
45 Source5:        %{name}-dnsconfd.upstart
46 Patch0:         %{name}-desktop.patch
47 Patch1:         %{name}-glade.patch
48 Patch2:         %{name}-destdir.patch
49 Patch3:         %{name}-mono-dir.patch
50 Patch4:         nss-mdns-package.patch
51 Patch5:         %{name}-dhclient_hooks.patch
52 Patch6:         %{name}-autoipd-sbin_ip.patch
53 Patch7:         gir.patch
54 URL:            http://avahi.org/
55 BuildRequires:  autoconf
56 BuildRequires:  automake
57 BuildRequires:  dbus-devel >= 0.92
58 %if %{with apidocs}
59 BuildRequires:  doxygen
60 # for the 'dot' tool used by doxygen
61 BuildRequires:  graphviz
62 %endif
63 BuildRequires:  expat-devel
64 BuildRequires:  gdbm-devel
65 BuildRequires:  gettext-devel
66 %if %{with gtk}
67 BuildRequires:  glib2-devel >= 1:2.12.2
68 BuildRequires:  gtk+2-devel >= 2:2.10.2
69 BuildRequires:  libglade2-devel >= 1:2.6.0
70 %endif
71 %if %{with gtk3}
72 BuildRequires:  glib2-devel
73 BuildRequires:  gtk+3-devel
74 BuildRequires:  libglade2-devel
75 %endif
76 BuildRequires:  intltool >= 0.35
77 BuildRequires:  libcap-devel
78 BuildRequires:  libdaemon-devel >= 0.11
79 BuildRequires:  libtool
80 %if %{with dotnet}
81 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10
82 BuildRequires:  mono-csharp
83 BuildRequires:  monodoc >= 2.6
84 %endif
85 BuildRequires:  pkgconfig
86 BuildRequires:  python >= 1:2.4
87 BuildRequires:  python-dbus >= 0.71
88 %{?with_pygtk:BuildRequires:    python-pygtk-devel >= 2:2.9.6}
89 %if %{with qt3}
90 BuildRequires:  qt-devel >= 1:3.0
91 %endif
92 %if %{with qt4}
93 BuildRequires:  QtCore-devel
94 BuildRequires:  qt4-build
95 %endif
96 BuildRequires:  rpm-pythonprov
97 BuildRequires:  rpmbuild(macros) >= 1.561
98 Requires(post,preun):   /sbin/chkconfig
99 Requires:       %{name}-libs = %{version}-%{release}
100 Requires:       dbus >= 0.92
101 Requires:       libdaemon >= 0.11
102 Requires:       rc-scripts >= 0.4.3
103 Suggests:       nss_mdns >= 0.10-2
104 Provides:       group(avahi)
105 Provides:       user(avahi)
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %description
109 Avahi is an implementation the DNS Service Discovery and Multicast DNS
110 specifications for Zeroconf Computing. It uses D-BUS for communication
111 between user applications and a system daemon.
112
113 %description -l pl.UTF-8
114 Avahi jest implementacją specyfikacji DNS Service Discovery i
115 Multicast DNS dla Zeroconf Computing. Używa D-BUSa dla komunikacji
116 pomiędzy programami użytkownika a demonem systemowym.
117
118 %package upstart
119 Summary:        Upstart jobs description for Avahi daemons
120 Summary(pl.UTF-8):      Opis zadań Upstart dla demonów Avahi
121 Group:          Daemons
122 Requires:       %{name} = %{version}-%{release}
123 Requires:       upstart >= 0.6
124
125 %description upstart
126 Upstart jobs description for Avahi daemons.
127
128 %description upstart -l pl.UTF-8
129 Opis zadań Upstart dla demonów Avahi.
130
131 %package autoipd
132 Summary:        IPv4LL network address configuration daemon
133 Summary(pl.UTF-8):      Demon configurujący adresy IPv4LL
134 Group:          Networking/Daemons
135 Requires(postun):       /usr/sbin/groupdel
136 Requires(postun):       /usr/sbin/userdel
137 Requires(pre):  /bin/id
138 Requires(pre):  /usr/bin/getgid
139 Requires(pre):  /usr/sbin/groupadd
140 Requires(pre):  /usr/sbin/useradd
141 Provides:       group(avahi)
142 Provides:       user(avahi)
143
144 %description autoipd
145 avahi-autoipd implements IPv4LL, "Dynamic Configuration of IPv4 Link-
146 Local Addresses" (IETF RFC3927), a protocol for automatic IP address
147 configuration from the link-local 169.254.0.0/16 range without the
148 need for a central server. It is primarily intended to be used in
149 ad-hoc networks which lack a DHCP server.
150
151 IPv4LL is part of the Zeroconf stack.
152
153 %description autoipd -l pl.UTF-8
154 avahi-autoipd jest implementacją IPv4LL, protokołu umożliwiającego
155 automatyczną konfigurację adresu z zakresu 169.254.0.0/16 bez potrzeby
156 użycia centralnego serwera. Jego głównym zastosowaniem są sieci
157 ad-hoc, w których brakuje serwera DHCP.
158
159 IPv4LL jest częścią stosu Zeroconf.
160
161 %package libs
162 Summary:        Avahi client, common and core libraries
163 Summary(pl.UTF-8):      Biblioteki Avahi: klienta, wspólna i główna
164 Group:          Libraries
165
166 %description libs
167 Avahi client, common and core libraries.
168
169 %description libs -l pl.UTF-8
170 Biblioteki Avahi: klienta, wspólna i główna.
171
172 %package devel
173 Summary:        Header files for Avahi library
174 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi
175 Group:          Development/Libraries
176 Requires:       %{name}-libs = %{version}-%{release}
177 Requires:       dbus-devel >= 0.92
178 Requires:       expat-devel
179
180 %description devel
181 This is the package containing the header files for Avahi library.
182
183 %description devel -l pl.UTF-8
184 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi.
185
186 %package static
187 Summary:        Static Avahi library
188 Summary(pl.UTF-8):      Statyczna biblioteka Avahi
189 Group:          Development/Libraries
190 Requires:       %{name}-devel = %{version}-%{release}
191
192 %description static
193 Static Avahi library.
194
195 %description static -l pl.UTF-8
196 Statyczna biblioteka Avahi.
197
198 %package ui
199 Summary:        Avahi UI library
200 Summary(pl.UTF-8):      Biblioteka Avahi UI
201 Group:          X11/Libraries
202 Requires:       %{name}-libs = %{version}-%{release}
203 Requires:       gtk+2 >= 2:2.10.2
204
205 %description ui
206 Common GTK+ UI support library for Avahi.
207
208 %description ui -l pl.UTF-8
209 Biblioteka wspólnego interfejsu użytkownika GTK+ dla Avahi.
210
211 %package ui-devel
212 Summary:        Header files for Avahi UI library
213 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi UI
214 Group:          X11/Development/Libraries
215 Requires:       %{name}-devel = %{version}-%{release}
216 Requires:       %{name}-ui = %{version}-%{release}
217 Requires:       gtk+2-devel >= 2:2.10.2
218
219 %description ui-devel
220 Header files for Avahi UI library.
221
222 %description ui-devel -l pl.UTF-8
223 Pliki nagłówkowe biblioteki Avahi UI.
224
225 %package ui-static
226 Summary:        Static Avahi UI library
227 Summary(pl.UTF-8):      Statyczna biblioteka Avahi UI
228 Group:          X11/Development/Libraries
229 Requires:       %{name}-ui-devel = %{version}-%{release}
230
231 %description ui-static
232 Static Avahi UI library.
233
234 %description ui-static -l pl.UTF-8
235 Statyczna biblioteka Avahi UI.
236
237 %package compat-libdns_sd
238 Summary:        Avahi Bonjour compat library
239 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Bonjour
240 Group:          Libraries
241 Provides:       mdns-bonjour
242 Obsoletes:      mDNSResponder-libs
243
244 %description compat-libdns_sd
245 Avahi Bonjour compat library.
246
247 %description compat-libdns_sd -l pl.UTF-8
248 Biblioteka Avahi zgodna z Bonjour.
249
250 %package compat-libdns_sd-devel
251 Summary:        Header files for Avahi Bonjour compat library
252 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour
253 Group:          Development/Libraries
254 Requires:       %{name}-compat-libdns_sd = %{version}-%{release}
255 Requires:       %{name}-devel = %{version}-%{release}
256 Provides:       mdns-bonjour-devel
257 Obsoletes:      mDNSResponder-devel
258
259 %description compat-libdns_sd-devel
260 Header files for Avahi Bonjour compat library.
261
262 %description compat-libdns_sd-devel -l pl.UTF-8
263 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour.
264
265 %package compat-libdns_sd-static
266 Summary:        Static Avahi Bonjour compat library
267 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Bonjour
268 Group:          Development/Libraries
269 Requires:       %{name}-compat-libdns_sd-devel = %{version}-%{release}
270 Provides:       mdns-bonjour-static
271
272 %description compat-libdns_sd-static
273 Static Avahi Bonjour compat library.
274
275 %description compat-libdns_sd-static -l pl.UTF-8
276 Statyczna biblioteka Avahi zgodna z Bonjour.
277
278 %package compat-howl
279 Summary:        Avahi Howl compat library
280 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Howl
281 Group:          Libraries
282 Provides:       mdns-howl-libs
283 Obsoletes:      howl-libs
284
285 %description compat-howl
286 Avahi Howl compat library.
287
288 %description compat-howl -l pl.UTF-8
289 Biblioteka Avahi zgodna z Howl.
290
291 %package compat-howl-devel
292 Summary:        Header files for Avahi Howl compat library
293 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl
294 Group:          Development/Libraries
295 Requires:       %{name}-compat-howl = %{version}-%{release}
296 Requires:       %{name}-devel = %{version}-%{release}
297 Provides:       mdns-howl-devel
298 Obsoletes:      howl-devel
299
300 %description compat-howl-devel
301 Header files for Avahi Howl compat library.
302
303 %description compat-howl-devel -l pl.UTF-8
304 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl.
305
306 %package compat-howl-static
307 Summary:        Static Avahi Howl compat library
308 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Howl
309 Group:          Development/Libraries
310 Requires:       %{name}-compat-howl-devel = %{version}-%{release}
311 Provides:       mdns-howl-static
312 Obsoletes:      howl-static
313
314 %description compat-howl-static
315 Static Avahi Howl compat library.
316
317 %description compat-howl-static -l pl.UTF-8
318 Statyczna biblioteka Avahi zgodna z Howl.
319
320 %package glib
321 Summary:        Avahi GLib library bindings
322 Summary(pl.UTF-8):      Wiązania Avahi dla bibioteki GLib
323 Group:          Libraries
324
325 %description glib
326 Avahi GLib library bindings.
327
328 %description glib -l pl.UTF-8
329 Wiązania Avahi dla bibioteki GLib.
330
331 %package glib-devel
332 Summary:        Header files for Avahi GLib library bindings
333 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki GLib
334 Group:          Development/Libraries
335 Requires:       %{name}-devel = %{version}-%{release}
336 Requires:       %{name}-glib = %{version}-%{release}
337 Requires:       glib2-devel >= 1:2.12.2
338
339 %description glib-devel
340 This is the package containing the header files for Avahi-glib
341 library.
342
343 %description glib-devel -l pl.UTF-8
344 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi-glib.
345
346 %package glib-static
347 Summary:        Static Avahi GLib library
348 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GLib
349 Group:          Development/Libraries
350 Requires:       %{name}-glib-devel = %{version}-%{release}
351
352 %description glib-static
353 Static Avahi GLib library.
354
355 %description glib-static -l pl.UTF-8
356 Statyczna biblioteka Avahi GLib.
357
358 %package gobject
359 Summary:        Avahi GObject interface
360 Summary(pl.UTF-8):      Interfejs GObject do Avahi
361 Group:          Libraries
362
363 %description gobject
364 Avahi GObject interface.
365
366 %description gobject -l pl.UTF-8
367 Interfejs GObject do Avahi.
368
369 %package gobject-devel
370 Summary:        Header files for Avahi GObject interface
371 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu GObject do Avahi
372 Group:          Development/Libraries
373 Requires:       %{name}-devel = %{version}-%{release}
374 Requires:       %{name}-gobject = %{version}-%{release}
375 Requires:       glib2-devel >= 1:2.12.2
376
377 %description gobject-devel
378 This is the package containing the header files for Avahi GObject
379 interface.
380
381 %description gobject-devel -l pl.UTF-8
382 Ten pakiet zawiera pliki nagłówkowe interfejsu GObject do Avahi.
383
384 %package gobject-static
385 Summary:        Static Avahi GObject library
386 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GObject
387 Group:          Development/Libraries
388 Requires:       %{name}-gobject-devel = %{version}-%{release}
389
390 %description gobject-static
391 Static Avahi GObject library.
392
393 %description gobject-static -l pl.UTF-8
394 Statyczna biblioteka Avahi GObject.
395
396 %package qt
397 Summary:        Avahi Qt 3 library bindings
398 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 3
399 Group:          Libraries
400 Requires:       %{name}-libs = %{version}-%{release}
401 Obsoletes:      avahi-qt3
402
403 %description qt
404 Avahi Qt 3 library bindings.
405
406 %description qt -l pl.UTF-8
407 Wiązania Avahi dla biblioteki Qt 3.
408
409 %package qt-devel
410 Summary:        Header files for Avahi Qt 3 library bindings
411 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3
412 Group:          Development/Libraries
413 Requires:       %{name}-devel = %{version}-%{release}
414 Requires:       %{name}-qt = %{version}-%{release}
415 Requires:       qt-devel >= 1:3.0
416 Obsoletes:      avahi-qt3-devel
417
418 %description qt-devel
419 Header files for Avahi Qt 3 library bindings.
420
421 %description qt-devel -l pl.UTF-8
422 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3.
423
424 %package qt-static
425 Summary:        Static Avahi Qt 3 library
426 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 3
427 Group:          Development/Libraries
428 Requires:       %{name}-qt-devel = %{version}-%{release}
429 Obsoletes:      avahi-qt3-static
430
431 %description qt-static
432 Static Avahi Qt 3 library.
433
434 %description qt-static -l pl.UTF-8
435 Statyczna biblioteka Avahi Qt 3.
436
437 %package Qt
438 Summary:        Avahi Qt 4 library bindings
439 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 4
440 Group:          Libraries
441 Requires:       %{name}-libs = %{version}-%{release}
442
443 %description Qt
444 Avahi Qt 4 library bindings.
445
446 %description Qt -l pl.UTF-8
447 Wiązania Avahi dla biblioteki Qt 4.
448
449 %package Qt-devel
450 Summary:        Header files for Avahi Qt 4 library bindings
451 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4
452 Group:          Development/Libraries
453 Requires:       %{name}-Qt = %{version}-%{release}
454 Requires:       %{name}-devel = %{version}-%{release}
455
456 %description Qt-devel
457 Header files for Avahi Qt 4 library bindings.
458
459 %description Qt-devel -l pl.UTF-8
460 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4.
461
462 %package Qt-static
463 Summary:        Static Avahi Qt 4 library
464 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 4
465 Group:          Development/Libraries
466 Requires:       %{name}-Qt-devel = %{version}-%{release}
467
468 %description Qt-static
469 Static Avahi Qt 4 library.
470
471 %description Qt-static -l pl.UTF-8
472 Statyczna biblioteka Avahi Qt 4.
473
474 %package -n python-avahi
475 Summary:        Avahi Python bindings
476 Summary(pl.UTF-8):      Wiązania Avahi dla Pythona
477 Group:          Development/Languages/Python
478 Requires:       %{name}-libs = %{version}-%{release}
479 Requires:       python-dbus >= 0.71
480
481 %description -n python-avahi
482 Avahi Python bindings.
483
484 %description -n python-avahi -l pl.UTF-8
485 Wiązania Avahi dla Pythona.
486
487 %package -n dotnet-avahi
488 Summary:        Avahi MONO bindings
489 Summary(pl.UTF-8):      Wiązania Avahi dla MONO
490 Group:          Libraries
491 Requires:       %{name}-libs = %{version}-%{release}
492
493 %description -n dotnet-avahi
494 Avahi MONO bindings.
495
496 %description -n dotnet-avahi -l pl.UTF-8
497 Wiązania Avahi dla MONO.
498
499 %package -n dotnet-avahi-devel
500 Summary:        Development files for MONO Avahi bindings
501 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi dla MONO
502 Group:          Development/Libraries
503 Requires:       dotnet-avahi = %{version}-%{release}
504 Requires:       monodoc >= 2.6
505
506 %description -n dotnet-avahi-devel
507 Development files for MONO Avahi bindings.
508
509 %description -n dotnet-avahi-devel -l pl.UTF-8
510 Pliki rozwojowe wiązań Avahi dla MONO.
511
512 %package -n dotnet-avahi-ui
513 Summary:        Avahi UI MONO bindings
514 Summary(pl.UTF-8):      Wiązania Avahi UI dla MONO
515 Group:          X11/Libraries
516 Requires:       %{name}-ui = %{version}-%{release}
517 Requires:       dotnet-avahi = %{version}-%{release}
518
519 %description -n dotnet-avahi-ui
520 Avahi UI MONO bindings.
521
522 %description -n dotnet-avahi-ui -l pl.UTF-8
523 Wiązania Avahi UI dla MONO.
524
525 %package -n dotnet-avahi-ui-devel
526 Summary:        Development files for MONO Avahi UI bindings
527 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi UI dla MONO
528 Group:          X11/Development/Libraries
529 Requires:       dotnet-avahi-ui = %{version}-%{release}
530 Requires:       monodoc >= 2.6
531
532 %description -n dotnet-avahi-ui-devel
533 Development files for MONO Avahi UI bindings.
534
535 %description -n dotnet-avahi-ui-devel -l pl.UTF-8
536 Pliki rozwojowe wiązań Avahi UI dla MONO.
537
538 %package bookmarks
539 Summary:        Miniature web server
540 Summary(pl.UTF-8):      Miniaturowy serwer WWW
541 Group:          Applications
542
543 %description bookmarks
544 A Python based miniature web server that browses for mDNS/DNS-SD
545 services of type '_http._tcp' (i.e. web sites) and makes them
546 available as HTML links on http://localhost:8080/.
547
548 %description bookmarks -l pl.UTF-8
549 Napisany w Pythonie miniaturowy serwer WWW, pozwalający na
550 przeglądanie usług typu '_http._tcp' (np. stron WWW) i udostępniający
551 je jako odnośniki HTML na http://localhost:8080/.
552
553 %package discover
554 Summary:        Avahi Zeroconf browser
555 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
556 Group:          Applications
557 Requires:       python-avahi = %{version}-%{release}
558 Requires:       python-pygtk-glade >= 2:2.9.6
559
560 %description discover
561 A tool for enumerating all available services on the local LAN
562 (python-pygtk implementation).
563
564 %description discover -l pl.UTF-8
565 Narzędzie wymieniające wszystkie dostępne usługi w sieci lokalnej LAN
566 (implementacja w python-pygtk).
567
568 %package discover-standalone
569 Summary:        Avahi Zeroconf browser
570 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
571 Group:          Applications
572 Requires:       %{name}-glib = %{version}-%{release}
573
574 %description discover-standalone
575 GTK+ tool for enumerating all available services on the local LAN.
576
577 %description discover-standalone -l pl.UTF-8
578 Narzędzie GTK+ wymieniające wszystkie dostępne usługi w sieci lokalnej
579 LAN.
580
581 %package utils
582 Summary:        Avahi CLI utilities
583 Summary(pl.UTF-8):      Narzędzia CLI Avahi
584 Group:          Applications
585
586 %description utils
587 Command line utilities using avahi-client.
588
589 %description utils -l pl.UTF-8
590 Narzędzia linii poleceń korzystające z avahi-client.
591
592 %prep
593 %setup -q
594 %patch0 -p1
595 %patch1 -p1
596 %patch2 -p1
597 %patch3 -p1
598 %patch4 -p1
599 %patch5 -p1
600 %patch6 -p1
601 %patch7 -p1
602
603 %build
604 %{__intltoolize}
605 %{__libtoolize}
606 %{__aclocal} -I common
607 %{__autoconf}
608 %{__autoheader}
609 %{__automake}
610 %configure \
611         --disable-silent-rules \
612         --enable-compat-libdns_sd \
613         --enable-compat-howl \
614         --with-distro=none \
615         %{!?with_apidocs:--disable-doxygen-doc} \
616         %{!?with_gtk:--disable-gtk} \
617         %{!?with_gtk3:--disable-gtk3} \
618         %{!?with_pygtk:--disable-pygtk} \
619         %{!?with_qt3:--disable-qt3} \
620         %{!?with_qt4:--disable-qt4} \
621         %{!?with_dotnet:--disable-mono} \
622         %{!?with_dotnet:--disable-monodoc} \
623         --with-avahi-priv-access-group=adm \
624         --with-autoipd-user=avahi \
625         --with-autoipd-group=avahi
626 %{__make}
627
628 %install
629 rm -rf $RPM_BUILD_ROOT
630 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},/etc/rc.d/init.d,/etc/init}
631
632 %{__make} install \
633         DESTDIR=$RPM_BUILD_ROOT \
634         pythondir=%{py_sitedir}
635
636 install -p %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d
637 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
638
639 install %{SOURCE4} $RPM_BUILD_ROOT/etc/init/avahi-daemon.conf
640 install %{SOURCE5} $RPM_BUILD_ROOT/etc/init/avahi-dnsconfd.conf
641
642 ln -sf %{_includedir}/avahi-compat-libdns_sd/dns_sd.h \
643         $RPM_BUILD_ROOT%{_includedir}/dns_sd.h
644
645 ln -sf %{_pkgconfigdir}/avahi-compat-howl.pc \
646         $RPM_BUILD_ROOT%{_pkgconfigdir}/howl.pc
647
648 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
649 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
650 %py_postclean
651
652 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{avahi-{browse-domains,publish-address,publish-service,resolve-address,resolve-host-name},bvnc}.1
653 echo '.so avahi-browse.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-browse-domains.1
654 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-address.1
655 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-service.1
656 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-address.1
657 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-host-name.1
658 echo '.so bssh.1' > $RPM_BUILD_ROOT%{_mandir}/man1/bvnc.1
659
660 %find_lang %{name}
661
662 %clean
663 rm -rf $RPM_BUILD_ROOT
664
665 %pre
666 %groupadd -g 165 -r -f avahi
667 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
668
669 %pre autoipd
670 %groupadd -g 165 -r -f avahi
671 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
672
673 %post
674 /sbin/chkconfig --add %{name}-daemon
675 %service %{name}-daemon restart
676 /sbin/chkconfig --add %{name}-dnsconfd
677 %service %{name}-dnsconfd restart
678
679 %preun
680 if [ "$1" = "0" ]; then
681         %service -q %{name}-dnsconfd stop
682         /sbin/chkconfig --del %{name}-dnsconfd
683         %service -q %{name}-daemon stop
684         /sbin/chkconfig --del %{name}-daemon
685 fi
686
687 %postun
688 if [ "$1" = "0" ]; then
689         %userremove avahi
690         %groupremove avahi
691 fi
692
693 %postun autoipd
694 if [ "$1" = "0" ]; then
695         %userremove avahi
696         %groupremove avahi
697 fi
698
699 %post upstart
700 %upstart_post avahi-daemon
701 %upstart_post avahi-dnsconfd
702
703 %postun upstart
704 %upstart_postun avahi-daemon
705 %upstart_postun avahi-dnsconfd
706
707 %post   libs -p /sbin/ldconfig
708 %postun libs -p /sbin/ldconfig
709
710 %post   ui -p /sbin/ldconfig
711 %postun ui -p /sbin/ldconfig
712
713 %post   compat-libdns_sd -p /sbin/ldconfig
714 %postun compat-libdns_sd -p /sbin/ldconfig
715
716 %post   compat-howl -p /sbin/ldconfig
717 %postun compat-howl -p /sbin/ldconfig
718
719 %post   glib -p /sbin/ldconfig
720 %postun glib -p /sbin/ldconfig
721
722 %post   gobject -p /sbin/ldconfig
723 %postun gobject -p /sbin/ldconfig
724
725 %post   qt -p /sbin/ldconfig
726 %postun qt -p /sbin/ldconfig
727
728 %post   Qt -p /sbin/ldconfig
729 %postun Qt -p /sbin/ldconfig
730
731 %files
732 %defattr(644,root,root,755)
733 %doc docs/AUTHORS docs/COMPAT-LAYERS docs/NEWS docs/README docs/TODO
734
735 %dir %{_sysconfdir}/avahi
736 %dir %{_sysconfdir}/avahi/services
737 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-daemon.conf
738 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-dnsconfd.action
739 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/hosts
740 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/ssh.service
741 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/sftp-ssh.service
742 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/*
743
744 %attr(755,root,root) %{_bindir}/avahi-set-host-name
745
746 %attr(755,root,root) %{_sbindir}/avahi-daemon
747 %attr(755,root,root) %{_sbindir}/avahi-dnsconfd
748 %dir %{_libdir}/%{name}
749 %{_libdir}/%{name}/service-types.db
750 #%%dir %{_datadir}/%{name}/introspection
751 #%%{_datadir}/%{name}/introspection/*.introspect
752 %{_datadir}/%{name}/avahi-service.dtd
753 %{_datadir}/%{name}/service-types
754 %{_datadir}/dbus-1/interfaces/org.freedesktop.Avahi.*.xml
755
756 %{_mandir}/man1/avahi-set-host-name.1*
757 %{_mandir}/man5/avahi-daemon.conf.5*
758 %{_mandir}/man5/avahi.hosts.5*
759 %{_mandir}/man5/avahi.service.5*
760 %{_mandir}/man8/avahi-daemon.8*
761 %{_mandir}/man8/avahi-dnsconfd.8*
762 %{_mandir}/man8/avahi-dnsconfd.action.8*
763
764 %attr(754,root,root) /etc/rc.d/init.d/%{name}-daemon
765 %attr(754,root,root) /etc/rc.d/init.d/%{name}-dnsconfd
766
767 %if "%{pld_release}" != "ti"
768 %files upstart
769 %defattr(644,root,root,755)
770 %config(noreplace) %verify(not md5 mtime size) /etc/init/*.conf
771 %endif
772
773 %files autoipd
774 %defattr(644,root,root,755)
775 %dir %{_sysconfdir}/avahi
776 %attr(755,root,root) %{_sysconfdir}/%{name}/avahi-autoipd.action
777 %dir %{_sysconfdir}/dhclient-enter-hooks.d
778 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-enter-hooks.d/avahi-autoipd
779 %dir %{_sysconfdir}/dhclient-exit-hooks.d
780 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-exit-hooks.d/avahi-autoipd
781 %attr(755,root,root) %{_sbindir}/avahi-autoipd
782 %{_mandir}/man8/avahi-autoipd.8*
783 %{_mandir}/man8/avahi-autoipd.action.8*
784
785 %files libs -f %{name}.lang
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_libdir}/libavahi-client.so.*.*.*
788 %attr(755,root,root) %ghost %{_libdir}/libavahi-client.so.3
789 %attr(755,root,root) %{_libdir}/libavahi-common.so.*.*.*
790 %attr(755,root,root) %ghost %{_libdir}/libavahi-common.so.3
791 %attr(755,root,root) %{_libdir}/libavahi-core.so.*.*.*
792 %attr(755,root,root) %ghost %{_libdir}/libavahi-core.so.7
793 # common for -discover*
794 %dir %{_datadir}/%{name}
795 %dir %{_datadir}/%{name}/interfaces
796
797 %files devel
798 %defattr(644,root,root,755)
799 %doc docs/API-CHANGES-0.6 docs/DBUS-API docs/HACKING docs/MALLOC
800 %attr(755,root,root) %{_libdir}/libavahi-client.so
801 %attr(755,root,root) %{_libdir}/libavahi-common.so
802 %attr(755,root,root) %{_libdir}/libavahi-core.so
803 %{_libdir}/libavahi-client.la
804 %{_libdir}/libavahi-common.la
805 %{_libdir}/libavahi-core.la
806 %{_includedir}/avahi-client
807 %{_includedir}/avahi-common
808 %{_includedir}/avahi-core
809 %{_pkgconfigdir}/avahi-client.pc
810 %{_pkgconfigdir}/avahi-core.pc
811
812 %files static
813 %defattr(644,root,root,755)
814 %{_libdir}/libavahi-client.a
815 %{_libdir}/libavahi-common.a
816 %{_libdir}/libavahi-core.a
817
818 %if %{with gtk}
819 %files ui
820 %defattr(644,root,root,755)
821 %attr(755,root,root) %{_bindir}/bshell
822 %attr(755,root,root) %{_bindir}/bssh
823 %attr(755,root,root) %{_bindir}/bvnc
824 %attr(755,root,root) %{_libdir}/libavahi-ui.so.*.*.*
825 %attr(755,root,root) %ghost %{_libdir}/libavahi-ui.so.0
826 %{_mandir}/man1/bssh.1*
827 %{_mandir}/man1/bvnc.1*
828 %{_desktopdir}/bssh.desktop
829 %{_desktopdir}/bvnc.desktop
830
831 %files ui-devel
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{_libdir}/libavahi-ui.so
834 %{_libdir}/libavahi-ui.la
835 %{_includedir}/avahi-ui
836 %{_pkgconfigdir}/avahi-ui.pc
837
838 %files ui-static
839 %defattr(644,root,root,755)
840 %{_libdir}/libavahi-ui.a
841 %endif
842
843 %files compat-libdns_sd
844 %defattr(644,root,root,755)
845 %attr(755,root,root) %{_libdir}/libdns_sd.so.*.*.*
846 %attr(755,root,root) %ghost %{_libdir}/libdns_sd.so.1
847
848 %files compat-libdns_sd-devel
849 %defattr(644,root,root,755)
850 %attr(755,root,root) %{_libdir}/libdns_sd.so
851 %{_libdir}/libdns_sd.la
852 %{_includedir}/avahi-compat-libdns_sd
853 %{_includedir}/dns_sd.h
854 %{_pkgconfigdir}/avahi-compat-libdns_sd.pc
855
856 %files compat-libdns_sd-static
857 %defattr(644,root,root,755)
858 %{_libdir}/libdns_sd.a
859
860 %files compat-howl
861 %defattr(644,root,root,755)
862 %attr(755,root,root) %{_libdir}/libhowl.so.*.*.*
863 %attr(755,root,root) %ghost %{_libdir}/libhowl.so.0
864
865 %files compat-howl-devel
866 %defattr(644,root,root,755)
867 %attr(755,root,root) %{_libdir}/libhowl.so
868 %{_libdir}/libhowl.la
869 %{_includedir}/avahi-compat-howl
870 %{_pkgconfigdir}/avahi-compat-howl.pc
871 %{_pkgconfigdir}/howl.pc
872
873 %files compat-howl-static
874 %defattr(644,root,root,755)
875 %{_libdir}/libhowl.a
876
877 %files -n python-avahi
878 %defattr(644,root,root,755)
879 %{py_sitedir}/avahi
880
881 %if %{with dotnet}
882 %files -n dotnet-avahi
883 %defattr(644,root,root,755)
884 %{_prefix}/lib/mono/gac/avahi-sharp
885
886 %files -n dotnet-avahi-devel
887 %defattr(644,root,root,755)
888 %{_prefix}/lib/mono/avahi-sharp
889 %{_prefix}/lib/monodoc/sources/avahi-sharp-docs.*
890 %{_pkgconfigdir}/avahi-sharp.pc
891
892 %files -n dotnet-avahi-ui
893 %defattr(644,root,root,755)
894 %{_prefix}/lib/mono/gac/avahi-ui-sharp
895
896 %files -n dotnet-avahi-ui-devel
897 %defattr(644,root,root,755)
898 %{_prefix}/lib/mono/avahi-ui-sharp
899 %{_prefix}/lib/monodoc/sources/avahi-ui-sharp-docs.*
900 %{_pkgconfigdir}/avahi-ui-sharp.pc
901 %endif
902
903 %files glib
904 %defattr(644,root,root,755)
905 %attr(755,root,root) %{_libdir}/libavahi-glib.so.*.*.*
906 %attr(755,root,root) %ghost %{_libdir}/libavahi-glib.so.1
907
908 %files glib-devel
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_libdir}/libavahi-glib.so
911 %{_libdir}/libavahi-glib.la
912 %{_includedir}/avahi-glib
913 %{_pkgconfigdir}/avahi-glib.pc
914
915 %files glib-static
916 %defattr(644,root,root,755)
917 %{_libdir}/libavahi-glib.a
918
919 %files gobject
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_libdir}/libavahi-gobject.so.*.*.*
922 %attr(755,root,root) %ghost %{_libdir}/libavahi-gobject.so.0
923 %{_libdir}/girepository-1.0/Avahi-0.6.typelib
924 %{_libdir}/girepository-1.0/AvahiCore-0.6.typelib
925
926 %files gobject-devel
927 %defattr(644,root,root,755)
928 %attr(755,root,root) %{_libdir}/libavahi-gobject.so
929 %{_libdir}/libavahi-gobject.la
930 %{_includedir}/avahi-gobject
931 %{_pkgconfigdir}/avahi-gobject.pc
932 %{_datadir}/gir-1.0/Avahi-0.6.gir
933 %{_datadir}/gir-1.0/AvahiCore-0.6.gir
934
935 %files gobject-static
936 %defattr(644,root,root,755)
937 %{_libdir}/libavahi-gobject.a
938
939 %if %{with qt3}
940 %files qt
941 %defattr(644,root,root,755)
942 %attr(755,root,root) %{_libdir}/libavahi-qt3.so.*.*.*
943 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt3.so.1
944
945 %files qt-devel
946 %defattr(644,root,root,755)
947 %attr(755,root,root) %{_libdir}/libavahi-qt3.so
948 %{_libdir}/libavahi-qt3.la
949 %{_includedir}/avahi-qt3
950 %{_pkgconfigdir}/avahi-qt3.pc
951
952 %files qt-static
953 %defattr(644,root,root,755)
954 %{_libdir}/libavahi-qt3.a
955 %endif
956
957 %if %{with qt4}
958 %files Qt
959 %defattr(644,root,root,755)
960 %attr(755,root,root) %{_libdir}/libavahi-qt4.so.*.*.*
961 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt4.so.1
962
963 %files Qt-devel
964 %defattr(644,root,root,755)
965 %attr(755,root,root) %{_libdir}/libavahi-qt4.so
966 %{_libdir}/libavahi-qt4.la
967 %{_includedir}/avahi-qt4
968 %{_pkgconfigdir}/avahi-qt4.pc
969
970 %files Qt-static
971 %defattr(644,root,root,755)
972 %{_libdir}/libavahi-qt4.a
973 %endif
974
975 %files bookmarks
976 %defattr(644,root,root,755)
977 %attr(755,root,root) %{_bindir}/avahi-bookmarks
978 %{_mandir}/man1/avahi-bookmarks.1*
979
980 %if %{with pygtk}
981 %files discover
982 %defattr(644,root,root,755)
983 %attr(755,root,root) %{_bindir}/avahi-discover
984 %{py_sitedir}/avahi_discover
985 %{_datadir}/%{name}/interfaces/avahi-discover.ui
986 %{_desktopdir}/avahi-discover.desktop
987 %{_pixmapsdir}/avahi.png
988 %{_mandir}/man1/avahi-discover.1*
989 %endif
990
991 %if %{with gtk}
992 %files discover-standalone
993 %defattr(644,root,root,755)
994 %attr(755,root,root) %{_bindir}/avahi-discover-standalone
995 %{_datadir}/%{name}/interfaces/avahi-discover-standalone.glade
996 %endif
997
998 %files utils
999 %defattr(644,root,root,755)
1000 %attr(755,root,root) %{_bindir}/avahi-browse
1001 %attr(755,root,root) %{_bindir}/avahi-browse-domains
1002 %attr(755,root,root) %{_bindir}/avahi-publish
1003 %attr(755,root,root) %{_bindir}/avahi-publish-address
1004 %attr(755,root,root) %{_bindir}/avahi-publish-service
1005 %attr(755,root,root) %{_bindir}/avahi-resolve
1006 %attr(755,root,root) %{_bindir}/avahi-resolve-address
1007 %attr(755,root,root) %{_bindir}/avahi-resolve-host-name
1008 %{_mandir}/man1/avahi-browse.1*
1009 %{_mandir}/man1/avahi-browse-domains.1*
1010 %{_mandir}/man1/avahi-publish.1*
1011 %{_mandir}/man1/avahi-publish-address.1*
1012 %{_mandir}/man1/avahi-publish-service.1*
1013 %{_mandir}/man1/avahi-resolve.1*
1014 %{_mandir}/man1/avahi-resolve-address.1*
1015 %{_mandir}/man1/avahi-resolve-host-name.1*
This page took 0.121849 seconds and 2 git commands to generate.