]> git.pld-linux.org Git - packages/autopsy.git/blob - autopsy.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/autopsy.git] / autopsy.spec
1 # TODO
2 #       - change use/require Appsort to Autopsy::lib::Appsort or Autopsy::Appsort and more
3 #
4 Summary:        The Autopsy Forensic Browser - a graphical interface to The Sleuth Kit utilities
5 Summary(pl.UTF-8):      Autopsy Forensic Browser - graficzny interfejs do narzędzi z The Sleuth Kit
6 Name:           autopsy
7 Version:        2.24
8 Release:        1
9 License:        GPL
10 Group:          Applications
11 Source0:        http://dl.sourceforge.net/autopsy/%{name}-%{version}.tar.gz
12 # Source0-md5:  4ed18aa9f79453d74957b5db220d0d59
13 Source1:        %{name}.init
14 URL:            http://www.sleuthkit.org/autopsy
15 BuildRequires:  rpm-perlprov >= 4.1-13
16 Requires:       coreutils
17 Requires:       file
18 # check: openssl contains only shared lib and I don't see any native code here
19 # shouldn't it be openssl-tools or some openssl-based perl module?
20 Requires:       openssl
21 Requires:       perl-Date-Manip
22 Requires:       sleuthkit
23 Requires(post,preun):   /sbin/chkconfig
24 Requires(postun):       /usr/sbin/groupdel
25 Requires(postun):       /usr/sbin/userdel
26 Requires(pre):  /bin/id
27 Requires(pre):  /usr/bin/getgid
28 Requires(pre):  /usr/sbin/groupadd
29 Requires(pre):  /usr/sbin/useradd
30 # some script/macro finds that autopsy requires the following perl modules
31 # which are provided in the package - as a workaround we provide them:
32 # (but this pollutes a perl module namespace)
33 Provides:       perl(Appsort)
34 Provides:       perl(Appview)
35 Provides:       perl(Args)
36 Provides:       perl(Caseman)
37 Provides:       perl(Data)
38 Provides:       perl(Exec)
39 Provides:       perl(File)
40 Provides:       perl(Filesystem)
41 Provides:       perl(Frame)
42 Provides:       perl(Fs)
43 Provides:       perl(Hash)
44 Provides:       perl(Kwsrch)
45 Provides:       perl(Main)
46 Provides:       perl(Meta)
47 Provides:       perl(Notes)
48 Provides:       perl(Print)
49 Provides:       perl(Timeline)
50 Provides:       perl(Vs)
51 # noarch?
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 The Autopsy Forensic Browser is a graphical interface to utilities
56 found in The Sleuth Kit (TSK). TSK is a collection of command line
57 tools that allow you to investigate a Windows or Unix system by
58 examining the hard disk contents. TSK and Autopsy will show you the
59 files, data units, and metadata of NTFS, FAT, EXTxFS, and UFS file
60 system images in a read-only environment. Autopsy allows you to search
61 for specific types of evidence based on keywords, MAC times, hash
62 values, and file types.
63
64 %description -l pl.UTF-8
65 Autopsy Forensic Browser to graficzny interfejs do narzędzi z pakietu
66 The Sleuth Kit (TSK). TSK to zbiór programów działających z linii
67 poleceń pozwalających zbadać system Windows lub uniksowy poprzez
68 sprawdzanie zawartości twardego dysku. TSK i Autopsy pokazują pliki,
69 jednostki danych i metadane obrazów systemów plików NTFS, FAT, EXTxFS
70 i UFS w środowisku tylko do odczytu. Autopsy pozwala wyszukiwać
71 określone rodzaje dowodów w oparciu o słowa kluczowe, czasy MAC,
72 wartości haszy i rodzaje plików.
73
74 %prep
75 %setup -q
76
77 echo '#!%{__perl} -wT' > autopsy
78 echo 'use lib qw(%{perl_vendorlib}/Autopsy);' >> autopsy
79 echo 'use lib qw(%{perl_vendorlib}/Autopsy/lib);' >> autopsy
80 cat base/autopsy.base >> autopsy
81
82 cat > conf.pl <<-'EOF'
83         # Autopsy configuration settings
84
85         # when set to 1, the server will stop after it receives no
86         # connections for STIMEOUT seconds.
87         $USE_STIMEOUT = 0;
88         $STIMEOUT = 3600;
89
90         # number of seconds that child waits for input from client
91         $CTIMEOUT = 15;
92
93         # set to 1 to save the cookie value in a file (for scripting)
94         $SAVE_COOKIE = 1;
95
96         $INSTALLDIR = '%{perl_vendorlib}/Autopsy/';
97
98         # System Utilities
99         $GREP_EXE = '/bin/grep';
100
101         # Directories
102         $TSKDIR = '%{_bindir}';
103         $FILE_EXE = '%{_bindir}/file';
104         $MD5_EXE = '%{_bindir}/md5sum';
105         $SHA1_EXE = '%{_bindir}/sha1sum';
106         $NSRLDB = '';
107 # FIXME: FHS: /var/{lib,run}/autopsy?
108         $LOCKDIR = '/home/services/autopsy';
109 EOF
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 install -d $RPM_BUILD_ROOT%{_bindir}
115 install -d $RPM_BUILD_ROOT%{_mandir}/man1
116 install -d $RPM_BUILD_ROOT/home/services/autopsy
117 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/Autopsy/{lib,pict}
118
119 install autopsy $RPM_BUILD_ROOT%{_bindir}
120 install conf.pl $RPM_BUILD_ROOT%{perl_vendorlib}/Autopsy
121 install lib/* $RPM_BUILD_ROOT%{perl_vendorlib}/Autopsy/lib
122 install pict/* $RPM_BUILD_ROOT%{perl_vendorlib}/Autopsy/pict
123
124 install man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
125
126 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
127 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/autopsy
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %pre
133 %groupadd -g 178 autopsy
134 %useradd -u 178 -r -d /home/services/autopsy -s /bin/false -c "Autopsy user" -g autopsy autopsy
135
136 %post
137 /sbin/chkconfig --add autopsy
138
139 %preun
140 %service autopsy stop
141 /sbin/chkconfig --del autopsy
142
143 %postun
144 %userremove autopsy
145 %groupremove autopsy
146
147
148 %files
149 %defattr(644,root,root,755)
150 %doc README.txt docs/sleuthkit-informer-13.txt
151 %attr(755,root,root) %{_bindir}/*
152 %dir %{perl_vendorlib}/Autopsy
153 %{perl_vendorlib}/Autopsy/conf.pl
154 %{perl_vendorlib}/Autopsy/lib
155 %{perl_vendorlib}/Autopsy/pict
156 %{_mandir}/man1/*
157 %attr(750,autopsy,autopsy) /home/services/autopsy
158 %attr(754,root,root) /etc/rc.d/init.d/autopsy
This page took 0.112282 seconds and 4 git commands to generate.