]> git.pld-linux.org Git - packages/autopano-sift.git/blob - autopano-sift.spec
- autogenerate mono deps
[packages/autopano-sift.git] / autopano-sift.spec
1 # NOTE: libsift is also available separately at
2 # http://user.cs.tu-berlin.de/~nowozin/libsift/
3 # it should be separate package when other packages use it
4 %include        /usr/lib/rpm/macros.mono
5 Summary:        SIFT Feature Detection implementation
6 Summary(pl):    Implementacja algorytmu SIFT do wykrywania cech obrazu
7 Name:           autopano-sift
8 Version:        2.4
9 Release:        2
10 License:        GPL, but SIFT algorithm may require license in some countries
11 Group:          X11/Applications/Graphics
12 Source0:        http://user.cs.tu-berlin.de/~nowozin/autopano-sift/%{name}-%{version}.tar.gz
13 # Source0-md5:  e497074d0cb5586cdc66506d782ccbd7
14 URL:            http://user.cs.tu-berlin.de/~nowozin/autopano-sift/
15 # uses {glib,atk,gdk,gtk,glade}-sharp
16 BuildRequires:  dotnet-gtk-sharp-devel >= 1.0
17 BuildRequires:  mono-csharp >= 1.0
18 BuildRequires:  rpmbuild(monoautodeps)
19 Requires:       dotnet-gtk-sharp >= 1.0
20 Requires:       libgdiplus >= 1.0
21 ExclusiveArch:  %{ix86} %{x8664} arm hppa ppc s390
22 ExcludeArch:    i386
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The SIFT algorithm provides the capability to identify key feature
27 points within arbitrary images. It further extracts highly distinct
28 information for each such point and allows to characterize the point
29 invariant to a number of modifications to the image. It is invariant
30 to contrast/brightness changes, to rotation, scaling and partially
31 invariant to other kinds of transformations. The algorithm can be
32 flexibly used to create input data for image matching, object
33 identification and other computer vision related algorithms.
34
35 This package provides an implementation of the SIFT algorithm and a
36 set of utilities to utilize the algorithm to match two or more images.
37 As output, a number of control points are created, which specify one
38 and the same image location in two images. The output is created as
39 project file for the hugin panorama stitching software, which is
40 available in hugin package.
41
42 %description -l pl
43 Algorytm SIFT daje mo¿liwo¶æ okre¶lenia kluczowych punktów
44 charakterystycznych na dowolnych zdjêciach. Nastêpnie wydobywa
45 informacje wyodrêbniaj±ce dla ka¿dego takiego punktu i pozwala
46 scharakteryzowaæ ten punkt niezale¿nie od liczby modyfikacji obrazu.
47 Jest niezale¿ny od zmian kontrastu/jasno¶ci, obrotów, skalowania i
48 czê¶ciowo niezale¿ny od innych rodzajów przekszta³ceñ. Algorytm mo¿e
49 byæ elastycznie u¿ywany do tworzenia danych wej¶ciowych do
50 dopasowywania obrazów, identyfikowania obiektów i innych algorytmów
51 zwi±zanych z grafik± komputerow±.
52
53 Ten pakiet dostarcza implementacjê algorytmu SIFT i zestaw narzêdzi
54 wykorzystuj±cych ten algorytm do dopasowywania dwóch lub wiêkszej
55 liczby zdjêæ. Na wyj¶ciu tworzony jest zbiór punktów kontrolnych
56 okre¶laj±cych to samo miejsce na dwóch zdjêciach. Wyj¶cie jest
57 tworzone w formacie pliku projektu dla programu do sklejania panoram
58 hugin, dostêpnego w pakiecie o tej samej nazwie.
59
60 %prep
61 %setup -q 
62
63 %build
64 %{__make} -C src
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir}/man{1,7}}
69
70 install src/libsift.dll $RPM_BUILD_ROOT%{_libdir}
71 install src/bin/autopano-complete.sh $RPM_BUILD_ROOT%{_bindir}
72 install src/util/{autopano,generatekeys,generatekeys-sd,showone,showtwo}.exe \
73         $RPM_BUILD_ROOT%{_bindir}
74 install src/util/monoopt.sh $RPM_BUILD_ROOT%{_bindir}
75 install src/util/autopanog/autopanog.exe $RPM_BUILD_ROOT%{_bindir}
76 install src/util/man/{autopano-complete,autopano,autopanog,generatekeys,showone,showtwo}.1 \
77         $RPM_BUILD_ROOT%{_mandir}/man1
78 install src/util/man/autopano-sift.7 $RPM_BUILD_ROOT%{_mandir}/man7
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc CHANGES README
86 %attr(755,root,root) %{_bindir}/*.sh
87 # blegh, cannot be run directly (caught by WINE in PLD)
88 %attr(755,root,root) %{_bindir}/*.exe
89 %{_libdir}/libsift.dll
90 %{_mandir}/man1/*
91 %{_mandir}/man7/autopano-sift.7*
This page took 0.0904 seconds and 3 git commands to generate.