]> git.pld-linux.org Git - packages/audacious-plugins.git/commitdiff
- rel 3; fix build auto/th/audacious-plugins-2_1-3 auto/ti/audacious-plugins-2_1-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 31 Dec 2009 19:24:38 +0000 (19:24 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    audacious-plugins-jack.patch -> 1.1
    audacious-plugins.spec -> 1.52

audacious-plugins-jack.patch [new file with mode: 0644]
audacious-plugins.spec

diff --git a/audacious-plugins-jack.patch b/audacious-plugins-jack.patch
new file mode 100644 (file)
index 0000000..c4d4054
--- /dev/null
@@ -0,0 +1,22 @@
+Index: audacious-plugins-2.2/src/jack/jack.c
+===================================================================
+--- audacious-plugins-2.2.orig/src/jack/jack.c
++++ audacious-plugins-2.2/src/jack/jack.c
+@@ -236,7 +236,7 @@ static OutputPluginInitStatus jack_init(
+ /* Return the amount of data that can be written to the device */
+-static gint jack_free(void)
++static gint audacious_jack_free(void)
+ {
+   unsigned long return_val = JACK_GetBytesFreeSpace(driver);
+   unsigned long tmp;
+@@ -448,7 +448,7 @@ OutputPlugin jack_op =
+     .close_audio = jack_close,
+     .flush = jack_flush,
+     .pause = jack_pause,
+-    .buffer_free = jack_free,
++    .buffer_free = audacious_jack_free,
+     .buffer_playing = jack_playing,
+     .output_time = jack_get_output_time,
+     .written_time = jack_get_written_time,
index 3e6a5c74ec2d6304affac0ffc5f32bc5175192ff..2aab762ce54bede68dccf94e5e488f47ca41284f 100644 (file)
@@ -8,12 +8,13 @@ Summary:      Plugins for Audacious media player (metapackage)
 Summary(pl.UTF-8):     Wtyczki dla odtwarzacza multimedialnego Audacious (metapakiet)
 Name:          audacious-plugins
 Version:       2.1
-Release:       2
+Release:       3
 License:       GPL
 Group:         X11/Applications/Sound
 Source0:       http://distfiles.atheme.org/%{name}-%{version}.tgz
 # Source0-md5: 087fcb1f6fb8429b267f18ed3e3acb7a
 Patch0:                %{name}-libmtp.patch
+Patch1:                %{name}-jack.patch
 URL:           http://audacious-media-player.org/
 # BR by visualization-projectM
 BuildRequires: OpenGL-GLU-devel
@@ -972,6 +973,7 @@ Wtyczka graficzna Spectrum dla odtwarzacza multimedialnego Audacious.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__aclocal} -I m4
This page took 0.151248 seconds and 4 git commands to generate.