]> git.pld-linux.org Git - packages/atom.git/blob - atom.spec
just use symlink to atom bin
[packages/atom.git] / atom.spec
1 # BUILDING:
2 # https://github.com/atom/atom/blob/master/docs/build-instructions/linux.md
3
4 Summary:        A hackable text editor for the 21st century
5 Name:           atom
6 Version:        1.2.4
7 Release:        0.2
8 License:        MIT
9 Group:          Applications/Editors
10 Source0:        https://github.com/atom/atom/releases/download/v%{version}/%{name}.x86_64.rpm
11 # NoSource0-md5:        2c1b984e9e2ce95449987006386463ca
12 # no point storing it in distfiles, this package is no ready
13 NoSource:       0
14 URL:            https://atom.io/
15 BuildRequires:  rpm-utils
16 ExclusiveArch:  %{x8664}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _appdir         %{_libdir}/%{name}
20
21 %description
22 Atom is a desktop application based on web technologies. Like other
23 desktop apps, it has its own icon in the dock, native menus and
24 dialogs, and full access to the file system.
25
26 Open the dev tools, however, and Atom's web-based core shines through.
27 Whether you're tweaking the look of Atom's interface with CSS or
28 adding major features with HTML and JavaScript, it's never been easier
29 to take control of your editor.
30
31 %prep
32 %setup -qcT
33 SOURCE=%{SOURCE0}
34 version=$(rpm -qp --nodigest --nosignature --qf '%{V}' $SOURCE)
35 test version:${version} = version:%{version}
36 rpm2cpio $SOURCE | cpio -i -d
37
38 mv usr/share/icons .
39 mv usr/share/applications/* .
40 mv usr/share/atom .
41 mv usr/bin .
42
43 mv atom/LICENSE .
44 mv atom/chromedriver/LICENSE LICENSE.chromedrive
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_bindir},%{_appdir}}
49
50 cp -a atom/* $RPM_BUILD_ROOT%{_appdir}
51
52 ln -s %{_appdir}/atom $RPM_BUILD_ROOT%{_bindir}
53 ln -s %{_appdir}/resources/app/apm/bin/apm $RPM_BUILD_ROOT%{_bindir}/apm
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc LICENSE LICENSE.chromedrive
61 %attr(755,root,root) %{_bindir}/atom
62 %attr(755,root,root) %{_bindir}/apm
63 %dir %{_appdir}
64 %{_appdir}/version
65 %{_appdir}/*.bin
66 %{_appdir}/content_shell.pak
67 %{_appdir}/icudtl.dat
68 %attr(755,root,root) %{_appdir}/atom
69 %attr(755,root,root) %{_appdir}/libgcrypt.so.11
70 %attr(755,root,root) %{_appdir}/libnode.so
71 %attr(755,root,root) %{_appdir}/libnotify.so.4
72 %dir %{_appdir}/chromedriver
73 %attr(755,root,root) %{_appdir}/chromedriver/chromedriver
74
75 %{_appdir}/locales
76 %{_appdir}/resources
This page took 0.121334 seconds and 3 git commands to generate.