]> git.pld-linux.org Git - packages/atftp.git/blob - atftp.spec
- use %userremove/%groupremove, some cosmetics
[packages/atftp.git] / atftp.spec
1 Summary:        Client for the Trivial File Transfer Protocol (TFTP)
2 Summary(de):    Client für das 'trivial file transfer protocol (tftp)'
3 Summary(fr):    Client pour le « trivial file transfer protocol » (tftp)
4 Summary(pl):    Klient TFTP (Trivial File Transfer Protocol)
5 Summary(tr):    Ýlkel dosya aktarým protokolu (TFTP) için sunucu ve istemci
6 Name:           atftp
7 Version:        0.7
8 Release:        2
9 License:        GPL
10 Group:          Applications/Networking
11 Source0:        ftp://ftp.mamalinux.com/pub/atftp/%{name}-%{version}.tar.gz
12 # Source0-md5:  3b27365772d918050b2251d98a9c7c82
13 Source1:        atftpd.inetd
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libwrap-devel
17 BuildRequires:  libtool
18 BuildRequires:  rpmbuild(macros) >= 1.159
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The Trivial File Transfer Protocol (TFTP) is normally used only for
23 booting diskless workstations. This package contains tftp client.
24
25 %description -l de
26 Das trivial file transfer protocol (tftp) wird in der Regel nur zum
27 Booten von disklosen Workstations benutzt. Es bietet nur geringe
28 Sicherheit und sollte nur im Bedarfsfall aktiviert werden.
29
30 %description -l fr
31 Le « trivial file transfer protocol » (tftp) est normalement utilisé
32 uniquement pour démarrer les stations de travail sans disque. Il offre
33 très peu de sécurité et ne devrait pas être activé sauf si c'est
34 nécessaire.
35
36 %description -l pl
37 Tftp (trivial file transfer protocol) jest u¿ywany g³ównie do
38 startowania stacji bezdyskowych z sieci. Pakiet ten zawiera aplikacjê
39 tftp klienta.
40
41 %description -l tr
42 Ýlkel dosya aktarým protokolu genelde disksiz iþ istasyonlarýnýn að
43 üzerinden açýlmalarýnda kullanýlýr. Güvenlik denetimleri çok az
44 olduðundan zorunlu kalmadýkça çalýþtýrýlmamalýdýr.
45
46 %package -n atftpd
47 Summary:        Daemon for the trivial file transfer protocol (tftp)
48 Summary(de):    Dämon für das 'trivial file transfer protocol (tftp)'
49 Summary(fr):    Démon pour le « trivial file transfer protocol » (tftp)
50 Summary(pl):    Serwer tftp (trivial file transfer protocol)
51 Summary(tr):    Ýlkel dosya aktarým protokolu (TFTP) için sunucu ve istemci
52 Group:          Networking/Daemons
53 PreReq:         rc-inetd >= 0.8.1
54 Requires(pre):  /bin/id
55 Requires(pre):  /usr/sbin/useradd
56 Requires(postun):       /usr/sbin/userdel
57 Provides:       tftpdaemon
58 Provides:       user(tftp)
59 Obsoletes:      tftpd
60 Obsoletes:      tftpd-hpa
61 Obsoletes:      tftp-server
62 Obsoletes:      utftpd
63
64 %description -n atftpd
65 The Trivial File Transfer Protocol (TFTP) is normally used only for
66 booting diskless workstations. The tftp package provides the user
67 interface for TFTP, which allows users to transfer files to and from a
68 remote machine. It provides very little security, and should not be
69 enabled unless it is needed.
70
71 %description -n atftpd -l de
72 Das trivial file transfer protocol (tftp) wird in der Regel nur zum
73 Booten von disklosen Workstations benutzt. Es bietet nur geringe
74 Sicherheit und sollte nur im Bedarfsfall aktiviert werden.
75
76 %description -n atftpd -l fr
77 Le « trivial file transfer protocol » (tftp) est normalement utilisé
78 uniquement pour démarrer les stations de travail sans disque. Il offre
79 très peu de sécurité et ne devrait pas être activé sauf si c'est
80 nécessaire.
81
82 %description -n atftpd -l pl
83 TFTP (Trivial File Transfer Protocol) jest u¿ywany g³ównie do
84 startowania stacji bezdyskowych z sieci. Serwer tftp powinien byæ
85 instalowany tylko wtedy, kiedy zachodzi taka konieczno¶æ poniewa¿
86 nale¿y on do aplikacji o niskim poziomie bezpieczeñstwa.
87
88 %prep
89 %setup -q
90
91 %build
92 rm -f missing
93 %{__libtoolize}
94 %{__aclocal}
95 %{__automake}
96 %{__autoconf}
97 %configure
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},/etc/sysconfig/rc-inetd} \
103         $RPM_BUILD_ROOT{%{_mandir}/man{1,8},/var/lib/tftp}
104
105 install atftpd $RPM_BUILD_ROOT%{_sbindir}
106 install atftp $RPM_BUILD_ROOT%{_bindir}
107 install *.8 $RPM_BUILD_ROOT%{_mandir}/man8/
108 install *.1 $RPM_BUILD_ROOT%{_mandir}/man1/
109
110 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/tftpd
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %pre -n atftpd
116 if [ -n "`id -u tftp 2>/dev/null`" ]; then
117         if [ "`id -u tftp`" != "15" ]; then
118                 echo "Error: user tftp doesn't have uid=15. Correct this before installing tftpd." 1>&2
119                 exit 1
120         fi
121 else
122         echo "Adding user tftp UID=15."
123         /usr/sbin/useradd -u 15 -r -d /var/lib/tftp -s /bin/false -c "TFTP User" -g ftp tftp 1>&2
124 fi
125
126 %post -n atftpd
127 if [ -f /var/lock/subsys/rc-inetd ]; then
128         /etc/rc.d/init.d/rc-inetd reload 1>&2
129 else
130         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server." 1>&2
131 fi
132
133 %postun -n atftpd
134 if [ "$1" = "0" -a -f /var/lock/subsys/rc-inetd ]; then
135         /etc/rc.d/init.d/rc-inetd reload
136 fi
137 if [ "$1" = "0" ]; then
138         %userremove tftp
139 fi
140
141 %files
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/*
144 %{_mandir}/man1/*
145
146 %files -n atftpd
147 %defattr(644,root,root,755)
148 %doc README FAQ
149 %attr(755,root,root) %{_sbindir}/*
150 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/tftpd
151 %attr(750,tftp,root) %dir /var/lib/tftp
152 %{_mandir}/man8/*
This page took 0.796712 seconds and 4 git commands to generate.