]> git.pld-linux.org Git - packages/asciidoc.git/blob - asciidoc.spec
- s|/#!/usr/bin/env python|#!/usr/bin/python|
[packages/asciidoc.git] / asciidoc.spec
1 Summary:        A tool for converting text files to various formats
2 Summary(pl.UTF-8):      Narzędzie do konwersji plików tekstowych do różnych formatów
3 Name:           asciidoc
4 Version:        7.1.2
5 Release:        3
6 License:        GPL v2
7 Group:          Applications/System
8 Source0:        http://www.methods.co.nz/asciidoc/%{name}-%{version}.tar.gz
9 # Source0-md5:  554af81fb0e578a77ede4359ef79db69
10 URL:            http://www.methods.co.nz/asciidoc/index.html
11 BuildRequires:  sed >= 4.0
12 Requires:       python >= 2.3
13 Requires:       python-modules >= 2.3
14 Requires:       xmlto
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _sysconfdir     /etc/asciidoc
19
20 %description
21 AsciiDoc is a text document format for writing short documents,
22 articles, books and UNIX man pages. AsciiDoc files can be translated
23 to HTML (with or without stylesheets), DocBook and LinuxDoc markup
24 using the asciidoc(1) command. AsciiDoc is highly configurable: both
25 the AsciiDoc source file syntax and the backend output markups (which
26 can be almost any type of SGML/XML markup) can be customized and
27 extended by the user.
28
29 %description -l pl.UTF-8
30 AsciiDoc jest formatem dokumentów tekstowych do pisania krótkich
31 dokumentów, artykułów, książek i podręczników systemu UNIX. Pliki
32 AsciiDoc mogą być tłumaczone do HTML-a (z lub bez CSS), DocBooka i
33 LinuxDoca używając polecenia asciidoc(1). AsciiDoc jest wysoce
34 konfigurowalny: zarówno składnia plików źródłowych, jak i znaczniki
35 backendów (które mogą być dowolnego typu SGML/XML) mogą być
36 dostosowywane i rozszerzane przez użytkownika.
37
38 %prep
39 %setup -q
40
41 %build
42 sed -i -e 's|^#!/usr/bin/env python|#!/usr/bin/python|' asciidoc.py
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_sysconfdir}}
47 install -d $RPM_BUILD_ROOT%{_datadir}/asciidoc/{docbook-xsl,javascripts,filters,stylesheets}
48 install -d $RPM_BUILD_ROOT%{_datadir}/asciidoc/images/icons/callouts
49
50 install *.conf $RPM_BUILD_ROOT%{_sysconfdir}
51 install asciidoc.py $RPM_BUILD_ROOT%{_datadir}/%{name}
52 for i in docbook-xsl filters images javascripts stylesheets
53 do
54         find $i -type f -exec install {} $RPM_BUILD_ROOT%{_datadir}/%{name}/{} \;;
55 done
56 install doc/asciidoc.1 $RPM_BUILD_ROOT%{_mandir}/man1
57 ln -sf %{_datadir}/asciidoc/asciidoc.py $RPM_BUILD_ROOT%{_bindir}/asciidoc
58 ln -sf %{_datadir}/%{name}/stylesheets $RPM_BUILD_ROOT%{_sysconfdir}/stylesheets
59
60 rm -rf examples/website
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc BUGS CHANGELOG README doc/asciidoc.html examples
68 %attr(755,root,root) %{_bindir}/%{name}
69 %dir %{_sysconfdir}
70 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
71 %dir %{_datadir}/%{name}
72 %attr(755,root,root) %{_datadir}/%{name}/asciidoc.py
73 %{_datadir}/%{name}/docbook-xsl
74 %{_datadir}/%{name}/filters
75 %{_datadir}/%{name}/images
76 %{_datadir}/%{name}/javascripts
77 %{_datadir}/%{name}/stylesheets
78 %{_mandir}/man1/*
This page took 0.116061 seconds and 4 git commands to generate.