]> git.pld-linux.org Git - packages/arpwatch.git/commitdiff
Rediff patches
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 9 May 2021 12:43:03 +0000 (14:43 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 9 May 2021 12:43:03 +0000 (14:43 +0200)
ac264.patch
arpwatch-makefile.patch

index e3e479ec6b0892c90676e11cd32f20ff98adf4f0..155568d064d1cc727d76cdea14e73833a46d197a 100644 (file)
@@ -1,18 +1,8 @@
 based on http://github.com/mcr/libpcap/commit/d1a3a92fab103210ab5f61780a731bce9a8909b5
---- configure.in.orig  2010-04-08 14:13:14.128949704 +0200
-+++ configure.in       2010-04-08 14:08:22.642391622 +0200
-@@ -21,6 +21,8 @@
- AC_CANONICAL_SYSTEM
-+AC_LBL_C_INIT_BEFORE_CC(V_CCOPT, V_INCLS)
-+AC_PROG_CC
- AC_LBL_C_INIT(V_CCOPT, V_INCLS)
- AC_LBL_C_INLINE
- AC_C___ATTRIBUTE__
---- aclocal.m4.orig    2010-04-08 14:16:43.134795418 +0200
-+++ aclocal.m4 2010-04-08 14:19:50.183311589 +0200
-@@ -23,29 +23,22 @@
+diff -urNp -x '*.orig' arpwatch-2.1a15.org/aclocal.m4 arpwatch-2.1a15/aclocal.m4
+--- arpwatch-2.1a15.org/aclocal.m4     2021-05-09 14:37:46.275738586 +0200
++++ arpwatch-2.1a15/aclocal.m4 2021-05-09 14:37:46.332408198 +0200
+@@ -23,29 +23,22 @@ dnl LBL autoconf macros
  dnl
  
  dnl
@@ -28,12 +18,6 @@ based on http://github.com/mcr/libpcap/commit/d1a3a92fab103210ab5f61780a731bce9a
  dnl   AC_LBL_C_INIT(copt, incls)
  dnl
 -dnl results:
--dnl
--dnl   $1 (copt set)
--dnl   $2 (incls set)
--dnl   CC
--dnl   LDFLAGS
--dnl   LBL_CFLAGS
 +dnl It appears that newer versions of autoconf (2.64 and later) will,
 +dnl if you use AC_TRY_COMPILE in a macro, stick AC_PROG_CC at the
 +dnl beginning of the macro, even if the macro itself calls AC_PROG_CC.
@@ -45,6 +29,12 @@ based on http://github.com/mcr/libpcap/commit/d1a3a92fab103210ab5f61780a731bce9a
 +dnl calling AC_PROG_CC, and then doing the tests we now do in
 +dnl AC_LBL_C_INIT.
  dnl
+-dnl   $1 (copt set)
+-dnl   $2 (incls set)
+-dnl   CC
+-dnl   LDFLAGS
+-dnl   LBL_CFLAGS
+-dnl
 -AC_DEFUN(AC_LBL_C_INIT,
 -    [AC_PREREQ(2.12)
 -    AC_BEFORE([$0], [AC_PROG_CC])
@@ -55,7 +45,7 @@ based on http://github.com/mcr/libpcap/commit/d1a3a92fab103210ab5f61780a731bce9a
      AC_ARG_WITH(gcc, [  --without-gcc           don't use gcc])
      $2=""
      if test "${srcdir}" != "." ; then
-@@ -70,7 +63,32 @@
+@@ -70,7 +63,32 @@ AC_DEFUN(AC_LBL_C_INIT,
            CC=cc
            export CC
      fi
@@ -89,4 +79,15 @@ based on http://github.com/mcr/libpcap/commit/d1a3a92fab103210ab5f61780a731bce9a
      if test "$GCC" != yes ; then
            AC_MSG_CHECKING(that $CC handles ansi prototypes)
            AC_CACHE_VAL(ac_cv_lbl_cc_ansi_prototypes,
-
+diff -urNp -x '*.orig' arpwatch-2.1a15.org/configure.in arpwatch-2.1a15/configure.in
+--- arpwatch-2.1a15.org/configure.in   2006-06-21 22:34:29.000000000 +0200
++++ arpwatch-2.1a15/configure.in       2021-05-09 14:37:46.332408198 +0200
+@@ -16,6 +16,8 @@ if test -z "$PWD" ; then
+       PWD=`pwd`
+ fi
++AC_LBL_C_INIT_BEFORE_CC(V_CCOPT, V_INCLS)
++AC_PROG_CC
+ AC_LBL_C_INIT(V_CCOPT, V_INCLS)
+ AC_CHECK_HEADERS(fcntl.h memory.h)
index d78ac60e07a0f103f829489bd1a9c302c3e7dd4c..a5ba8dc6773fe63dc75994157e3d7514bbca99fe 100644 (file)
@@ -1,7 +1,7 @@
-diff -u arpwatch-2.1a4/Makefile.in arpwatch-2.1a4.new/Makefile.in
---- arpwatch-2.1a4/Makefile.in Wed Jul 29 07:16:45 1998
-+++ arpwatch-2.1a4.new/Makefile.in     Wed Feb 17 00:54:19 1999
-@@ -45,7 +45,7 @@
+diff -urNp -x '*.orig' arpwatch-2.1a15.org/Makefile.in arpwatch-2.1a15/Makefile.in
+--- arpwatch-2.1a15.org/Makefile.in    2021-05-09 14:42:25.080236575 +0200
++++ arpwatch-2.1a15/Makefile.in        2021-05-09 14:42:25.160240737 +0200
+@@ -45,7 +45,7 @@ VPATH = @srcdir@
  CC = @CC@
  PROG = arpwatch
  CCOPT = @V_CCOPT@
@@ -10,8 +10,8 @@ diff -u arpwatch-2.1a4/Makefile.in arpwatch-2.1a4.new/Makefile.in
  DEFS = -DDEBUG @DEFS@ -DARPDIR=\"$(ARPDIR)\" -DPATH_SENDMAIL=\"$(SENDMAIL)\" \
        -DETHERCODES=\"$(ETHERCODES)\"
  
-@@ -109,13 +109,13 @@
-       $(CC) $(CFLAGS) -o $@ zap.o intoa.o -lutil
+@@ -113,13 +113,13 @@ zap: zap.o intoa.o
+       $(CC) $(CFLAGS) $(LDFLAGS) -o $@ zap.o intoa.o -lutil
  
  install: force
 -      $(INSTALL) -m 555 -o bin -g bin arpwatch $(DESTDIR)$(BINDEST)
@@ -28,9 +28,10 @@ diff -u arpwatch-2.1a4/Makefile.in arpwatch-2.1a4.new/Makefile.in
            $(DESTDIR)$(MANDEST)/man8
  
  lint: $(GENSRC) force
---- arpwatch/configure.in.org  2008-11-01 14:11:41.708042556 +0100
-+++ arpwatch/configure.in      2008-11-01 14:11:51.594708133 +0100
-@@ -47,7 +47,7 @@
+diff -urNp -x '*.orig' arpwatch-2.1a15.org/configure.in arpwatch-2.1a15/configure.in
+--- arpwatch-2.1a15.org/configure.in   2021-05-09 14:42:25.090237095 +0200
++++ arpwatch-2.1a15/configure.in       2021-05-09 14:42:25.160240737 +0200
+@@ -49,7 +49,7 @@ osf3*)
        ;;
  esac
  
This page took 0.111221 seconds and 4 git commands to generate.