]> git.pld-linux.org Git - packages/arpwatch.git/blob - arpwatch.spec
- removed using %attr(644,root,man) macros in %files.
[packages/arpwatch.git] / arpwatch.spec
1 Summary:        Arpwatch monitors changes in ethernet/ip address pairings.
2 Summary(pl):    Arpwatch monitoruje zmiany w parach adresów ethernet/ip
3 Name:           arpwatch
4 Version:        2.1a4
5 Release:        5d
6 Group:          Applications/Networking
7 Group(pl):      Aplikacje/Sieciowe
8 Copyright:      GPL
9 Vendor:         PLD
10 Source0:        ftp://ftp.ee.lbl.gov/%{name}-%{version}.tar.Z   
11 Source1:        %{name}.init
12 Patch0:         %{name}-makefile.patch
13 Prereq:         chkconfig
14 BuildRoot:      /tmp/%{name}-%{version}-root
15
16 %description
17 Arpwatch and arpsnmp are tools that monitors ethernet or fddi activity and
18 maintain a database of ethernet/ip address pairings.
19
20 %description -l pl
21 Arpwatch i arpsnmp to narzêdzia do monitorowania ethernetu i fddi.
22 Dodatkowo tworzona jest baza par adresów ethernet/ip.
23
24 %prep
25 %setup  -q
26 %patch0 -p1
27
28 %build
29 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
30 ./configure %{_target} \
31         --prefix=/usr
32 make \
33         ARPDIR=/var/arpwatch
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37
38 install -d $RPM_BUILD_ROOT/{var/arpwatch,etc/rc.d/init.d,usr/{sbin,man/man8}}
39
40 make install \
41         DESTDIR=$RPM_BUILD_ROOT \
42         install-man
43
44 for n in arp2ethers massagevendor; do
45         install -m755 $n $RPM_BUILD_ROOT/var/arpwatch
46 done
47 for n in *.awk *.dat; do
48         install -m644 $n $RPM_BUILD_ROOT/var/arpwatch
49 done
50
51 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/arpwatch
52
53 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/*
54 gzip -9nf README CHANGES
55
56 %post 
57 chkconfig --add arpwatch
58
59 %preun 
60 chkconfig --del arpwatch
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc    README.gz CHANGES.gz
68
69 %attr(755,root,root) /usr/sbin/*
70
71 %{_mandir}/man8/*
72
73 %attr(750,root,root) /etc/rc.d/init.d/arpwatch
74
75 %dir    /var/arpwatch
76 %config(noreplace) %verify(not size mtime md5) /var/arpwatch/arp.dat
77 %config %verify(not size mtime md5) /var/arpwatch/ethercodes.dat
78 /var/arpwatch/*.awk
79
80 %attr(755,root,root) /var/arpwatch/arp2ethers
81 %attr(755,root,root) /var/arpwatch/massagevendor
82
83 %changelog
84 * Tue Feb 16 1999 Artur Frysiak <wiget@usa.net>
85   [2.1a4-5d]
86 - initial release for PLD
This page took 0.044572 seconds and 3 git commands to generate.