]> git.pld-linux.org Git - packages/arpack.git/blob - arpack.spec
- release 4
[packages/arpack.git] / arpack.spec
1 #
2 # Conditional build:
3 %bcond_with     acml    # With ACML version of BLAS instead of NETLIB implementation
4 #
5 Summary:        Subroutines for solving large scale eigenvalue problems
6 Summary(pl.UTF-8):      Rozwiązywanie zagadnienia własnego dla dużych macierzy
7 Name:           arpack
8 Version:        2.1
9 Release:        4%{?with_acml:ACML}
10 License:        Freely distributable
11 Group:          Libraries
12 Source0:        http://www.caam.rice.edu/software/ARPACK/SRC/%{name}96.tar.gz
13 # Source0-md5:  fffaa970198b285676f4156cebc8626e
14 Source1:        http://www.caam.rice.edu/software/ARPACK/SRC/patch.tar.gz
15 # Source1-md5:  14830d758f195f272b8594a493501fa2
16 Source2:        http://www.caam.rice.edu/software/ARPACK/SRC/ug.ps.gz
17 # Source2-md5:  79cc51e4812c75873adafcad2185842e
18 Source3:        http://www.caam.rice.edu/software/ARPACK/SRC/P57_58.ps.gz
19 # Source3-md5:  b86d77199f989fc438acaf7ac0433e76
20 Source4:        http://www.caam.rice.edu/software/ARPACK/SRC/P61_62.ps.gz
21 # Source4-md5:  d116887acb3d61fecf645c2d37d4d517
22 Patch0:         %{name}-automake_support.patch
23 Patch1:         %{name}-no_etime.patch
24 URL:            http://www.caam.rice.edu/software/ARPACK/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  gcc-g77
28 BuildRequires:  libtool >= 2:1.5
29 %{!?with_acml:BuildRequires:    blas-devel}
30 %{?with_acml:ExclusiveArch:     %{x8664}}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 ARPACK software is capable of solving large scale symmetric,
35 nonsymmetric, and generalized eigenproblems from significant
36 application areas. The software is designed to compute a few (k)
37 eigenvalues with user specified features such as those of largest real
38 part or largest magnitude. Storage requirements are on the order of
39 n*k locations. No auxiliary storage is required. A set of Schur basis
40 vectors for the desired k-dimensional eigen-space is computed which is
41 numerically orthogonal to working precision. Numerically accurate
42 eigenvectors are available on request.
43
44 %description -l pl.UTF-8
45 Rozwiązywanie zagadnienia własnego (symetrycznego, niesymetrycznego,
46 ogólnego) dla dużych macierzy. Macierz może być dowolna, przy czym
47 procedury działają szczególnie dobrze w przypadku dużych macierzy
48 rzadkich bądź macierzy ze znaną strukturą. Biblioteka służy do
49 obliczenia kilku (k) wartości własnych o zadanych z góry własnościach,
50 takich jak największa (najmniejsza) część rzeczywista albo największy
51 (najmniejszy) moduł. Wymagania pamięciowe są rzędu n*k, żadna
52 dodatkowa pamięć (np. dyskowa) nie jest wymagana.
53
54 %package devel
55 Summary:        ARPACK development files
56 Summary(pl.UTF-8):      Pliki programistyczne ARPACK
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 %{!?with_acml:Requires: blas-devel}
60
61 %description devel
62 ARPACK development files.
63
64 %description devel -l pl.UTF-8
65 Pliki programistyczne ARPACK.
66
67 %package static
68 Summary:        Static ARPACK library
69 Summary(pl.UTF-8):      Statyczna biblioteka ARPACK
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static ARPACK library.
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka ARPACK.
78
79 %prep
80 %setup -q -n ARPACK -b1
81 %patch0 -p1
82 %patch1 -p1
83 cp %{SOURCE2} .
84 cp %{SOURCE3} .
85 cp %{SOURCE4} .
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoheader}
91 %{__autoconf}
92 %{__automake}
93 %configure \
94         LDFLAGS=%{?with_acml:-lacml}%{!?with_acml:-lblas}
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %clean
105 rm -fr $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc README
113 %attr(755,root,root) %{_libdir}/libarpack.so.*.*.*
114
115 %files devel
116 %defattr(644,root,root,755)
117 %doc DOCUMENTS/*.doc *.ps.gz
118 %attr(755,root,root) %{_libdir}/libarpack.so
119 %{_libdir}/libarpack.la
120
121 %files static
122 %defattr(644,root,root,755)
123 %{_libdir}/libarpack.a
This page took 0.030372 seconds and 3 git commands to generate.