]> git.pld-linux.org Git - packages/arm-trusted-firmware.git/blame - arm-trusted-firmware.spec
new (based on fedora)
[packages/arm-trusted-firmware.git] / arm-trusted-firmware.spec
CommitLineData
eb9d0724
JP
1Summary: ARM Trusted Firmware
2Name: arm-trusted-firmware
3Version: 2.4
4Release: 1
5License: BSD
6Group: Base/Kernel
7Source0: https://git.trustedfirmware.org/TF-A/trusted-firmware-a.git/snapshot/trusted-firmware-a-%{version}.tar.gz
8# Source0-md5: 19a6d208f613227415654db38cf88c81
9URL: https://developer.arm.com/tools-and-software/open-source-software/firmware/trusted-firmware
10BuildRequires: crossarm-gcc
11BuildRequires: dtc
12ExclusiveArch: aarch64
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15%description
16ARM Trusted firmware is a reference implementation of secure world
17software for ARMv8-A including Exception Level 3 (EL3) software. It
18provides a number of standard ARM interfaces like Power State
19Coordination (PSCI), Trusted Board Boot Requirements (TBBR) and Secure
20Monitor.
21
22Note: the contents of this package are generally just consumed by
23bootloaders such as u-boot. As such the binaries aren't of general
24interest to users.
25
26%package -n arm-trusted-firmware-armv8
27Summary: ARM Trusted Firmware for ARMv8-A
28
29%description -n arm-trusted-firmware-armv8
30ARM Trusted Firmware binaries for various ARMv8-A SoCs.
31
32Note: the contents of this package are generally just consumed by
33bootloaders such as u-boot. As such the binaries aren't of general
34interest to users.
35
36Note: the contents of this package are generally just consumed by
37bootloaders such as u-boot. As such the binaries aren't of general
38interest to users.
39
40%prep
41%setup -q -n trusted-firmware-a-%{version}
42
43# Fix the name of the cross compile for the rk3399 Cortex-M0 PMU
44sed -i 's/arm-none-eabi-/arm-linux-gnueabi-/' plat/rockchip/rk3399/drivers/m0/Makefile
45
46%build
47for soc in rk3399; do
48%{__make} HOSTCC="%{__cc} %{rpmcflags}" CROSS_COMPILE="" PLAT="$soc" bl31
49done
50
51%install
52rm -rf $RPM_BUILD_ROOT
53install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
54
55for soc in rk3399; do
56install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/$soc
57 for file in bl31/bl31.elf m0/rk3399m0.bin m0/rk3399m0.elf; do
58 if [ -f build/$soc/release/$file ]; then
59 cp -p build/$soc/release/$file $RPM_BUILD_ROOT%{_datadir}/%{name}/$soc
60 fi
61 done
62done
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files -n arm-trusted-firmware-armv8
68%defattr(644,root,root,755)
69%doc readme.rst
70%{_datadir}/%{name}
This page took 1.015231 seconds and 4 git commands to generate.