]> git.pld-linux.org Git - packages/ardour.git/blob - ardour.spec
- stricter BR for libart_lgpl
[packages/ardour.git] / ardour.spec
1 Summary:        Multitrack hard disk recorder
2 Summary(pl):    Wielo¶cie¿kowy magnetofon nagrywaj±cy na twardym dysku
3 Name:           ardour
4 Version:        0.9
5 %define _beta   beta18
6 Release:        0.%{_beta}.1
7 License:        GPL
8 Group:          X11/Applications/Sound
9 Source0:        http://ardour.org/releases/%{name}-%{version}%{_beta}.tar.bz2
10 # Source0-md5:  f0ab7b6fccb67b209b1f11edea49fbf1
11 Source1:        %{name}.desktop
12 Patch0:         %{name}-system-libs.patch
13 Patch1:         %{name}-opt.patch
14 Patch2:         %{name}-ac_cleanup.patch
15 Patch3:         %{name}-nptl_fix.patch
16 URL:            http://ardour.org/
17 BuildRequires:  XFree86-devel
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  alsa-lib-devel >= 0.9.0
21 BuildRequires:  gtk+-devel >= 1.0.0
22 #BuildRequires: gtk-canvas-devel >= 0.1
23 BuildRequires:  gtkmm1-devel >= 1.2.6
24 BuildRequires:  jack-audio-connection-kit-devel >= 0.98.0
25 BuildRequires:  libart_lgpl >= 2.3.16
26 BuildRequires:  libpng-devel
27 BuildRequires:  liblrdf-devel >= 0.3.0
28 BuildRequires:  libsamplerate-devel >= 0.0.13
29 BuildRequires:  libsigc++1-devel >= 0.8.8
30 BuildRequires:  libsndfile-devel >= 1.0.0
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool
33 BuildRequires:  libxml2-devel >= 2.5.0
34 BuildRequires:  pkgconfig
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 A "professional" multitrack, multichannel audio recorder and DAW for
39 Linux, using ALSA-supported audio interfaces. Supports up to 32 bit
40 samples, 24+ channels at up to 96kHz, full MMC control,
41 non-destructive, non-linear editor, LADSPA plugins.
42
43 %description -l pl
44 "Profesjonalny" wielo¶cie¿kowy, wielokana³owy magnetofon oraz DAW dla
45 Linuksa, wykorzystuj±cy interfejsy d¼wiêkowe obs³ugiwane przez ALSA.
46 Obs³uguje próbki do 32 bitów, 24+ kana³ów do 96kHz, pe³n± kontrolê
47 MMC, niedestruktywny, nieliniowy edytor oraz wtyczki LADSPA.
48
49 %prep
50 %setup -q -n %{name}-%{version}%{_beta}
51 %patch0 -p1
52 %patch1 -p1
53 %patch2 -p1
54 %patch3 -p1
55
56 install -d m4
57 # extract AM_BUILD_ENVIRONMENT (patched!)
58 tail -n +837 aclocal.m4 > m4/buildenv.m4
59 # AM_OPT_FLAGS (patched!)
60 tail -n +862 libs/pbd/aclocal.m4 | head -n 33 >> m4/buildenv.m4
61
62 %{__perl} -pi -e 's/pt_PT/pt/' gtk_ardour/po/LINGUAS
63 mv -f gtk_ardour/po/{pt_PT,pt}.po
64
65 %build
66 %{__aclocal} -I m4
67 %{__autoconf}
68 %{__automake}
69 cd gtk_ardour
70 %{__aclocal} -I ../m4
71 %{__autoconf}
72 %{__automake}
73 cd ../libs
74 %{__libtoolize}
75 %{__aclocal} -I ../m4
76 %{__autoconf}
77 %{__automake}
78 cd ardour
79 %{__libtoolize}
80 %{__aclocal} -I ../../m4
81 %{__autoconf}
82 %{__automake}
83 cd ../gtk-canvas
84 %{__aclocal} -I ../../m4
85 %{__autoconf}
86 %{__automake}
87 cd ../gtkmmext
88 %{__aclocal} -I ../../m4
89 %{__autoconf}
90 %{__automake}
91 cd ../midi++
92 %{__aclocal} -I ../../m4
93 %{__autoconf}
94 %{__automake}
95 cd ../pbd
96 %{__aclocal} -I ../../m4
97 %{__autoconf}
98 %{__automake}
99 cd ../soundtouch
100 %{__aclocal} -I ../../m4
101 %{__autoconf}
102 %{__automake}
103 cd ../..
104 # ksi doesn't build for a moment
105 %configure \
106         --disable-ksi \
107         %{!?debug:--enable-optimize}
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT%{_desktopdir}
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
119
120 # it shouldn't be there
121 rm -f $RPM_BUILD_ROOT%{_datadir}/ardour/libardour.{la,a}
122
123 %find_lang %{name} --all-name
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files -f %{name}.lang
129 %defattr(644,root,root,755)
130 %doc ChangeLog DOCUMENTATION/{AUTHORS,CONTRIBUTORS,FAQ,README,TODO,TRANSLATORS}
131 %lang(es) %doc DOCUMENTATION/{AUTHORS.es,CONTRIBUTORS.es,README.es}
132 %lang(fr) %doc DOCUMENTATION/README.fr
133 %lang(it) %doc DOCUMENTATION/README.it
134 %lang(ru) %doc DOCUMENTATION/README.ru
135 %attr(755,root,root) %{_bindir}/*
136 %{_datadir}/%{name}
137 %{_mandir}/man1/ardour.1*
138 %lang(es) %{_mandir}/es/man1/ardour.1*
139 %lang(fr) %{_mandir}/fr/man1/ardour.1*
140 %lang(ru) %{_mandir}/ru/man1/ardour.1*
141 %dir %{_sysconfdir}/ardour
142 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/ardour/*.rc
143 %{_desktopdir}/ardour.desktop
This page took 0.094811 seconds and 3 git commands to generate.