]> git.pld-linux.org Git - packages/arabica.git/blob - arabica.spec
- converted to UTF-8
[packages/arabica.git] / arabica.spec
1 #
2 # TODO:
3 # - unify Arabica <-> arabica
4 # - is -fPIC correct?
5 # - more parsers
6 #
7 Summary:        Arabica - an XML parser toolkit written in C++
8 Summary(pl.UTF-8):   Arabica - narzędzia do parsowania XML napisane w C++
9 Name:           arabica
10 Version:        2004_february
11 %define _ver    %(echo %{version} | tr _ -)
12 Release:        0.1
13 License:        BSD-like
14 Group:          Development/Libraries
15 Source0:        http://dl.sourceforge.net/arabica/%{name}-%{_ver}.tar.gz
16 # Source0-md5:  64a0ccdfd9a9e10a5391237969033c3c
17 Patch0:         %{name}-makefile.patch
18 URL:            http://www.jezuk.co.uk/cgi-bin/view/arabica
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libxml2-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Arabica is an XML parser toolkit, providing SAX2 and DOM
25 implementations, written in Standard C++.
26
27 Arabica is a full SAX2 implementation, including the optional
28 interfaces and helper classes. It delivers UTF-8 encoded std::strings
29 or UCS-2 std::wstrings, but is templated on string type and so can
30 accommodate custom string types. It provides uniform SAX2 wrappers
31 for the expat parser, Xerces, libxml and, on Windows only, for the
32 Microsoft XML parser COM component.
33
34 %description -l pl.UTF-8
35 Arabica to pakiet narzędzi do parsowania XML zawierający implementacje
36 SAX2 i DOM napisane w standardowym C++.
37
38 Arabica to pełna implementacja SAX2 wraz z opcjonalnymi interfejsami i
39 klasami pomocniczymi. Dostarcza kodowane UTF-8 std::strings albo
40 kodowane UCS-2 std::wstrings, ale ma szablony oparte na typie string,
41 więc może obsługiwać własne typy string. Udostępnia jednolite wrappery
42 SAX2 dla parserów expat, Xerces, libxml oraz - tylko pod Windows -
43 komponentu COM parsera XML Microsoftu.
44
45 %package devel
46 Summary:        Header files for Arabica
47 Summary(pl.UTF-8):   Pliki nagłówkowe Arabica
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       libstdc++-devel
51 Requires:       libxml2-devel
52
53 %description devel
54 Header files for Arabica.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe Arabica.
58
59 %prep
60 %setup -q -n %{name}-%{_ver}
61 %patch0 -p1
62
63 %build
64 %{__make} \
65         CXX="%{__cxx}" \
66         CPP="%{__cpp}" \
67         LD="%{__cxx}" \
68         CXXFLAGS="%{rpmcxxflags} -fPIC" \
69         INCS_DIRS="-I%{_builddir}/%{buildsubdir} `xml2-config --cflags`" \
70         DYNAMIC_LIBS="-lstdc++ `xml2-config --libs`" \
71         LINK_SHARED="-shared -fPIC"
72 #       USE_PARSER="-DUSE_EXPAT -DUSE_LIBXML2 -DUSE_XERCES"
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/arabica}
77
78 install bin/libArabica.so $RPM_BUILD_ROOT%{_libdir}
79 find DOM SAX XML Utils -name \*.h -exec \
80         install -D '{}' $RPM_BUILD_ROOT%{_includedir}/arabica/'{}' \;
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc ChangeLog todo.txt
88 %attr(755,root,root) %{_libdir}/*.so
89
90 %files devel
91 %defattr(644,root,root,755)
92 %{_includedir}/arabica
This page took 0.069593 seconds and 3 git commands to generate.