]> git.pld-linux.org Git - packages/apache1-mod_auth_mysql.git/blob - apache1-mod_auth_mysql.spec
c31893491194a8924c63e3d50ebf853d3bb25bf5
[packages/apache1-mod_auth_mysql.git] / apache1-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the MySQL authentication module for Apache
4 Name:           apache-mod_%{mod_name}
5 Version:        2.20a
6 Release:        1
7 License:        GPL
8 Group:          Networking/Daemons
9 Source0:        http://web.oyvax.com/src/mod_auth_mysql-%{version}.tar.gz
10 URL:            http://www.diegonet.com/support/mod_auth_mysql.shtml
11 BuildRequires:  mysql-devel
12 BuildRequires:  %{apxs}
13 BuildRequires:  apache(EAPI)-devel
14 Prereq:         %{_sbindir}/apxs
15 Requires:       apache(EAPI)
16 Requires:       apache-mod_auth
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
20
21 %description
22 This is an authentication module for Apache that allows you to
23 authenticate HTTP clients using mysql RDBMS.
24
25 %description -l cs
26 Balíèek mod_auth_mysql slou¾í pro omezení pøístupu k dokumentùm, které
27 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
28 MySQL.
29
30 %description -l de
31 mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
32 Web- Server bediente Dokumente zu beschränken, indem es die Daten in
33 einer MySQL-Datenbank prüft.
34
35 %description -l es
36 mod_auth_mysql puede usarse para limitar el acceso a documentos
37 servidos por un servidor web verificando datos en una base de datos
38 MySQL.
39
40 %description -l fr
41 mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
42 servis par un serveur Web en vérifiant les données dans une base de
43 données MySQL.
44
45 %description -l it
46 mod_auth_mysql può essere usato per limitare l'accesso a documenti
47 serviti da un server Web controllando i dati in un database MySQL.
48
49 %description -l ja
50 mod_auth_mysql ¤Ï¡¢MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Ç¡¼¥¿¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
51 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
52 ¤¬¤Ç¤­¤Þ¤¹¡£
53
54 %description -l pl
55 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
56 klientów HTTP z u¿yciem bazy danych mysql.
57
58 %description -l pt_BR
59 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
60 MySQL.
61
62 %description -l sv
63 mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
64 servade av en webbserver genom att kontrollera data i en
65 MySQL-databas.
66
67 %prep
68 %setup -q -n mod_%{mod_name}-%{version}
69
70 %build
71 %{configure2_13} \
72         --with-apxs=%{apxs} \
73         --with-mysql=%{_prefix}
74
75 %{apxs} -c -I %{_includedir}/mysql mod_%{mod_name}.c -o mod_%{mod_name}.so
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT%{_pkglibdir}
80
81 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
82
83 gzip -9nf README README-2.20a USAGE
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post
89 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
90 if [ -f /var/lock/subsys/httpd ]; then
91         /etc/rc.d/init.d/httpd restart 1>&2
92 fi
93
94 %preun
95 if [ "$1" = "0" ]; then
96         %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
97         if [ -f /var/lock/subsys/httpd ]; then
98                 /etc/rc.d/init.d/httpd restart 1>&2
99         fi
100 fi
101
102 %files
103 %defattr(644,root,root,755)
104 %doc *.gz
105 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.234444 seconds and 2 git commands to generate.