]> git.pld-linux.org Git - packages/apache1-mod_auth_checkpasswd.git/blob - apache1-mod_auth_checkpasswd.spec
c526259ff80505c7a8c6421da9862c74906cd61f
[packages/apache1-mod_auth_checkpasswd.git] / apache1-mod_auth_checkpasswd.spec
1 %define         mod_name        auth_checkpasswd
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the CHECKPASSWD authentication module for Apache
4 Summary(pl):    To jest modu³ Apache autentykuj±cy przez CHECKPASSWD
5 Name:           apache-mod_%{mod_name}
6 Version:        1.0
7 Release:        4
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  7f699981ada026656affe2e35409bdf2
12 Patch0:         %{name}-aplog.patch
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache(EAPI)-devel
15 Prereq:         %{_sbindir}/apxs
16 Requires:       apache(EAPI)
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
20
21 %description
22 This is an authentication module for Apache that uses an external
23 application compatible with DJB's "checkpasswd". The application may
24 be setuid, which gives you a possibility to verify passwords using
25 regular /etc/shadow.
26
27 %description -l pl
28 To jest modu³ autentykuj±cy dla Apache który wykorzystuje zewnêtrzn±
29 aplikacjê kompatybiln± z "checkpasswd" DJB. Aplikacja mo¿e byæ
30 suidowana, co daje mo¿liwo¶æ weryfikowania hase³ wykorzystuj±c zwyk³y
31 plik /etc/shadow.
32
33 %prep
34 %setup -q -c -n "mod_%{mod_name}-%{version}"
35 %patch -p1
36
37 %build
38 %{apxs} \
39         -c mod_%{mod_name}.c \
40         -o mod_%{mod_name}.so
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{_pkglibdir}
45
46 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
47
48 %post
49 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
50 if [ -f /var/lock/subsys/httpd ]; then
51         /etc/rc.d/init.d/httpd restart 1>&2
52 fi
53
54 %preun
55 if [ "$1" = "0" ]; then
56         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
57         if [ -f /var/lock/subsys/httpd ]; then
58                 /etc/rc.d/init.d/httpd restart 1>&2
59         fi
60 fi
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README
68 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.060968 seconds and 2 git commands to generate.