]> git.pld-linux.org Git - packages/apache1-mod_auth_checkpasswd.git/blob - apache1-mod_auth_checkpasswd.spec
- sed -e "s/%{_sbindir}\/apxs -e/\%{apxs} -e/"
[packages/apache1-mod_auth_checkpasswd.git] / apache1-mod_auth_checkpasswd.spec
1 %define         mod_name        auth_checkpasswd
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the CHECKPASSWD authentication module for Apache
4 Summary(pl):    To jest modu³ Apache autentykuj±cy przez CHECKPASSWD
5 Name:           apache-mod_%{mod_name}
6 Version:        1.0
7 Release:        4
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        mod_%{mod_name}-%{version}.tar.gz
11 Patch0:         %{name}-aplog.patch
12 BuildRequires:  %{apxs}
13 BuildRequires:  apache(EAPI)-devel
14 Prereq:         %{_sbindir}/apxs
15 Requires:       apache(EAPI)
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
19
20 %description
21 This is an authentication module for Apache that uses an external
22 application compatibile with DJB's "checkpasswd". The application may
23 be setuid, which gives you a possibility to verify passwords using
24 regular /etc/shadow.
25
26 %description -l pl
27 To jest modu³ autentykuj±cy dla Apache który wykorzystuje zewnêtrzn±
28 aplikacjê kompatybiln± z "checkpasswd" DJB. Aplikacja mo¿e byæ
29 suidowana, co daje mo¿liwo¶æ weryfikowania hase³ wykorzystuj±c zwyk³y
30 plik /etc/shadow.
31
32 %prep
33 %setup -q -c -n "mod_%{mod_name}-%{version}"
34 %patch -p1
35
36 %build
37 %{apxs} \
38         -c mod_%{mod_name}.c \
39         -o mod_%{mod_name}.so
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{_pkglibdir}
44
45 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
46
47 %post
48 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
49 if [ -f /var/lock/subsys/httpd ]; then
50         /etc/rc.d/init.d/httpd restart 1>&2
51 fi
52
53 %preun
54 if [ "$1" = "0" ]; then
55         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
56         if [ -f /var/lock/subsys/httpd ]; then
57                 /etc/rc.d/init.d/httpd restart 1>&2
58         fi
59 fi
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README
67 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.065302 seconds and 3 git commands to generate.