]> git.pld-linux.org Git - packages/apache.git/commitdiff
- from upstream, prefork: log an error instead of segfaulting when child auto/th/apache-2_2_11-4 auto/ti/apache-2_2_11-4
authorhawk <hawk@pld-linux.org>
Fri, 13 Feb 2009 12:20:41 +0000 (12:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  startup fails due to pollset creation failures

Changed files:
    apache-pollset-segv.patch -> 1.1
    apache.spec -> 1.553

apache-pollset-segv.patch [new file with mode: 0644]
apache.spec

diff --git a/apache-pollset-segv.patch b/apache-pollset-segv.patch
new file mode 100644 (file)
index 0000000..e0ac8e0
--- /dev/null
@@ -0,0 +1,17 @@
+--- server/mpm/prefork/prefork.c       2009/01/12 11:37:23     733697
++++ server/mpm/prefork/prefork.c       2009/01/12 11:37:32     733698
+@@ -517,8 +517,12 @@
+     (void) ap_update_child_status(sbh, SERVER_READY, (request_rec *) NULL);
+     /* Set up the pollfd array */
+-    /* ### check the status */
+-    (void) apr_pollset_create(&pollset, num_listensocks, pchild, 0);
++    status = apr_pollset_create(&pollset, num_listensocks, pchild, 0);
++    if (status != APR_SUCCESS) {
++        ap_log_error(APLOG_MARK, APLOG_EMERG, status, ap_server_conf,
++                     "Couldn't create pollset in child; check system or user limits");
++        clean_child_exit(APEXIT_CHILDSICK); /* assume temporary resource issue */
++    }
+     for (lr = ap_listeners, i = num_listensocks; i--; lr = lr->next) {
+         apr_pollfd_t pfd = { 0 };
index ba319c2357895419dbcec7b1f86e7fc2d256c9c2..29c9fc6df16ef590e8f9d5878249c09798544ddc 100644 (file)
@@ -34,7 +34,7 @@ Summary(ru.UTF-8):    Самый популярный веб-сервер
 Summary(tr.UTF-8):     Lider WWW tarayıcı
 Name:          apache
 Version:       2.2.11
-Release:       3
+Release:       4
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
@@ -93,6 +93,7 @@ Patch21:      httpd-peruser.patch
 Patch23:       %{name}-suexec_fcgi.patch
 Patch24:       %{name}-revert-bug-40463.patch
 Patch25:       %{name}-prefork-graceful-fix.patch
+Patch26:       %{name}-pollset-segv.patch
 URL:           http://httpd.apache.org/
 BuildRequires: apr-devel >= 1:1.2
 BuildRequires: apr-util-devel >= 1:1.3
@@ -1751,6 +1752,7 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch23 -p1
 %patch24 -p1
 %patch25 -p0
+%patch26 -p0
 
 # using system apr, apr-util and pcre
 rm -rf srclib/{apr,apr-util,pcre}
This page took 0.103879 seconds and 4 git commands to generate.