]> git.pld-linux.org Git - packages/apache-mod_suphp.git/blob - apache-mod_suphp.spec
- previous commit reverted (mistake)
[packages/apache-mod_suphp.git] / apache-mod_suphp.spec
1 #
2 # Available build options:
3 %bcond_with     checkpath       # enable check if php execution is within DOCUMENT_ROOT of the vhost
4 #
5 %define         mod_name        suphp
6 %define         apxs            /usr/sbin/apxs
7 Summary:        Apache module: suPHP - execute PHP scripts with the permissions of their owners
8 Summary(pl.UTF-8):      Moduł do apache: suPHP - uruchamianie skryptów PHP z uprawnieniami ich właścicieli
9 Name:           apache-mod_%{mod_name}
10 Version:        0.6.3
11 Release:        1
12 License:        GPL
13 Group:          Networking/Daemons/HTTP
14 Source0:        http://www.suphp.org/download/%{mod_name}-%{version}.tar.gz
15 # Source0-md5:  756e8893857fefed087a89959a87645a
16 Source1:        %{name}.logrotate
17 Source2:        %{name}.conf
18 Source3:        %{name}-suphp.conf
19 Patch0:         %{name}-apr.patch
20 Patch1:         %{name}-compiler-flags.patch
21 Patch2:         %{name}-apache_version.patch
22 URL:            http://www.suphp.org/
23 BuildRequires:  %{apxs}
24 BuildRequires:  apache-devel >= 2.0.52-2
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  rpmbuild(macros) >= 1.268
29 Requires:       apache(modules-api) = %apache_modules_api
30 Requires:       php-cgi
31 Conflicts:      logrotate < 3.7-4
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
35 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
36
37 %description
38 suPHP is a tool for executing PHP scripts with the permissions of
39 their owners. It consists of an Apache module (mod_suphp) and a setuid
40 root binary (suphp) that is called by the Apache module to change the
41 uid of the process executing the PHP interpreter.
42
43 %description -l pl.UTF-8
44 suPHP jest narzędziem pozwalającym na wykonywanie skryptów w PHP z
45 uprawnieniami ich właścicieli. Składa się z modułu (mod_suphp) oraz
46 programu (suphp) z ustawionym bitem suid, który uruchamiany jest przez
47 moduł w celu zmiany uid procesu uruchamiającego interpreter PHP.
48
49 %prep
50 %setup -q -n %{mod_name}-%{version}
51 %patch0 -p1
52 %patch1 -p1
53 %patch2 -p1
54
55 %build
56 %{__aclocal}
57 %{__autoconf}
58 %{__autoheader}
59 %{__automake}
60 APACHE_VERSION=$(rpm -q --qf '%{V}' apache-devel); export APACHE_VERSION
61 %configure \
62         --%{?with_checkpath:en}%{!?with_checkpath:dis}able-checkpath \
63         --with-apache-user=http \
64         --with-min-uid=500 \
65         --with-min-gid=1000 \
66         --with-apxs=%{apxs} \
67         --disable-checkuid \
68         --disable-checkgid \
69         --with-setid-mode=owner \
70         --with-logfile=/var/log/httpd/suphp_log
71
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT{%{_sbindir},%{apachelibdir},%{_datadir}/suphp}
77 install -d $RPM_BUILD_ROOT%{apacheconfdir}
78
79 install src/suphp $RPM_BUILD_ROOT%{_sbindir}
80 install src/apache2/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{apachelibdir}
81 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/70_mod_%{mod_name}.conf
82 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{mod_name}.conf
83
84 install -d $RPM_BUILD_ROOT/etc/logrotate.d
85 install %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/apache-mod_suphp
86
87 install doc/suphp.conf-example $RPM_BUILD_ROOT%{_datadir}/suphp
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post
93 %service -q httpd restart
94
95 %postun
96 if [ "$1" = "0" ]; then
97         %service -q httpd restart
98 fi
99
100 %files
101 %defattr(644,root,root,755)
102 %doc README AUTHORS ChangeLog doc
103 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
104 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{mod_name}.conf
105 %attr(755,root,root) %{apachelibdir}/*.so
106 %attr(4755,root,root) %{_sbindir}/suphp
107 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
108 %dir %{_datadir}/suphp
109 %{_datadir}/suphp/*
This page took 0.070579 seconds and 4 git commands to generate.