]> git.pld-linux.org Git - packages/apache-mod_python.git/commitdiff
This commit was manufactured by cvs2git to create branch 'VER3'.
authorcvs2git <feedback@pld-linux.org>
Fri, 1 Nov 2002 11:45:15 +0000 (11:45 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Sprout from master 2002-11-01 11:45:15 UTC serek <serek@pld-linux.org> '- for third version of mod_python, currently beta4.'
Delete:
    apache-mod_python-DESTDIR.patch
    apache-mod_python-Makefile-in.patch
    apache-mod_python-cleanup.patch
    apache-mod_python-shared.patch
    apache-mod_python-static-lib-dir-fix.patch

apache-mod_python-DESTDIR.patch [deleted file]
apache-mod_python-Makefile-in.patch [deleted file]
apache-mod_python-cleanup.patch [deleted file]
apache-mod_python-shared.patch [deleted file]
apache-mod_python-static-lib-dir-fix.patch [deleted file]

diff --git a/apache-mod_python-DESTDIR.patch b/apache-mod_python-DESTDIR.patch
deleted file mode 100644 (file)
index e1ee7db..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
---- mod_python-2.6.4/Makefile.in.wiget Tue Dec 12 19:23:28 2000
-+++ mod_python-2.6.4/Makefile.in       Tue Dec 12 19:25:51 2000
-@@ -90,7 +90,8 @@
-       @echo
-       @echo "Performing DSO installation."
-       @echo
--      $(INSTALL) src/mod_python.so $(LIBEXECDIR)
-+      $(INSTALL) -d $(DESTDIR)$(LIBEXECDIR)
-+      $(INSTALL) src/mod_python.so $(DESTDIR)$(LIBEXECDIR)
-       @$(MAKE) install_py_lib
-       @echo
-       @echo "Now don't forget to edit your main config and add"
-@@ -123,12 +124,12 @@
-       @echo
- install_py_lib:
--      $(INSTALL) -d $(PY_STD_LIB)/site-packages/mod_python
-+      $(INSTALL) -d $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python
-       @for f in `ls lib/python/mod_python/*.py`; \
-       do \
--              $(INSTALL) $$f $(PY_STD_LIB)/site-packages/mod_python; \
-+              $(INSTALL) $$f $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python; \
-       done
--      python $(PY_STD_LIB)/compileall.py $(PY_STD_LIB)/site-packages/mod_python
-+      python $(PY_STD_LIB)/compileall.py $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python
- clean:
-       cd src && $(MAKE) clean
diff --git a/apache-mod_python-Makefile-in.patch b/apache-mod_python-Makefile-in.patch
deleted file mode 100644 (file)
index e6e9a64..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -uNr mod_python-2.7.6/Makefile.in mod_python-2.7.6.orig/Makefile.in
-+++ mod_python-2.7.6/Makefile.in       Wed Feb  6 09:49:05 2002
---- mod_python-2.7.6.orig/Makefile.in  Wed Feb  6 09:47:01 2002
-@@ -120,7 +120,7 @@
-       do \
-               $(INSTALL) $$f $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python; \
-       done
-+      python $(PY_STD_LIB)/compileall.pyc $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python
--      python $(PY_STD_LIB)/compileall.py $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python
- clean:
-       cd src && $(MAKE) clean
diff --git a/apache-mod_python-cleanup.patch b/apache-mod_python-cleanup.patch
deleted file mode 100644 (file)
index c591b23..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-Index: mod_python/lib/python/mod_python/apache.py
-===================================================================
-RCS file: /home/devel/CVS/rhn/modules/mod_python/lib/python/mod_python/apache.py,v
-retrieving revision 1.4
-diff -u -r1.4 apache.py
---- mod_python/lib/python/mod_python/apache.py 2 Aug 2001 22:52:50 -0000       1.4
-+++ mod_python/lib/python/mod_python/apache.py 28 Feb 2002 02:57:53 -0000
-@@ -58,10 +58,6 @@
- # variable stores the last PythonPath in raw (unevaled) form.
- _path = None
--# this is used in Request.__init__
--def _cleanup_request(_req):
--    _req._Request = None
--
- class Request:
-     """ This is a normal Python Class that can be subclassed.
-         However, most of its functionality comes from a built-in
-@@ -73,11 +69,6 @@
-         # look at __setattr__ if changing this line!
-         self._req = _req
-         
--        # this will decrement the reference to the _req
--        # object at cleanup time. If we don't do this, we
--        # get a cirular reference and _req never gets destroyed.
--        _req.register_cleanup(_cleanup_request, _req)
--
-     def __getattr__(self, attr):
-         try:
-             return getattr(self._req, attr)
-@@ -129,6 +120,7 @@
-         # is there a Request object for this request?
-         if not _req._Request:
-+            # warning, creating circular reference here
-             _req._Request = Request(_req)
-             
-         req = _req._Request
-@@ -239,6 +231,10 @@
-                                           htype=htype, hname=handler, debug=debug)
-             finally:
-                 exc_traceback = None
-+
-+        if htype == "PythonCleanupHandler":
-+            # destroy the circular reference
-+            _req._Request = req = None
-       return result
diff --git a/apache-mod_python-shared.patch b/apache-mod_python-shared.patch
deleted file mode 100644 (file)
index 1c04d9d..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- mod_python-2.6.4/configure.in.wiget        Tue Dec 12 19:08:13 2000
-+++ mod_python-2.6.4/configure.in      Tue Dec 12 19:13:21 2000
-@@ -187,7 +187,7 @@
- if test -z "$PYTHON_SRC"; then
-   PyLIBP=${PyEXEC_INSTALLDIR}/lib/python${PyVERSION}
-   PyLIBPL=${PyLIBP}/config
--  PyPYTHONLIBS=${PyLIBPL}/libpython${PyVERSION}.a
-+  PyPYTHONLIBS="-L${PyLIBPL} -lpython${PyVERSION}"
-   PyLIBS=`grep "^LIB[[SMC]]=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' '   '`
-   PyMODLIBS=`grep "^LOCALMODLIBS=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' '   '`
-   PY_LIBS="${PyPYTHONLIBS} ${PyLIBS} ${PyMODLIBS}"
diff --git a/apache-mod_python-static-lib-dir-fix.patch b/apache-mod_python-static-lib-dir-fix.patch
deleted file mode 100644 (file)
index ad17e8d..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- mod_python-2.7.8/configure.in      Mon Jun 11 21:16:25 2001
-+++ mod_python-2.7.8.new/configure.in  Wed Oct 16 16:11:36 2002
-@@ -242,7 +242,8 @@
- if test -z "$PYTHON_SRC"; then
-   PyLIBP=${PyEXEC_INSTALLDIR}/lib/python${PyVERSION}
-   PyLIBPL=${PyLIBP}/config
--  PyPYTHONLIBS=${PyLIBPL}/libpython${PyVERSION}.a
-+  # PyPYTHONLIBS=${PyLIBPL}/libpython${PyVERSION}.a
-+  PyPYTHONLIBS=/usr/lib/libpython${PyVERSION}.a
-   PyLIBS=`grep "^LIB[[SMC]]=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' '   '`
-   PyMODLIBS=`grep "^LOCALMODLIBS=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' '   '`
-   PY_LIBS="${PyPYTHONLIBS} ${PyLIBS} ${PyMODLIBS}"
This page took 0.143875 seconds and 4 git commands to generate.