]> git.pld-linux.org Git - packages/apache-mod_python.git/commitdiff
- added %{apxs} local macro to avoid adapter problems
authorankry <ankry@pld-linux.org>
Sun, 17 Feb 2002 19:01:43 +0000 (19:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix use of %{apxs} and %{_sbindir}/apxs
- added BR %{apxs} & Prereq %{_sbindir}/apxs (if necessary); removed BR apache

Changed files:
    apache-mod_python.spec -> 1.22

apache-mod_python.spec

index aa9739029efc98ccbd1575211c40a864019ce038..c990550adbe677ccf37e653f250ac7e979d96265 100644 (file)
@@ -1,5 +1,6 @@
 %include       /usr/lib/rpm/macros.python
 %define                mod_name        python
+%define        apxs            /usr/sbin/apxs
 Summary:       An embedded Python interpreter for the Apache Web server
 Summary(cs):   VestavìnĂ˝ interpret Pythonu pro WWW server Apache
 Summary(da):   En indbygget Python-fortolker for webtjeneren Apache
@@ -43,15 +44,16 @@ Patch2:             apache-mod_python-Makefile-in.patch
 URL:           http://www.modpython.org/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: apache
 BuildRequires: apache-devel
 BuildRequires: python-devel >= 2.2
 BuildRequires: rpm-pythonprov
+BuildRequires: %{apxs}
+Prereq:                %{_sbindir}/apxs
 Requires:      apache
 %requires_eq   python
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                apache_moddir   %(/usr/sbin/apxs -q LIBEXECDIR)
+%define                apache_moddir   %(%{apxs} -q LIBEXECDIR)
 
 %description
 Mod_python is a module that embeds the Python language interpreter
@@ -150,7 +152,7 @@ autoconf
 # new apache needs it
 CFLAGS="-DEAPI %{rpmcflags}"
 %configure \
-       --with-apxs=/usr/sbin/apxs
+       --with-apxs=%{apxs}
 
 %{__make} dso
 
@@ -166,14 +168,14 @@ gzip -9nf README COPYRIGHT NEWS CREDITS
 rm -rf $RPM_BUILD_ROOT
 
 %post
-/usr/sbin/apxs -e -a -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
+%{_sbindir}/apxs -e -a -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       /usr/sbin/apxs -e -A -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
+       %{_sbindir}/apxs -e -A -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
This page took 0.032766 seconds and 4 git commands to generate.