]> git.pld-linux.org Git - packages/apache-mod_fastcgi.git/blob - apache-mod_fastcgi.spec
605befa470920cd08f30c559f0e6877214c63cd1
[packages/apache-mod_fastcgi.git] / apache-mod_fastcgi.spec
1 %define         mod_name        fastcgi
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Support for the FastCGI protocol for apache webserver
4 Summary(pl):    Obs³uga protoko³u FastCGI dla serwera apache
5 Summary(ru):    FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
6 Summary(uk):    FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
7 Name:           apache-mod_%{mod_name}
8 # NOTE: remember about apache1-mod_fastcgi.spec when messing here
9 Version:        2.4.2
10 Release:        6
11 License:        distributable
12 Group:          Networking/Daemons
13 Source0:        http://www.FastCGI.com/dist/mod_%{mod_name}-%{version}.tar.gz
14 # Source0-md5:  e994414304b535cb99e10b7d1cad1d1e
15 Patch0:         %{name}-apr1.patch
16 Patch1:         %{name}-allow-uid-gid.patch
17 Patch2:         %{name}-socketdir.patch
18 Source1:        %{name}.conf
19 URL:            http://www.FastCGI.com/
20 BuildRequires:  %{apxs}
21 BuildRequires:  apache-devel >= 2
22 BuildRequires:  libtool
23 Requires(post,preun):   %{apxs}
24 Requires:       apache >= 2
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
28 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
29 # FIXME /var/run/httpd, but apache.spec owns /var/run/apache, so fix there first.
30 %define         _socketdir      /var/run/apache/fastcgi
31
32 %description
33 This 3rd party module provides support for the FastCGI protocol.
34 FastCGI is a language independent, scalable, open extension to CGI
35 that provides high performance and persistence without the limitations
36 of server specific APIs.
37
38 %description -l pl
39 To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
40 niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
41 du¿± wydajno¶æ bez ograniczania API specyficznego dla serwera.
42
43 %description -l ru
44 FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
45 ×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
46 ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
47
48 óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
49
50 %description -l uk
51 FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
52 ×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
53 ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
54
55 û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
56
57 %prep
58 %setup -q -n mod_%{mod_name}-%{version}
59 %patch0 -p1
60 %patch1 -p1
61 %patch2 -p1
62
63 %build
64 %{__make} -f Makefile.AP2 \
65         top_dir=%{_pkglibdir} \
66         INCLUDES="-I%(%{apxs} -q INCLUDEDIR)"
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf,%{_socketdir}/dynamic}
71
72 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
73 install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd.conf/
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 if [ -f /var/lock/subsys/httpd ]; then
80         /etc/rc.d/init.d/httpd restart 1>&2
81 else
82         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache HTTP daemon."
83 fi
84
85 %preun
86 if [ "$1" = "0" ]; then
87         if [ -f /var/lock/subsys/httpd ]; then
88                 /etc/rc.d/init.d/httpd restart 1>&2
89         fi
90 fi
91
92 %files
93 %defattr(644,root,root,755)
94 %doc docs/LICENSE.TERMS CHANGES docs/*.html
95 %attr(755,root,root) %{_pkglibdir}/*.so
96 %config %{_sysconfdir}/httpd.conf/*.conf
97 %dir %attr(770,root,http) %{_socketdir}
98 %dir %attr(770,root,http) %{_socketdir}/dynamic
This page took 0.022328 seconds and 2 git commands to generate.