]> git.pld-linux.org Git - packages/apache-mod_fastcgi.git/blob - apache-mod_fastcgi.spec
- release 3: finished unifications, dropped apache1 bcond (->apache1-*.spec)
[packages/apache-mod_fastcgi.git] / apache-mod_fastcgi.spec
1 %define         mod_name        fastcgi
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Support for the FastCGI protocol for apache webserver
4 Summary(pl):    Obs³uga protoko³u FastCGI dla serwera apache
5 Summary(ru):    FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
6 Summary(uk):    FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
7 Name:           apache-mod_%{mod_name}
8 Version:        2.4.2
9 Release:        3
10 License:        distributable
11 Group:          Networking/Daemons
12 Source0:        http://www.FastCGI.com/dist/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  e994414304b535cb99e10b7d1cad1d1e
14 Patch0:         %{name}-allow-uid-gid.patch
15 Source1:        %{name}.conf
16 URL:            http://www.FastCGI.com/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache-devel >= 2
19 BuildRequires:  libtool
20 Requires(post,preun):   %{apxs}
21 Requires:       apache >= 2
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
26
27 %description
28 This 3rd party module provides support for the FastCGI protocol.
29 FastCGI is a language independent, scalable, open extension to CGI
30 that provides high performance and persistence without the limitations
31 of server specific APIs.
32
33 %description -l pl
34 To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
35 niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
36 du¿± wydajno¶æ bez ograniczania API specyficznego dla serwera.
37
38 %description -l ru
39 FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
40 ×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
41 ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
42
43 óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
44
45 %description -l uk
46 FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
47 ×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
48 ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
49
50 û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
51
52 %prep
53 %setup -q -n mod_%{mod_name}-%{version}
54 %patch0 -p1
55
56 %build
57 %{__make} -f Makefile.AP2 \
58         top_dir=%{_pkglibdir} \
59         INCLUDES="-I%(%{apxs} -q INCLUDEDIR)"
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
64
65 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
66 install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd.conf/
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post
72 if [ -f /var/lock/subsys/httpd ]; then
73         /etc/rc.d/init.d/httpd restart 1>&2
74 else
75         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
76  
77 %preun
78 if [ "$1" = "0" ]; then
79         if [ -f /var/lock/subsys/httpd ]; then
80                 /etc/rc.d/init.d/httpd restart 1>&2
81         fi
82 fi
83  
84 %files
85 %defattr(644,root,root,755)
86 %doc docs/LICENSE.TERMS CHANGES docs/*.html
87 %attr(755,root,root) %{_pkglibdir}/*.so
88 %config %{_sysconfdir}/httpd.conf/*.conf
This page took 0.211727 seconds and 3 git commands to generate.