]> git.pld-linux.org Git - packages/apache-mod_bt.git/blob - apache-mod_bt.spec
- corrections when awake
[packages/apache-mod_bt.git] / apache-mod_bt.spec
1 %define         mod_name        bt
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache BitTorrent tracker
4 Name:           apache-mod_%{mod_name}
5 Version:        0.0.4
6 Release:        1
7 License:        GPL
8 Group:          Networking/Daemons
9 Source0: http://www.crackerjack.net/mod_%{mod_name}/mod_%{mod_name}-0.0.4.tgz
10 # Source0-md5:  dfb1f1a1aaae3313d8e1056a3d317740
11 Patch0: %{name}-paths.patch
12 URL:            http://www.crackerjack.net/mod_bt/
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache-devel
15 BuildRequires:  db-devel >= 4.2.52
16 Requires(post,preun):   %{apxs}
17 Requires:       apache
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
21
22 %description
23 Apache-based BitTorrent Tracker
24
25 %prep
26 %setup -q -n mod_%{mod_name}-%{version}
27 %patch0 -p1
28
29 %build
30 %{__make}
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT%{_pkglibdir}
35
36 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %post
42 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
43 if [ -f /var/lock/subsys/httpd ]; then
44         /etc/rc.d/init.d/httpd restart 1>&2
45 fi
46
47 %preun
48 if [ "$1" = "0" ]; then
49         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
50         if [ -f /var/lock/subsys/httpd ]; then
51                 /etc/rc.d/init.d/httpd restart 1>&2
52         fi
53 fi
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README
58 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.111311 seconds and 3 git commands to generate.