]> git.pld-linux.org Git - packages/apache-mod_auth_any.git/blob - apache-mod_auth_any.spec
- added %{apxs} local macro to avoid adapter problems
[packages/apache-mod_auth_any.git] / apache-mod_auth_any.spec
1 %define         mod_name        auth_any
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Basic authentication for the Apache Web server using arbitrary shell commands
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí shellových pøíkazù
5 Summary(da):    En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
6 Summary(de):    Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
7 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
8 Summary(it):    Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
9 Summary(no):    En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
10 Summary(pl):    Podstawowy modu³ autentykacji dla Apache, u¿ywaj±cy poleceñ pow³oki
11 Summary(pt):    Um módulo de autenticação de LDAP para o servidor Web Apache
12 Summary(sl):    Osnovna avtentikacija za spletni stre¾nik Apache, z uporabo poljubnih lupinskih ukazov
13 Summary(sv):    Grundläggande autentisering för webbservern Apache med valfria skalkommandon
14 Name:           apache-mod_%{mod_name}
15 Version:        1.2.1
16 Release:        1
17 License:        GPL
18 Group:          Networking/Daemons
19 Group(cs):      Sí»ové/Démoni
20 Group(da):      Netværks/Dæmoner
21 Group(de):      Netzwerkwesen/Server
22 Group(es):      Red/Servidores
23 Group(fr):      Réseau/Serveurs
24 Group(is):      Net/Púkar
25 Group(it):      Rete/Demoni
26 Group(no):      Nettverks/Daemoner
27 Group(pl):      Sieciowe/Serwery
28 Group(pt):      Rede/Servidores
29 Group(ru):      óÅÔØ/äÅÍÏÎÙ
30 Group(sl):      Omre¾ni/Stre¾niki
31 Group(sv):      Nätverk/Demoner
32 Group(uk):      íÅÒÅÖÁ/äÅÍÏÎÉ
33 Source0:        ftp://ftp.itlab.musc.edu/pub/toolbox/mod_%{mod_name}/mod_%{mod_name}-%{version}.tar.gz
34 URL:            http://www.itlab.musc.edu/~nafees/mod_%{mod_name}.html
35 Prereq:         %{_sbindir}/apxs
36 Requires:       apache(EAPI)
37 BuildRequires:  %{apxs}
38 BuildRequires:  apache(EAPI)-devel
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
42
43 %description
44 This module allows you to use any command line program (such as
45 webNIS) to authenticate a user.
46
47 %description -l cs
48 Balíèek mod_auth_any slou¾í pro omezení pøístupu k dokumentùm, které
49 poskytuje WWW server Apache. Jména a hesla jsou kontrolována pomocí
50 jakéhokoliv pøíkazu (jeho návratovým kódem).
51
52 %description -l de
53 Mod_auth_any kann verwendet werden, um den Zugriff auf von einem Web-
54 Server bediente Dokumente zu beschränken, indem es den Rückcode eines
55 gegebenen arbiträren Befehls prüft.
56
57 %description -l es
58 Mod_auth_any puede usarse para limitar el acceso a documentos servidos
59 desde un servidor web verificando el código de retorno de un comando
60 arbitrario especificado.
61
62 %description -l fr
63 Mod_auth_any peut être utilisé pour limiter l'accès à des documents
64 servis par un serveur Web en vérifiant le code de retour d'une
65 commande spécifiée arbitraire.
66
67 %description -l it
68 Mod_auth_any può essere utilizzato per limitare l'accesso ai documenti
69 serviti da un server Web controllando il codice di ritorno di un dato
70 comando arbitrario.
71
72 %description -l ja
73 Mod_auth_any ¤ÏǤ°Õ¤Ë»ØÄꤵ¤ì¤¿¥³¥Þ¥ó¥É¤ÎÌá¤ê¥³¡¼¥É¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
74 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
75 ¤¬¤Ç¤­¤Þ¤¹¡£
76
77 %description -l pl
78 Ten modu³ pozwala na u¿ycie dowolnego programu dzia³aj±cego z linii
79 poleceñ (jak np. webNIS) do autentykacji u¿ytkownika.
80
81 %description -l sv
82 Mod_auth_any kan användas för att begränsa åtkomsten till dokument
83 servade av en webbserver genom att kontrollera returkoden från ett
84 godtyckligt angivet kommando.
85
86 %prep
87 %setup -q -n mod_%{mod_name}-%{version}
88
89 %build
90 %{apxs} -c src/mod_%{mod_name}.c -o mod_%{mod_name}.so
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{_pkglibdir}
95
96 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
97
98 gzip -9nf docs/*
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post
104 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
105 if [ -f /var/lock/subsys/httpd ]; then
106         /etc/rc.d/init.d/httpd restart 1>&2
107 fi
108
109 %preun
110 if [ "$1" = "0" ]; then
111         %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
112         if [ -f /var/lock/subsys/httpd ]; then
113                 /etc/rc.d/init.d/httpd restart 1>&2
114         fi
115 fi
116
117 %files
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_pkglibdir}/*
120 %doc docs/*.gz
This page took 0.059115 seconds and 3 git commands to generate.