]> git.pld-linux.org Git - packages/antlr.git/blob - antlr.spec
- bcond's desc fixed.
[packages/antlr.git] / antlr.spec
1 # TODO: Move antlr-java to separate package ?
2 #
3 # Conditional build:
4 %bcond_with     javac   # use javac instead of gcj
5 #
6 Summary:        ANother Tool for Language Recognition
7 Summary(pl):    Jeszcze jedno narzêdzie do rozpoznawania jêzyka
8 Name:           antlr
9 Version:        2.7.4
10 Release:        1
11 License:        Public Domain
12 Group:          Development/Tools
13 Source0:        http://www.antlr.org/download/%{name}-%{version}.tar.gz
14 # Source0-md5:  33df7cdc8e80447cdd78607c76f02bac
15 URL:            http://www.antlr.org/
16 BuildRequires:  automake
17 %if !%{with javac}
18 BuildRequires:  gcc-java
19 BuildRequires:  gcc-java-tools
20 %else
21 BuildRequires:  jar
22 BuildRequires:  jdk
23 Requires:       jre
24 %endif
25 Conflicts:      pccts < 1.33MR33-6
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 ANTLR, ANother Tool for Language Recognition, (formerly PCCTS) is a language
30 tool that provides a framework for constructing recognizers, compilers, and
31 translators from grammatical descriptions containing Java, C#, or C++ actions.
32 ANTLR is popular because it is easy to understand, powerful, flexible,
33 generates human-readable output, and comes with complete source. ANTLR provides
34 excellent support for tree construction, tree walking, and translation. 
35
36 %description -l pl
37 ANTLR (ANother Tool for Language Recognition; poprzednio znane jako
38 PCCTS) to narzêdzie jêzykowe dostarczaj±ce szkielet do tworzenia
39 programów rozpoznaj±cych jêzyki, kompilatorów, translatorów z opisów
40 gramatycznych obejmuj±cych Javê, C# lub C++. ANTLR jest popularne
41 poniewa¿ jest ³atwe do zrozumienia, potê¿ne, elastyczne, generuje
42 wyj¶cie czytelne dla cz³owieka i jest dostêpne z pe³nymi ¼ród³ami.
43 ANTLR ma ¶wietne wsparcie dla tworzenia drzew, przechodzenia po
44 drzewach oraz translacji.
45
46 %prep
47 %setup -q
48
49 %build
50 #export CLASSPATH=$RPM_BUILD_DIR/%{name}-%{version}
51
52 cp -f /usr/share/automake/config.sub scripts
53
54 %configure \
55         %{?with_javac:CLASSPATH=`pwd`} \
56         %{!?with_javac:--enable-gcj}
57
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc doc/*
72 %attr(755,root,root) %{_bindir}/antlr
73 %attr(755,root,root) %{_bindir}/antlr-config
74 %{!?with_javac:%attr(755,root,root) %{_bindir}/antlr-java}
75 %{_includedir}/%{name}
76 %{_libdir}/libantlr.a
77 %{_datadir}/%{name}-2.7.3
This page took 0.167221 seconds and 3 git commands to generate.