]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- BR: gettext-devel
[packages/amarok.git] / amarok.spec
1 # TODO
2 # - try not to link with static mysql
3
4 %define         state   stable
5 %define         qtver   4.5.3
6 %define         kdever  4.3.3
7
8 Summary:        A KDE audio player
9 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
10 Name:           amarok
11 Version:        2.2.1
12 Release:        2
13 License:        GPL
14 Group:          X11/Applications/Multimedia
15 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
16 # Source0-md5:  4f6f45f0c25f85f2a2a1fff169ac7193
17 Patch0:         %{name}-link.patch
18 Patch1:         %{name}-qthreadpool.patch
19 URL:            http://amarok.kde.org/
20 BuildRequires:  Qt3Support-devel >= %{qtver}
21 BuildRequires:  QtCore-devel >= %{qtver}
22 BuildRequires:  QtDBus-devel >= %{qtver}
23 BuildRequires:  QtDesigner-devel >= %{qtver}
24 BuildRequires:  QtNetwork-devel >= %{qtver}
25 BuildRequires:  QtOpenGL-devel >= %{qtver}
26 BuildRequires:  QtScript-devel >= %{qtver}
27 BuildRequires:  QtSql-devel >= %{qtver}
28 BuildRequires:  QtSvg-devel >= %{qtver}
29 BuildRequires:  QtTest-devel >= %{qtver}
30 BuildRequires:  QtUiTools-devel >= %{qtver}
31 BuildRequires:  QtWebKit-devel >= %{qtver}
32 BuildRequires:  QtXml-devel >= %{qtver}
33 BuildRequires:  automoc4
34 BuildRequires:  cmake >= 2.6.1-2
35 BuildRequires:  curl-devel
36 BuildRequires:  gettext-devel
37 BuildRequires:  giflib-devel
38 BuildRequires:  glib2-devel
39 BuildRequires:  kde4-kdebase-devel >= %{kdever}
40 BuildRequires:  kde4-kdemultimedia-devel >= %{kdever}
41 BuildRequires:  libgpod-devel >= 0.7.0
42 BuildRequires:  libifp-devel >= 1.0.0.2
43 BuildRequires:  liblastfm-devel
44 BuildRequires:  libmtp-devel >= 0.3.0
45 BuildRequires:  libnjb-devel >= 2.2.4
46 BuildRequires:  libvisual-devel >= 0.4.0
47 BuildRequires:  loudmouth-devel
48 BuildRequires:  mpeg4ip-devel >= 1:1.6
49 BuildRequires:  mysql-devel >= 5.1.31-3
50 BuildRequires:  pcre-devel
51 BuildRequires:  pkgconfig
52 BuildRequires:  qca-devel
53 BuildRequires:  qt4-build >= %{qtver}
54 BuildRequires:  qt4-qmake >= %{qtver}
55 BuildRequires:  qtscriptbindings
56 BuildRequires:  rpm-pythonprov
57 BuildRequires:  rpmbuild(macros) >= 1.129
58 BuildRequires:  soprano-devel >= 2.1
59 BuildRequires:  strigi-devel >= 0.5.10
60 BuildRequires:  taglib-devel >= 1.6
61 BuildRequires:  taglib-extras-devel >= 1.0.0
62 BuildRequires:  utempter-devel
63 BuildRequires:  xorg-lib-libXpm-devel
64 Requires(post,postun):  /sbin/ldconfig
65 Requires:       kde4-kdebase-core
66 Requires:       kde4-kdemultimedia-audiocd
67 Requires:       kde4-phonon
68 Requires:       qtscriptbindings
69 Suggests:       libvisual-plugin-actor-JESS
70 Suggests:       libvisual-plugin-actor-bumpscope
71 Suggests:       libvisual-plugin-actor-corona
72 Suggests:       libvisual-plugin-actor-flower
73 Suggests:       libvisual-plugin-actor-gdkpixbuf
74 Suggests:       libvisual-plugin-actor-gforce
75 Suggests:       libvisual-plugin-actor-gstreamer
76 Suggests:       libvisual-plugin-actor-infinite
77 Suggests:       libvisual-plugin-actor-jakdaw
78 Suggests:       libvisual-plugin-actor-lv_analyzer
79 Suggests:       libvisual-plugin-actor-lv_gltest
80 Suggests:       libvisual-plugin-actor-lv_scope
81 Suggests:       libvisual-plugin-actor-madspin
82 Suggests:       libvisual-plugin-actor-nastyfft
83 Suggests:       libvisual-plugin-actor-oinksie
84 Suggests:       libvisual-plugin-input-alsa
85 Suggests:       libvisual-plugin-input-esd
86 Suggests:       libvisual-plugin-input-jack
87 Suggests:       libvisual-plugin-input-mplayer
88 Suggests:       libvisual-plugin-morph-alphablend
89 Suggests:       libvisual-plugin-morph-flash
90 Suggests:       libvisual-plugin-morph-slide
91 Suggests:       libvisual-plugin-morph-tentacle
92 Obsoletes:      amarok-arts
93 Obsoletes:      amarok-xmms
94 # It should require mysql-embeded
95 Requires:       mysql >= 5.1.31-3
96 Conflicts:      mysql < 5.1.31-3
97 # sr@Latn vs. sr@latin
98 Conflicts:      glibc-misc < 6:2.7
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %description
102 A KDE audio player.
103
104 %description -l pl.UTF-8
105 Odtwarzacz audio dla KDE.
106
107 %package scripts
108 Summary:        amaroK scripts
109 Summary(pl.UTF-8):      Skrypty amaroKa
110 Group:          X11/Applications/Multimedia
111 Requires:       %{name} = %{version}-%{release}
112 Requires:       kde4-kdebase-kdialog
113
114 %description scripts
115 amaroK scripts allow you extend amaroK functionality.
116
117 You can learn more about scripts in amaroK from here:
118 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
119
120 %description scripts -l pl.UTF-8
121 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
122
123 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
124 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
125
126 %prep
127 %setup -q
128 #%patch0 -p0
129 #%patch1 -p0
130
131 %build
132 install -d build
133 cd build
134 %cmake \
135         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
136         -DLIB_INSTALL_DIR=%{_libdir} \
137         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
138 %if "%{_lib}" == "lib64"
139         -DLIB_SUFFIX=64 \
140 %endif
141         ../
142
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147
148 %{__make} -C build install \
149         DESTDIR=$RPM_BUILD_ROOT \
150         kde_htmldir=%{_kdedocdir} \
151         kde_libs_htmldir=%{_kdedocdir}
152
153 # remove bogus dir
154 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
155
156 %find_lang %{name} --with-kde
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post           -p /sbin/ldconfig
162 %postun         -p /sbin/ldconfig
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 %doc AUTHORS ChangeLog README
167 %attr(755,root,root) %{_bindir}/amarok
168 %attr(755,root,root) %{_bindir}/amarokpkg
169 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
170 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
171 %attr(755,root,root) %{_bindir}/amarok_afttagger
172 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
173 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
175 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
176 %attr(755,root,root) %{_libdir}/strigi/strigita_audible.so
177 %attr(755,root,root) %{_libdir}/strigi/strigita_mp4.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
179 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
180 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
181 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
182 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
192 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
193 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
194 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
195 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
203 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
204 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
205 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
206 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
207 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
208 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
209 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
210 %attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
211 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
212 %dir %{_datadir}/apps/amarok
213 %attr(755,root,root) %{_libdir}/libamaroklib.so
214 %attr(755,root,root) %{_libdir}/libamarokocsclient.so
215 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.4
216 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.4.3.0
217 %attr(755,root,root) %{_libdir}/libamarokpud.so
218 %dir %{_datadir}/apps/amarok/scripts
219 %{_datadir}/apps/amarok/data
220 %{_datadir}/apps/amarok/icons
221 %{_datadir}/apps/amarok/images
222 %{_datadir}/apps/amarok/amarok.notifyrc
223 %{_datadir}/apps/desktoptheme
224 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
225 %{_datadir}/config.kcfg/amarokconfig.kcfg
226 %{_datadir}/config/amarok.knsrc
227 %{_datadir}/config/amarokapplets.knsrc
228 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
229 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
230 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
231 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
232 %{_datadir}/dbus-1/interfaces/org.kde.amarok.SqlCollection.xml
233 %{_datadir}/kde4/services/amarok.protocol
234 %{_datadir}/kde4/services/amaroklastfm.protocol
235 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
236 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
237 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
238 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
239 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
240 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
241 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
242 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
243 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
244 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
245 %{_datadir}/kde4/services/amarok_service_ampache.desktop
246 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
247 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
248 %{_datadir}/kde4/services/amarok_service_lastfm.desktop
249 %{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
250 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
251 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
252 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
253 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
254 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
255 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
256 %{_datadir}/kde4/services/amarok_massstorage-device.desktop
257 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
258 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
259 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
260 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
261 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
262 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
263 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
264 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
265 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
266 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
267 %{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
268 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
269 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
270 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
271 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
272 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
273 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
274 %{_desktopdir}/kde4/amarok.desktop
275 %{_iconsdir}/*/*/apps/amarok.*
276 %{_datadir}/config/amarok_homerc
277
278 %files scripts
279 %defattr(644,root,root,755)
280 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
281 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
282 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
283 %dir %{_datadir}/apps/amarok/scripts/script_console
284 %{_datadir}/apps/amarok/scripts/script_console/main.js
285 %{_datadir}/apps/amarok/scripts/script_console/script.spec
286 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
287 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
288 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
289 %dir %{_datadir}/apps/amarok/scripts/librivox_service
290 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
291 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
292 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
293 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
294 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
295 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
296 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
297 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.08081 seconds and 3 git commands to generate.