]> git.pld-linux.org Git - packages/amanda.git/commitdiff
- fix missing extern for global var auto/th/amanda-3.5.1-4
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 9 May 2021 08:40:43 +0000 (10:40 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 9 May 2021 08:40:43 +0000 (10:40 +0200)
- use libtirpc for RPC support
- rel 4

amanda.spec
missing-extern.patch [new file with mode: 0644]
tirpc.patch [new file with mode: 0644]

index 065a78b0696f4c92cdae866d4d64f1b64c376859..1f732f810064b7eee91a5026942c750bc253d409 100644 (file)
@@ -12,7 +12,7 @@ Summary:      A network-capable tape backup solution
 Summary(pl.UTF-8):     Sieciowo zorientowany system tworzenia kopii zapasowych
 Name:          amanda
 Version:       3.5.1
-Release:       3
+Release:       4
 License:       BSD
 Group:         Networking/Utilities
 Source0:       http://downloads.sourceforge.net/amanda/%{name}-%{version}.tar.gz
@@ -41,6 +41,8 @@ Patch8:               %{name}-ac.patch
 Patch9:                %{name}-krb5-auth.patch
 Patch10:       swig.patch
 Patch11:       krb5-ac.patch
+Patch12:       missing-extern.patch
+Patch13:       tirpc.patch
 URL:           http://www.amanda.org/
 %{?with_samba:BuildRequires:   /usr/bin/smbclient}
 BuildRequires: autoconf >= 2.64
@@ -54,6 +56,7 @@ BuildRequires:        heimdal-devel
 BuildRequires: rpmbuild(macros) >= 1.654
 # curl is broken, see curl-config --libs (c8cba693)
 BuildRequires: keyutils-devel
+BuildRequires: libtirpc-devel
 BuildRequires: libtool
 BuildRequires: libxslt-progs
 BuildRequires: ncurses-devel
@@ -213,6 +216,8 @@ typu streamer).
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
+%patch12 -p1
+%patch13 -p1
 cp -a %{SOURCE10} .
 
 find perl/ -name '*.swg' -print0 | xargs -0 touch
diff --git a/missing-extern.patch b/missing-extern.patch
new file mode 100644 (file)
index 0000000..be384ff
--- /dev/null
@@ -0,0 +1,11 @@
+--- amanda-3.5.1/common-src/testutils.h~       2017-12-01 14:26:28.000000000 +0100
++++ amanda-3.5.1/common-src/testutils.h        2021-05-09 10:32:10.263953946 +0200
+@@ -75,7 +75,7 @@
+ #define tu_dbg(...) if (tu_debugging_enabled) { g_fprintf(stderr, __VA_ARGS__); }
+ /* Is debugging enabled for this test run? (set internally) */
+-int tu_debugging_enabled;
++extern int tu_debugging_enabled;
+ /*
+  * Main loop
diff --git a/tirpc.patch b/tirpc.patch
new file mode 100644 (file)
index 0000000..11d3480
--- /dev/null
@@ -0,0 +1,100 @@
+diff --git a/config/amanda/amanda_configure.m4 b/config/amanda/amanda_configure.m4
+index 5b427ae..f90810f 100644
+--- a/config/amanda/amanda_configure.m4
++++ b/config/amanda/amanda_configure.m4
+@@ -18,7 +18,6 @@ AC_PREREQ(2.64)
+ # Take care of some early Amanda-specific setup
+ #
+ AMANDA_CONFIGURE_ARGS
+-AMANDA_INIT_SUMMARY
+ AMANDA_SNAPSHOT_STAMP
+ AMANDA_SPLIT_VERSION
+ AMANDA_CONFIG_LOCAL
+diff --git a/config/amanda/components.m4 b/config/amanda/components.m4
+index f2a07db..7628453 100644
+--- a/config/amanda/components.m4
++++ b/config/amanda/components.m4
+@@ -186,7 +186,21 @@ AC_DEFUN([AMANDA_WITHOUT_NDMP], [
+           n | no) WANT_NDMP=false;;
+           *) AC_MSG_ERROR([You must not supply an argument to --with-ndmp option.]) ;;
+           esac
+-      ])
++    ])
++    AC_CHECK_HEADERS(rpc/rpc.h, HAVE_RPC_RPC_H=1)
++    if test x"$WANT_NDMP" = x"true"; then
++      if test x"$HAVE_RPC_RPC_H" = x"1"; then
++          WANT_NDMP=true
++      else
++          AMANDA_CHECK_TIRPC
++          if test x"$HAVE_RPC_RPC_H" = x"1"; then
++              WANT_NDMP=true
++          else
++              WANT_NDMP=false
++              AMANDA_MSG_WARN([Disabling NDMP because rpc/rpc.h is not found])
++          fi
++      fi
++   fi
+ ])
+ # SYNOPSIS
+diff --git a/config/amanda/libs.m4 b/config/amanda/libs.m4
+index 0388c9b..a640557 100644
+--- a/config/amanda/libs.m4
++++ b/config/amanda/libs.m4
+@@ -183,6 +183,44 @@ AC_DEFUN([AMANDA_CHECK_GLIB], [
+     AMANDA_ADD_LIBS($GLIB_LIBS)
+ ])
++# SYNOPSIS
++#
++#   AMANDA_CHECK_TIRPC
++#
++# OVERVIEW
++#
++#   Search for tirpc.
++#
++AC_DEFUN([AMANDA_CHECK_TIRPC],
++[
++    AC_PATH_PROG(PKG_CONFIG, pkg-config, [], $LOCSYSPATH:/opt/csw/bin:/usr/local/bin:/opt/local/bin)
++
++    tirpc_ld_flags=`$PKG_CONFIG libtirpc --libs-only-L 2>/dev/null`
++    tirpc_lib_flags=`$PKG_CONFIG libtirpc --libs-only-l --libs-only-other 2>/dev/null`
++    tirpc_cppflags=`$PKG_CONFIG libtirpc --cflags-only-I 2>/dev/null`
++    tirpc_cflags=`$PKG_CONFIG libtirpc --cflags-only-other 2>/dev/null`
++
++    _libtirpc_save_cppflags=$CPPFLAGS
++    CPPFLAGS="$CPPFLAGS $tirpc_cppflags"
++    _libtirpc_save_libs=$LIBS
++    LIBS="$LIBS $tirpc_lib_flags"
++
++    unset HAVE_RPC_RPC_H
++    unset ac_cv_header_rpc_rpc_h
++    AC_CHECK_HEADERS(rpc/rpc.h, HAVE_RPC_RPC_H=1)
++
++    CPPFLAGS=$_libtirpc_save_cppflags
++    LIBS=$_libtirpc_save_libs
++
++    if test x"$HAVE_RPC_RPC_H" = x"1"; then
++      AMANDA_ADD_LDFLAGS($tirpc_ld_flags)
++      AMANDA_ADD_LIBS($tirpc_lib_flags)
++
++      AMANDA_ADD_CPPFLAGS($tirpc_cppflags)
++      AMANDA_ADD_CFLAGS($tirpc_cflags)
++    fi
++])
++
+ # LIBCURL_CHECK_CONFIG is from the libcurl
+ # distribution and licensed under the BSD license:
+ # Copyright (c) 1996 - 2007, Daniel Stenberg, <daniel@haxx.se>.
+diff --git a/configure.ac b/configure.ac
+index 89c4890..8d325b7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -13,6 +13,7 @@ AMANDA_VERSION
+ gl_EARLY
+ gl_INIT
++AMANDA_INIT_SUMMARY
+ AMANDA_CONFIGURE
+ AC_DEFINE([USE_GETTEXT], 1, [Define to 1 if files will be processed with gettextize])
This page took 0.123875 seconds and 4 git commands to generate.