]> git.pld-linux.org Git - packages/amanda.git/commitdiff
- rel 4 auto/th/amanda-3_2_3-4
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 3 Apr 2012 10:04:45 +0000 (10:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix building with glib2 2.32

Changed files:
    amanda-glib2.32.patch -> 1.1
    amanda.spec -> 1.222

amanda-glib2.32.patch [new file with mode: 0644]
amanda.spec

diff --git a/amanda-glib2.32.patch b/amanda-glib2.32.patch
new file mode 100644 (file)
index 0000000..2108d85
--- /dev/null
@@ -0,0 +1,30 @@
+--- amanda-3.2.3/common-src/glib-util.c~       2010-12-08 23:09:29.000000000 +0100
++++ amanda-3.2.3/common-src/glib-util.c        2012-04-03 12:02:32.801046078 +0200
+@@ -120,6 +120,7 @@
+ }
+ #endif
++#if (GLIB_MAJOR_VERSION < 2 || (GLIB_MAJOR_VERSION == 2 && GLIB_MINOR_VERSION < 32))
+ void g_queue_free_full(GQueue * queue) {
+     while (!g_queue_is_empty(queue)) {
+         gpointer data;
+@@ -128,6 +129,7 @@
+     }
+     g_queue_free(queue);
+ }
++#endif
+ void g_ptr_array_free_full(GPtrArray * array) {
+     size_t i;
+--- amanda-3.2.3/common-src/glib-util.h~       2010-12-08 23:09:29.000000000 +0100
++++ amanda-3.2.3/common-src/glib-util.h        2012-04-03 12:03:14.514381294 +0200
+@@ -72,7 +72,9 @@
+ /* These functions all take a GLib container, and call free() on all the
+  * pointers in the container before free()ing the container itself. */
++#if (GLIB_MAJOR_VERSION < 2 || (GLIB_MAJOR_VERSION == 2 && GLIB_MINOR_VERSION < 32))
+ void g_queue_free_full(GQueue * queue);
++#endif
+ void g_ptr_array_free_full(GPtrArray * array);
+ /* g_value_compare() does what you expect. It returns TRUE if and
index a98e6e67a51fea1e8d147ae35d970e9ec9f04c2c..25d78009b3be4a639ed7829fb52b559d2869ef0f 100644 (file)
@@ -10,7 +10,7 @@ Summary:      A network-capable tape backup solution
 Summary(pl.UTF-8):     Sieciowo zorientowany system tworzenia kopii zapasowych
 Name:          amanda
 Version:       3.2.3
-Release:       3
+Release:       4
 License:       BSD
 Group:         Networking/Utilities
 Source0:       http://downloads.sourceforge.net/amanda/%{name}-%{version}.tar.gz
@@ -36,6 +36,7 @@ Patch9:               %{name}-ac.patch
 Patch10:       %{name}-amstar-exclude.patch
 Patch11:       %{name}-amstar-exclude-fix.patch
 Patch12:       %{name}-krb5-auth.patch
+Patch13:       %{name}-glib2.32.patch
 URL:           http://www.amanda.org/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
@@ -208,6 +209,7 @@ typu streamer).
 %patch10 -p2
 %patch11 -p1
 %patch12 -p1
+%patch13 -p1
 
 %build
 %{__aclocal} -I config -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
This page took 0.058764 seconds and 4 git commands to generate.