]> git.pld-linux.org Git - packages/allegro5.git/blob - allegro5.spec
flac rebuild
[packages/allegro5.git] / allegro5.spec
1 #
2 # TODO:
3 # - check if it's usable now
4 #
5 # Conditional build:
6 %bcond_without  alsa            # ALSA support in allegro_audio library
7 %bcond_with     curl            # cURL example
8 %bcond_without  doc             # rebuild HTML and texinfo documentation
9 %bcond_without  dumb            # MOD support in allegro_acodec library
10 %bcond_without  gtk             # (GTK+ 2.x based) native dialog library
11 %bcond_without  openal          # OpenAL support in allegro_audio library
12 %bcond_without  physfs          # PhysFS addon library
13 %bcond_without  pulseaudio      # PulseAudio support in allegro_audio library
14 %bcond_without  python          # Python wrapper
15 %bcond_with     sse             # SSE instructions usage
16 #
17 %ifarch pentium3 pentium4 %{x8664}
18 %define with_sse        1
19 %endif
20
21 Summary:        A game programming library
22 Summary(de.UTF-8):      Eine Bibliothek zur Programmierung von Spielen
23 Summary(es.UTF-8):      Una biblioteca de programación de juegos
24 Summary(fr.UTF-8):      Une librairie de programmation de jeux
25 Summary(it.UTF-8):      Una libreria per la programmazione di videogiochi
26 Summary(pl.UTF-8):      Biblioteka do programowania gier
27 Name:           allegro5
28 Version:        5.2.5.0
29 Release:        2
30 License:        Giftware
31 Group:          Libraries
32 #Source0Download: https://github.com/liballeg/allegro5/releases
33 Source0:        https://github.com/liballeg/allegro5/releases/download/%{version}/allegro-%{version}.tar.gz
34 # Source0-md5:  8bcc28c86878405bf7d069aa77008032
35 Patch0:         %{name}-glx.patch
36 URL:            https://liballeg.org/
37 %{?with_openal:BuildRequires:   OpenAL-devel}
38 BuildRequires:  OpenGL-GLU-devel
39 BuildRequires:  OpenGL-devel
40 %{?with_alsa:BuildRequires:     alsa-lib-devel}
41 BuildRequires:  cmake >= 2.6
42 %{?with_curl:BuildRequires:     curl-devel}
43 BuildRequires:  dumb-devel
44 BuildRequires:  flac-devel
45 BuildRequires:  freetype-devel >= 2
46 %{?with_gtk:BuildRequires:      glib2-devel >= 2.0}
47 %{?with_gtk:BuildRequires:      gtk+2-devel >= 2.0}
48 BuildRequires:  libjpeg-devel
49 BuildRequires:  libogg-devel
50 BuildRequires:  libpng-devel
51 BuildRequires:  libvorbis-devel
52 %{?with_physfs:BuildRequires:   physfs-devel}
53 BuildRequires:  pkgconfig
54 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9.15}
55 BuildRequires:  rpmbuild(macros) >= 1.605
56 BuildRequires:  xorg-lib-libX11-devel
57 BuildRequires:  xorg-lib-libXcursor-devel
58 BuildRequires:  xorg-lib-libXext-devel
59 BuildRequires:  xorg-lib-libXinerama-devel
60 BuildRequires:  xorg-lib-libXpm-devel
61 BuildRequires:  xorg-lib-libXrandr-devel
62 BuildRequires:  xorg-lib-libXxf86vm-devel
63 BuildRequires:  zlib-devel
64 %if %{with python}
65 BuildRequires:  python
66 BuildRequires:  python-modules
67 BuildRequires:  rpm-pythonprov
68 %endif
69 %if %{with doc}
70 BuildRequires:  ctags
71 BuildRequires:  pandoc >= 1.5
72 BuildRequires:  texinfo
73 BuildRequires:  texlive-latex
74 %endif
75 Obsoletes:      allegro5-tools
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %description
79 Allegro is a cross-platform library intended for use in computer games
80 and other types of multimedia programming.
81
82 %description -l de.UTF-8
83 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
84 Computerspielen und anderen Formen von Multinediaprogrammierung.
85
86 %description -l es.UTF-8
87 Allegro es una librería multi-plataforma creada para ser usada en la
88 programación de juegos u otro tipo de programación multimedia.
89
90 %description -l fr.UTF-8
91 Allegro est une librairie multi-plateforme destinée à être utilisée
92 dans les jeux vidéo ou d'autres types de programmation multimédia.
93
94 %description -l it.UTF-8
95 Allegro è una libreria multipiattaforma dedicata all'uso nei
96 videogiochi ed in altri tipi di programmazione multimediale.
97
98 %description -l pl.UTF-8
99 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
100 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
101
102 %package devel
103 Summary:        A game programming library - header files
104 Summary(es.UTF-8):      Archivos de inclusión
105 Summary(pl.UTF-8):      Biblioteka do programowania gier - pliki nagłówkowe
106 Group:          Development/Libraries
107 Requires:       %{name} = %{version}-%{release}
108
109 %description devel
110 Allegro is a cross-platform library intended for use in computer games
111 and other types of multimedia programming.
112
113 This package contains header files neccessary for compiling
114 applications using allegro library.
115
116 %description devel -l de.UTF-8
117 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
118 Computerspielen und anderen Formen von Multinediaprogrammierung.
119 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
120 verwenden.
121
122 %description devel -l es.UTF-8
123 Allegro es una librería multi-plataforma creada para ser usada en la
124 programación de juegos u otro tipo de programación multimedia. Este
125 paquete es necesario para compilar los programas que usen Allegro.
126
127 %description devel -l fr.UTF-8
128 Allegro est une librairie multi-plateforme destinée à être utilisée
129 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
130 package est nécessaire pour compiler les programmes utilisant Allegro.
131
132 %description devel -l it.UTF-8
133 Allegro è una libreria multipiattaforma dedicata all'uso nei
134 videogiochi ed in altri tipi di programmazione multimediale. Questo
135 pacchetto è necessario per compilare programmi scritti con Allegro.
136
137 %description devel -l pl.UTF-8
138 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
139 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
140
141 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
142 aplikacji wykorzystujących bibliotekę allegro.
143
144 %package acodec
145 Summary:        Allegro acodec addon library
146 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro acodec
147 Group:          Libraries
148 Requires:       %{name}-audio = %{version}-%{release}
149
150 %description acodec
151 Allegro acodec addon library.
152
153 %description acodec -l pl.UTF-8
154 Biblioteka dodatkowa Allegro acodec.
155
156 %package acodec-devel
157 Summary:        Header files for Allegro acodec addon library
158 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro acodec
159 Group:          Libraries
160 Requires:       %{name}-acodec = %{version}-%{release}
161 Requires:       %{name}-audio-devel = %{version}-%{release}
162
163 %description acodec-devel
164 Header files for Allegro acodec addon library.
165
166 %description acodec-devel -l pl.UTF-8
167 Pliki nagłówkowe biblioteki dodatkowej Allegro acodec.
168
169 %package audio
170 Summary:        Allegro audio addon library
171 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro audio
172 Group:          Libraries
173 Requires:       %{name} = %{version}-%{release}
174
175 %description audio
176 Allegro audio addon library.
177
178 %description audio -l pl.UTF-8
179 Biblioteka dodatkowa Allegro audio.
180
181 %package audio-devel
182 Summary:        Header files for Allegro audio addon library
183 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro audio
184 Group:          Libraries
185 Requires:       %{name}-audio = %{version}-%{release}
186 Requires:       %{name}-devel = %{version}-%{release}
187
188 %description audio-devel
189 Header files for Allegro audio addon library.
190
191 %description audio-devel -l pl.UTF-8
192 Pliki nagłówkowe biblioteki dodatkowej Allegro audio.
193
194 %package dialog
195 Summary:        Allegro dialog addon library
196 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro dialog
197 Group:          Libraries
198 Requires:       %{name} = %{version}-%{release}
199
200 %description dialog
201 Allegro dialog addon library.
202
203 %description dialog -l pl.UTF-8
204 Biblioteka dodatkowa Allegro dialog.
205
206 %package dialog-devel
207 Summary:        Header files for Allegro dialog addon library
208 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro dialog
209 Group:          Libraries
210 Requires:       %{name}-dialog = %{version}-%{release}
211 Requires:       %{name}-devel = %{version}-%{release}
212
213 %description dialog-devel
214 Header files for Allegro dialog addon library.
215
216 %description dialog-devel -l pl.UTF-8
217 Pliki nagłówkowe biblioteki dodatkowej Allegro dialog.
218
219 %package image
220 Summary:        Allegro image addon library
221 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro image
222 Group:          Libraries
223 Requires:       %{name} = %{version}-%{release}
224
225 %description image
226 Allegro image addon library.
227
228 %description image -l pl.UTF-8
229 Biblioteka dodatkowa Allegro image.
230
231 %package image-devel
232 Summary:        Header files for Allegro image addon library
233 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro image
234 Group:          Libraries
235 Requires:       %{name}-image = %{version}-%{release}
236 Requires:       %{name}-devel = %{version}-%{release}
237
238 %description image-devel
239 Header files for Allegro image addon library.
240
241 %description image-devel -l pl.UTF-8
242 Pliki nagłówkowe biblioteki dodatkowej Allegro image.
243
244 %package physfs
245 Summary:        Allegro physfs addon library
246 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro physfs
247 Group:          Libraries
248 Requires:       %{name} = %{version}-%{release}
249
250 %description physfs
251 Allegro physfs addon library.
252
253 %description physfs -l pl.UTF-8
254 Biblioteka dodatkowa Allegro physfs.
255
256 %package physfs-devel
257 Summary:        Header files for Allegro physfs addon library
258 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro physfs
259 Group:          Libraries
260 Requires:       %{name}-physfs = %{version}-%{release}
261 Requires:       %{name}-devel = %{version}-%{release}
262
263 %description physfs-devel
264 Header files for Allegro physfs addon library.
265
266 %description physfs-devel -l pl.UTF-8
267 Pliki nagłówkowe biblioteki dodatkowej Allegro physfs.
268
269 %package ttf
270 Summary:        Allegro ttf addon library
271 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro ttf
272 Group:          Libraries
273 Requires:       %{name} = %{version}-%{release}
274
275 %description ttf
276 Allegro ttf addon library.
277
278 %description ttf -l pl.UTF-8
279 Biblioteka dodatkowa Allegro ttf.
280
281 %package ttf-devel
282 Summary:        Header files for Allegro ttf addon library
283 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro ttf
284 Group:          Libraries
285 Requires:       %{name}-ttf = %{version}-%{release}
286 Requires:       %{name}-devel = %{version}-%{release}
287
288 %description ttf-devel
289 Header files for Allegro ttf addon library.
290
291 %description ttf-devel -l pl.UTF-8
292 Pliki nagłówkowe biblioteki dodatkowej Allegro ttf.
293
294 %package video
295 Summary:        Allegro audio addon library
296 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro audio
297 Group:          Libraries
298 Requires:       %{name}-audio = %{version}-%{release}
299
300 %description video
301 Allegro audio addon library.
302
303 %description video -l pl.UTF-8
304 Biblioteka dodatkowa Allegro audio.
305
306 %package video-devel
307 Summary:        Header files for Allegro video addon library
308 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro video
309 Group:          Libraries
310 Requires:       %{name}-audio-devel = %{version}-%{release}
311 Requires:       %{name}-video = %{version}-%{release}
312
313 %description video-devel
314 Header files for Allegro audio video library.
315
316 %description video-devel -l pl.UTF-8
317 Pliki nagłówkowe biblioteki dodatkowej Allegro video.
318
319 %package examples
320 Summary:        A game programming library - examples
321 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy przykładowe
322 Group:          Development/Libraries
323 Requires:       %{name} = %{version}-%{release}
324
325 %description examples
326 This package contains example programs which demonstrate allegro
327 features.
328
329 %description examples -l pl.UTF-8
330 Pakiet zawiera programy przykładowe demonstrujące możliwości
331 biblioteki allegro.
332
333 %package -n python-%{name}
334 Summary:        Python wrapper for Allegro library
335 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki Allegro
336 Group:          Development/Languages/Python
337 Requires:       %{name} = %{version}-%{release}
338 Requires:       python-modules
339
340 %description -n python-%{name}
341 Python wrapper for Allegro library.
342
343 %description -n python-%{name} -l pl.UTF-8
344 Pythonowy interfejs do biblioteki Allegro.
345
346 %prep
347 %setup -q -n allegro-%{version}
348 %patch0 -p1
349
350 %build
351 install -d build
352 cd build
353 %cmake .. \
354         -DMANDIR=%{_mandir} \
355         -DINFODIR=%{_infodir} \
356         -DWANT_TTF=ON \
357         %{!?with_sse:-DWANT_ALLOW_SSE=OFF} \
358         %{!?with_alsa:-DWANT_ALSA=OFF} \
359         %{?with_curl:-DWANT_CURL_EXAMPLE=ON} \
360         %{!?with_dumb:-DWANT_MODAUDIO=OFF} \
361         %{!?with_gtk:-DWANT_NATIVE_DIALOG=OFF} \
362         %{!?with_openal:-DWANT_OPENAL=OFF} \
363         %{!?with_physfs:-DWANT_PHYSFS=OFF} \
364         %{!?with_pulseaudio:-DWANT_PULSEAUDIO=OFF} \
365         %{?with_python:-DWANT_PYTHON_WRAPPER=ON}
366
367 %{__make}
368
369 %install
370 rm -rf $RPM_BUILD_ROOT
371 install -d $RPM_BUILD_ROOT%{_bindir}
372
373 %{__make} install -C build \
374         DESTDIR=$RPM_BUILD_ROOT
375
376 %if %{with python}
377 install -d $RPM_BUILD_ROOT%{py_sitescriptdir}
378 install build/python/allegro.py $RPM_BUILD_ROOT%{py_sitescriptdir}
379 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
380 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
381 %py_postclean
382 %endif
383
384 install -d $RPM_BUILD_ROOT%{_mandir}/man3
385 cp -p docs/man/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
386
387 # install examples
388 find build/examples -maxdepth 1 -perm 755 -name "ex*" -exec install {} $RPM_BUILD_ROOT%{_bindir} \;
389
390 %clean
391 rm -rf $RPM_BUILD_ROOT
392
393 %post   -p /sbin/ldconfig
394 %postun -p /sbin/ldconfig
395
396 %post   acodec -p /sbin/ldconfig
397 %postun acodec -p /sbin/ldconfig
398
399 %post   audio -p /sbin/ldconfig
400 %postun audio -p /sbin/ldconfig
401
402 %post   dialog -p /sbin/ldconfig
403 %postun dialog -p /sbin/ldconfig
404
405 %post   image -p /sbin/ldconfig
406 %postun image -p /sbin/ldconfig
407
408 %post   physfs -p /sbin/ldconfig
409 %postun physfs -p /sbin/ldconfig
410
411 %post   ttf -p /sbin/ldconfig
412 %postun ttf -p /sbin/ldconfig
413
414 %post   video -p /sbin/ldconfig
415 %postun video -p /sbin/ldconfig
416
417 %files
418 %defattr(644,root,root,755)
419 %doc CHANGES-5.0.txt CHANGES-5.1.txt CHANGES-5.2.txt README.txt docs/html/refman
420 %attr(755,root,root) %{_libdir}/liballegro.so.*.*.*
421 %attr(755,root,root) %ghost %{_libdir}/liballegro.so.5.2
422 %attr(755,root,root) %{_libdir}/liballegro_color.so.*.*.*
423 %attr(755,root,root) %ghost %{_libdir}/liballegro_color.so.5.2
424 %attr(755,root,root) %{_libdir}/liballegro_font.so.*.*.*
425 %attr(755,root,root) %ghost %{_libdir}/liballegro_font.so.5.2
426 %attr(755,root,root) %{_libdir}/liballegro_main.so.*.*.*
427 %attr(755,root,root) %ghost %{_libdir}/liballegro_main.so.5.2
428 %attr(755,root,root) %{_libdir}/liballegro_memfile.so.*.*.*
429 %attr(755,root,root) %ghost %{_libdir}/liballegro_memfile.so.5.2
430 %attr(755,root,root) %{_libdir}/liballegro_primitives.so.*.*.*
431 %attr(755,root,root) %ghost %{_libdir}/liballegro_primitives.so.5.2
432
433 %files devel
434 %defattr(644,root,root,755)
435 %attr(755,root,root) %{_libdir}/liballegro.so
436 %attr(755,root,root) %{_libdir}/liballegro_color.so
437 %attr(755,root,root) %{_libdir}/liballegro_font.so
438 %attr(755,root,root) %{_libdir}/liballegro_main.so
439 %attr(755,root,root) %{_libdir}/liballegro_memfile.so
440 %attr(755,root,root) %{_libdir}/liballegro_primitives.so
441 %{_includedir}/allegro5
442 %exclude %{_includedir}/allegro5/allegro_acodec.h
443 %exclude %{_includedir}/allegro5/allegro_audio.h
444 %exclude %{_includedir}/allegro5/allegro_image.h
445 %{?with_gtk:%exclude %{_includedir}/allegro5/allegro_native_dialog.h}
446 %{?with_physfs:%exclude %{_includedir}/allegro5/allegro_physfs.h}
447 %exclude %{_includedir}/allegro5/allegro_ttf.h
448 %exclude %{_includedir}/allegro5/allegro_video.h
449 %{_pkgconfigdir}/allegro-5.pc
450 %{_pkgconfigdir}/allegro_color-5.pc
451 %{_pkgconfigdir}/allegro_font-5.pc
452 %{_pkgconfigdir}/allegro_main-5.pc
453 %{_pkgconfigdir}/allegro_memfile-5.pc
454 %{_pkgconfigdir}/allegro_primitives-5.pc
455 %{_mandir}/man3/ALLEGRO_*.3*
456 %{_mandir}/man3/al_*.3*
457
458 %files acodec
459 %defattr(644,root,root,755)
460 %attr(755,root,root) %{_libdir}/liballegro_acodec.so.*.*.*
461 %attr(755,root,root) %ghost %{_libdir}/liballegro_acodec.so.5.2
462
463 %files acodec-devel
464 %defattr(644,root,root,755)
465 %attr(755,root,root) %{_libdir}/liballegro_acodec.so
466 %{_includedir}/allegro5/allegro_acodec.h
467 %{_pkgconfigdir}/allegro_acodec-5.pc
468
469 %files audio
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{_libdir}/liballegro_audio.so.*.*.*
472 %attr(755,root,root) %ghost %{_libdir}/liballegro_audio.so.5.2
473
474 %files audio-devel
475 %defattr(644,root,root,755)
476 %attr(755,root,root) %{_libdir}/liballegro_audio.so
477 %{_includedir}/allegro5/allegro_audio.h
478 %{_pkgconfigdir}/allegro_audio-5.pc
479
480 %if %{with gtk}
481 %files dialog
482 %defattr(644,root,root,755)
483 %attr(755,root,root) %{_libdir}/liballegro_dialog.so.*.*.*
484 %attr(755,root,root) %ghost %{_libdir}/liballegro_dialog.so.5.2
485
486 %files dialog-devel
487 %defattr(644,root,root,755)
488 %attr(755,root,root) %{_libdir}/liballegro_dialog.so
489 %{_includedir}/allegro5/allegro_native_dialog.h
490 %{_pkgconfigdir}/allegro_dialog-5.pc
491 %endif
492
493 %files image
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{_libdir}/liballegro_image.so.*.*.*
496 %attr(755,root,root) %ghost %{_libdir}/liballegro_image.so.5.2
497
498 %files image-devel
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_libdir}/liballegro_image.so
501 %{_includedir}/allegro5/allegro_image.h
502 %{_pkgconfigdir}/allegro_image-5.pc
503
504 %if %{with physfs}
505 %files physfs
506 %defattr(644,root,root,755)
507 %attr(755,root,root) %{_libdir}/liballegro_physfs.so.*.*.*
508 %attr(755,root,root) %ghost %{_libdir}/liballegro_physfs.so.5.2
509
510 %files physfs-devel
511 %defattr(644,root,root,755)
512 %attr(755,root,root) %{_libdir}/liballegro_physfs.so
513 %{_includedir}/allegro5/allegro_physfs.h
514 %{_pkgconfigdir}/allegro_physfs-5.pc
515 %endif
516
517 %files ttf
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{_libdir}/liballegro_ttf.so.*.*.*
520 %attr(755,root,root) %ghost %{_libdir}/liballegro_ttf.so.5.2
521
522 %files ttf-devel
523 %defattr(644,root,root,755)
524 %attr(755,root,root) %{_libdir}/liballegro_ttf.so
525 %{_includedir}/allegro5/allegro_ttf.h
526 %{_pkgconfigdir}/allegro_ttf-5.pc
527
528 %files video
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_libdir}/liballegro_video.so.*.*.*
531 %attr(755,root,root) %ghost %{_libdir}/liballegro_video.so.5.2
532
533 %files video-devel
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_libdir}/liballegro_video.so
536 %{_includedir}/allegro5/allegro_video.h
537 %{_pkgconfigdir}/allegro_video-5.pc
538
539 %files examples
540 %defattr(644,root,root,755)
541 %attr(755,root,root) %{_bindir}/ex_acodec
542 %attr(755,root,root) %{_bindir}/ex_acodec_multi
543 %attr(755,root,root) %{_bindir}/ex_android
544 %attr(755,root,root) %{_bindir}/ex_audio_chain
545 %attr(755,root,root) %{_bindir}/ex_audio_props
546 %attr(755,root,root) %{_bindir}/ex_audio_simple
547 %attr(755,root,root) %{_bindir}/ex_audio_timer
548 %attr(755,root,root) %{_bindir}/ex_bitmap
549 %attr(755,root,root) %{_bindir}/ex_bitmap_flip
550 %attr(755,root,root) %{_bindir}/ex_blend
551 %attr(755,root,root) %{_bindir}/ex_blend2
552 %attr(755,root,root) %{_bindir}/ex_blend_bench
553 %attr(755,root,root) %{_bindir}/ex_blend_target
554 %attr(755,root,root) %{_bindir}/ex_blend_test
555 %attr(755,root,root) %{_bindir}/ex_blit
556 %attr(755,root,root) %{_bindir}/ex_camera
557 %attr(755,root,root) %{_bindir}/ex_clip
558 %attr(755,root,root) %{_bindir}/ex_clipboard
559 %attr(755,root,root) %{_bindir}/ex_color
560 %attr(755,root,root) %{_bindir}/ex_color2
561 %attr(755,root,root) %{_bindir}/ex_compressed
562 %attr(755,root,root) %{_bindir}/ex_config
563 %attr(755,root,root) %{_bindir}/ex_convert
564 %attr(755,root,root) %{_bindir}/ex_cpu
565 %{?with_curl:%attr(755,root,root) %{_bindir}/ex_curl}
566 %attr(755,root,root) %{_bindir}/ex_depth_mask
567 %attr(755,root,root) %{_bindir}/ex_depth_target
568 %attr(755,root,root) %{_bindir}/ex_dir
569 %attr(755,root,root) %{_bindir}/ex_disable_screensaver
570 %attr(755,root,root) %{_bindir}/ex_display_events
571 %attr(755,root,root) %{_bindir}/ex_display_options
572 %attr(755,root,root) %{_bindir}/ex_draw
573 %attr(755,root,root) %{_bindir}/ex_draw_bitmap
574 %attr(755,root,root) %{_bindir}/ex_drawpixels
575 %attr(755,root,root) %{_bindir}/ex_dualies
576 %attr(755,root,root) %{_bindir}/ex_expose
577 %attr(755,root,root) %{_bindir}/ex_file
578 %attr(755,root,root) %{_bindir}/ex_file_slice
579 %attr(755,root,root) %{_bindir}/ex_filter
580 %attr(755,root,root) %{_bindir}/ex_font
581 %attr(755,root,root) %{_bindir}/ex_font_justify
582 %attr(755,root,root) %{_bindir}/ex_font_multiline
583 %attr(755,root,root) %{_bindir}/ex_fs_resize
584 %attr(755,root,root) %{_bindir}/ex_fs_window
585 %attr(755,root,root) %{_bindir}/ex_get_path
586 %attr(755,root,root) %{_bindir}/ex_gldepth
587 %attr(755,root,root) %{_bindir}/ex_glext
588 %attr(755,root,root) %{_bindir}/ex_haiku
589 %attr(755,root,root) %{_bindir}/ex_haptic
590 %attr(755,root,root) %{_bindir}/ex_haptic2
591 %attr(755,root,root) %{_bindir}/ex_icon
592 %attr(755,root,root) %{_bindir}/ex_icon2
593 %attr(755,root,root) %{_bindir}/ex_inject_events
594 %attr(755,root,root) %{_bindir}/ex_joystick_events
595 %attr(755,root,root) %{_bindir}/ex_joystick_hotplugging
596 %attr(755,root,root) %{_bindir}/ex_kcm_direct
597 %attr(755,root,root) %{_bindir}/ex_keyboard_events
598 %attr(755,root,root) %{_bindir}/ex_keyboard_focus
599 %attr(755,root,root) %{_bindir}/ex_lines
600 %attr(755,root,root) %{_bindir}/ex_loading_thread
601 %attr(755,root,root) %{_bindir}/ex_lockbitmap
602 %attr(755,root,root) %{_bindir}/ex_logo
603 %attr(755,root,root) %{_bindir}/ex_membmp
604 %attr(755,root,root) %{_bindir}/ex_memfile
605 %attr(755,root,root) %{_bindir}/ex_menu
606 %attr(755,root,root) %{_bindir}/ex_mixer_chain
607 %attr(755,root,root) %{_bindir}/ex_mixer_pp
608 %attr(755,root,root) %{_bindir}/ex_monitorinfo
609 %attr(755,root,root) %{_bindir}/ex_mouse
610 %attr(755,root,root) %{_bindir}/ex_mouse_cursor
611 %attr(755,root,root) %{_bindir}/ex_mouse_events
612 %attr(755,root,root) %{_bindir}/ex_mouse_focus
613 %attr(755,root,root) %{_bindir}/ex_mouse_warp
614 %attr(755,root,root) %{_bindir}/ex_multisample
615 %attr(755,root,root) %{_bindir}/ex_multisample_target
616 %attr(755,root,root) %{_bindir}/ex_multiwin
617 %attr(755,root,root) %{_bindir}/ex_native_filechooser
618 %attr(755,root,root) %{_bindir}/ex_nodisplay
619 %attr(755,root,root) %{_bindir}/ex_noframe
620 %attr(755,root,root) %{_bindir}/ex_opengl
621 %attr(755,root,root) %{_bindir}/ex_opengl_pixel_shader
622 %attr(755,root,root) %{_bindir}/ex_palette
623 %attr(755,root,root) %{_bindir}/ex_path
624 %attr(755,root,root) %{_bindir}/ex_path_test
625 %{?with_physfs:%attr(755,root,root) %{_bindir}/ex_physfs}
626 %attr(755,root,root) %{_bindir}/ex_pixelformat
627 %attr(755,root,root) %{_bindir}/ex_polygon
628 %attr(755,root,root) %{_bindir}/ex_premulalpha
629 %attr(755,root,root) %{_bindir}/ex_prim
630 %attr(755,root,root) %{_bindir}/ex_prim_shader
631 %attr(755,root,root) %{_bindir}/ex_projection
632 %attr(755,root,root) %{_bindir}/ex_projection2
633 %attr(755,root,root) %{_bindir}/ex_record
634 %attr(755,root,root) %{_bindir}/ex_record_name
635 %attr(755,root,root) %{_bindir}/ex_reparent
636 %attr(755,root,root) %{_bindir}/ex_resample_test
637 %attr(755,root,root) %{_bindir}/ex_resize
638 %attr(755,root,root) %{_bindir}/ex_resize2
639 %attr(755,root,root) %{_bindir}/ex_rotate
640 %attr(755,root,root) %{_bindir}/ex_saw
641 %attr(755,root,root) %{_bindir}/ex_scale
642 %attr(755,root,root) %{_bindir}/ex_shader
643 %attr(755,root,root) %{_bindir}/ex_shader_multitex
644 %attr(755,root,root) %{_bindir}/ex_shader_target
645 %attr(755,root,root) %{_bindir}/ex_stream_file
646 %attr(755,root,root) %{_bindir}/ex_stream_seek
647 %attr(755,root,root) %{_bindir}/ex_subbitmap
648 %attr(755,root,root) %{_bindir}/ex_synth
649 %attr(755,root,root) %{_bindir}/ex_threads
650 %attr(755,root,root) %{_bindir}/ex_threads2
651 %attr(755,root,root) %{_bindir}/ex_timedwait
652 %attr(755,root,root) %{_bindir}/ex_timer
653 %attr(755,root,root) %{_bindir}/ex_timer_pause
654 %attr(755,root,root) %{_bindir}/ex_touch_input
655 %attr(755,root,root) %{_bindir}/ex_transform
656 %attr(755,root,root) %{_bindir}/ex_ttf
657 %attr(755,root,root) %{_bindir}/ex_user_events
658 %attr(755,root,root) %{_bindir}/ex_utf8
659 %attr(755,root,root) %{_bindir}/ex_vertex_buffer
660 %attr(755,root,root) %{_bindir}/ex_video
661 %attr(755,root,root) %{_bindir}/ex_vsync
662 %attr(755,root,root) %{_bindir}/ex_window_constraints
663 %attr(755,root,root) %{_bindir}/ex_window_maximized
664 %attr(755,root,root) %{_bindir}/ex_windows
665 %attr(755,root,root) %{_bindir}/ex_window_title
666 %attr(755,root,root) %{_bindir}/ex_winfull
667
668 %if %{with python}
669 %files -n python-%{name}
670 %defattr(644,root,root,755)
671 %{py_sitescriptdir}/allegro.py[co]
672 %endif
This page took 0.207461 seconds and 4 git commands to generate.