]> git.pld-linux.org Git - packages/allegro-gl.git/blob - allegro-gl.spec
- proper GLU BR
[packages/allegro-gl.git] / allegro-gl.spec
1 Summary:        The Allegro game programming library GL backend
2 Summary(pl.UTF-8):      Wsparcie GL dla biblioteki do programowania gier Allegro
3 Name:           allegro-gl
4 Version:        0.4.0
5 Release:        1
6 License:        Giftware
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/allegrogl/alleggl-%{version}.tar.bz2
9 # Source0-md5:  43e5d123fa5c78ade8e9b486b4102998
10 URL:            http://allegrogl.sourceforge.net/
11 BuildRequires:  OpenGL-GLU-devel
12 BuildRequires:  allegro-devel >= 4.0.0
13 BuildRequires:  autoconf >= 2.53
14 BuildRequires:  automake
15 Requires:       allegro >= 4.0.0
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         specflags       -fomit-frame-pointer
19
20 %description
21 AllegroGL is a cross-platform GL backend for the Allegro library.
22
23 %description -l pl.UTF-8
24 AllegroGL jest przenośną biblioteką dodającą wsparcie GL
25 w aplikacjach używających biblioteki Allegro.
26
27 %package devel
28 Summary:        A game programming library - header files
29 Summary(pl.UTF-8):      Biblioteka do programowania gier - pliki nagłówkowe
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32 Requires:       allegro-devel >= 4.0.0
33
34 %description devel
35 AllegroGL is a cross-platform GL backend for the Allegro library.
36
37 This package contains header files neccessary for compiling
38 applications using AllegroGL library.
39
40 %description devel -l pl.UTF-8
41 AllegroGL jest przenośną biblioteką dodającą wsparcie GL
42 w aplikacjach używających biblioteki Allegro.
43
44 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
45 aplikacji wykorzystujących bibliotekę AllegroGL.
46
47 %prep
48 %setup -q -n alleggl
49
50 %build
51 %{__aclocal}
52 %{__autoconf}
53 %configure \
54         --enable-static \
55 %ifnarch %{ix86}
56         --disable-asm \
57         --disable-mmx \
58         --disable-sse
59 %endif
60
61 %{__make} lib \
62         CFLAGS="%{rpmcflags} -Wall -ffast-math"
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}{,/allegrogl{,/GLext}}}
67
68 install include/*.h $RPM_BUILD_ROOT%{_includedir}
69 install include/allegrogl/*.h $RPM_BUILD_ROOT%{_includedir}/allegrogl
70 install include/allegrogl/GLext/*.h $RPM_BUILD_ROOT%{_includedir}/allegrogl/GLext
71 install lib/unix/libagl.so $RPM_BUILD_ROOT%{_libdir}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %doc readme.txt todo.txt bugs.txt
82 %attr(755,root,root) %{_libdir}/libagl.so
83
84 %files devel
85 %defattr(644,root,root,755)
86 %doc howto.txt
87 %{_includedir}/*
This page took 0.066329 seconds and 3 git commands to generate.