]> git.pld-linux.org Git - packages/akonadi.git/blob - akonadi.spec
- rel 9; patches from FC
[packages/akonadi.git] / akonadi.spec
1 %define         snap            svn1057960
2 %define         qtver           4.8.1
3 Summary:        Akonadi - The PIM Storage Service
4 Summary(pl.UTF-8):      Akonadi - usługa przechowywania danych dla aplikacji PIM
5 Name:           akonadi
6 Version:        1.13.0
7 Release:        8
8 License:        GPL v2+
9 Group:          X11/Applications
10 Source0:        ftp://ftp.kde.org/pub/kde/stable/akonadi/src/%{name}-%{version}.tar.bz2
11 # Source0-md5:  84eb2e471bd6bdfe54a2a2f1d858c07d
12 # svn co svn://anonsvn.kde.org/home/kde/trunk/kdesupport/akonadi/
13 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
14 Patch1:         0001-FindSqlite-Use-CMAKE_FLAGS-the-right-way-in-try_comp.patch
15 Patch2:         0002-Do-not-enter-the-test-directories-if-AKONADI_BUILD_T.patch
16 Patch3:         0003-STORE-Allow-modifying-items-tags-via-Tag-RID-or-GID.patch
17 Patch4:         0004-Fix-typo-in-if-condition.patch
18 Patch5:         0005-Fix-buffer-overflow-in-AKTEST_FAKESERVER_MAIN.patch
19 Patch6:         0006-Don-t-crash-when-setmntent-returns-NULL.patch
20 Patch7:         0007-Don-t-call-insert-from-Q_ASSERT-breaks-unit-tests-in.patch
21 Patch8:         0008-Suppress-unused-variable-warnings-in-release-mode.patch
22 Patch9:         0009-Test-whether-compiler-supports-all-required-C-11-fea.patch
23 Patch10:        0010-prevent-starting-a-QTimer-with-a-negative-interval.patch
24 Patch11:        0011-Convert-some-qDebugs-to-akDebugs.patch
25 Patch12:        0012-Optimize-Reduce-the-amount-of-allocations-required-t.patch
26 Patch13:        0013-Intern-entity-strings-for-table-and-column-names.patch
27 Patch14:        0014-No-semicolon-after-Q_DECLARE_METATYPE.patch
28 Patch15:        0015-Use-QMutexLocker-instead-of-manual-lock-unlock-calls.patch
29 Patch16:        0016-Use-an-QAtomicInt-instead-of-a-plain-bool-for-Entity.patch
30 Patch17:        0017-Optimize-Only-do-one-hash-lookup-to-retrieve-value-f.patch
31 Patch18:        0018-Optimize-Skip-value-condition-on-invalid-flags.patch
32 Patch19:        0019-Optimize-queries-Do-not-retrieve-known-key-used-in-t.patch
33 Patch20:        0020-Avoid-ridiculous-amount-of-SQL-queries-by-caching-Pa.patch
34 Patch21:        0021-Implement-support-for-CASE.WHEN.THEN-SQL-statements-.patch
35 Patch22:        0022-Implement-cache-for-CollectionStatistics-to-signific.patch
36 Patch23:        0023-Always-create-a-new-PartType-when-it-does-not-exist.patch
37 Patch24:        0024-Fix-compilation-with-strict-iterators.patch
38 Patch25:        0025-Avoid-repeated-calls-to-PimItem-flags-and-PimItem-ta.patch
39 Patch26:        0026-Avoid-recursive-collection-listing-in-SearchHelper.patch
40 Patch27:        0027-Minor-improvements-in-StatisticsCache-as-suggested-b.patch
41 Patch28:        0028-Extend-imapparser-benchmark-and-keep-static-data-aro.patch
42 Patch29:        0029-Reduce-the-amount-of-allocations-by-preallocating-a-.patch
43 Patch30:        0030-Preallocate-a-capacity-of-16-for-the-returned-list.patch
44 URL:            http://pim.kde.org/akonadi/
45 BuildRequires:  QtCore-devel >= %{qtver}
46 BuildRequires:  QtDBus-devel >= %{qtver}
47 BuildRequires:  QtGui-devel >= %{qtver}
48 BuildRequires:  QtNetwork-devel >= %{qtver}
49 BuildRequires:  QtSql-devel >= %{qtver}
50 BuildRequires:  QtTest-devel >= %{qtver}
51 BuildRequires:  automoc4
52 BuildRequires:  boost-devel
53 #BuildRequires: clucene-core-devel >= 0.9.16a-2
54 BuildRequires:  cmake >= 2.8.0
55 BuildRequires:  libxslt-progs
56 BuildRequires:  qt4-build >= %{qtver}
57 BuildRequires:  qt4-qmake >= %{qtver}
58 BuildRequires:  rpmbuild(macros) >= 1.293
59 BuildRequires:  shared-mime-info
60 BuildRequires:  soprano-devel >= 2.4.64
61 Requires:       %{name}-libs = %{version}-%{release}
62 Requires:       QtSql-mysql
63 Requires:       mysql
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 Akonadi is a personal information management (PIM) framework for KDE
68 4.1 and newer. Akonadi will function as an extensible data storage for
69 all PIM applications.
70
71 Besides data storage, Akonadi has several other components including
72 search, and a library (cache) for easy access and notification of data
73 changes.
74
75 %description -l pl.UTF-8
76 Akonadi do szkielet zarządzania informacjami osobistymi (PIM) dla KDE
77 w wersji 4.1 i nowszych. Działa jako rozszerzalny system
78 przechowywania danych dla wszystkich aplikacji PIM.
79
80 Poza przechowywaniem danych Akonadi ma kilka innych komponentów, w tym
81 wyszukiwanie oraz bibliotekę (pamięć podręczną) w celu łatwego dostępu
82 i powiadamiania i zmianie danych.
83
84 %package devel
85 Summary:        Header files for Akonadi
86 Summary(pl.UTF-8):      Pliki nagłówkowe dla Akonadi
87 Group:          Development/Libraries
88 Requires:       %{name}-libs = %{version}-%{release}
89
90 %description devel
91 Header files needed to build Akonadi client libraries and
92 applications.
93
94 %description devel -l pl.UTF-8
95 Pliki nagłówkowe do tworzenia bibliotek klienckich i aplikacji
96 używających Akonadi.
97
98 %package libs
99 Summary:        Akonadi libraries
100 Summary(pl.UTF-8):      Biblioteki Akonadi
101 Group:          Libraries
102
103 %description libs
104 Akonadi libraries.
105
106 %description libs -l pl.UTF-8
107 Biblioteki Akonadi.
108
109 %prep
110 %setup -q
111 %patch1 -p1
112 %patch2 -p1
113 %patch3 -p1
114 %patch4 -p1
115 %patch5 -p1
116 %patch6 -p1
117 %patch7 -p1
118 %patch8 -p1
119 %patch9 -p1
120 %patch10 -p1
121 %patch11 -p1
122 %patch12 -p1
123 %patch13 -p1
124 %patch14 -p1
125 %patch15 -p1
126 %patch16 -p1
127 %patch17 -p1
128 %patch18 -p1
129 %patch19 -p1
130 %patch20 -p1
131 %patch21 -p1
132 %patch22 -p1
133 %patch23 -p1
134 %patch24 -p1
135 %patch25 -p1
136 %patch26 -p1
137 %patch27 -p1
138 %patch28 -p1
139 %patch29 -p1
140 %patch30 -p1
141
142 %build
143 install -d build
144 cd build
145 %cmake \
146         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
147         -DINSTALL_QSQLITE_IN_QT_PREFIX=%{_libdir}/qt4/plugins \
148         -DMYSQLD_EXECUTABLE=/usr/sbin/mysqld \
149 %if "%{_lib}" == "lib64"
150         -DLIB_SUFFIX=64 \
151 %endif
152         ..
153
154 %{__make}
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158
159 install -d $RPM_BUILD_ROOT%{_libdir}/kde4/akonadi
160
161 %{__make} -C build install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post   libs -p /sbin/ldconfig
168 %postun libs -p /sbin/ldconfig
169
170 %files
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_bindir}/akonadi_agent_launcher
173 %attr(755,root,root) %{_bindir}/akonadi_agent_server
174 %attr(755,root,root) %{_bindir}/akonadi_control
175 %attr(755,root,root) %{_bindir}/akonadi_rds
176 %attr(755,root,root) %{_bindir}/akonadictl
177 %attr(755,root,root) %{_bindir}/akonadiserver
178 %attr(755,root,root) %{_bindir}/asapcat
179 %dir %{_datadir}/config/akonadi
180 %{_datadir}/config/akonadi/mysql-global.conf
181 %{_datadir}/config/akonadi/mysql-global-mobile.conf
182 %{_datadir}/mime/packages/akonadi-mime.xml
183
184 %files libs
185 %defattr(644,root,root,755)
186 %dir %{_libdir}/kde4/akonadi
187 %attr(755,root,root) %ghost %{_libdir}/libakonadiprotocolinternals.so.?
188 %attr(755,root,root) %{_libdir}/libakonadiprotocolinternals.so.*.*.*
189 %attr(755,root,root) %{_libdir}/qt4/plugins/sqldrivers/libqsqlite3.so
190 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.AgentManager.xml
191 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.Agent.Search.xml
192 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.Agent.Status.xml
193 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.NotificationManager.xml
194 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.NotificationSource.xml
195 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.Preprocessor.xml
196 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.Resource.xml
197 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.Tracer.xml
198 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.Agent.Control.xml
199 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.ControlManager.xml
200 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.DebugInterface.xml
201 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.Server.xml
202 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.StorageDebugger.xml
203 %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.TracerNotification.xml
204 %{_datadir}/dbus-1/services/org.freedesktop.Akonadi.Control.service
205
206 %files devel
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_libdir}/libakonadiprotocolinternals.so
209 %{_libdir}/cmake/Akonadi
210 %{_includedir}/akonadi
211 %{_pkgconfigdir}/akonadi.pc
This page took 0.578858 seconds and 4 git commands to generate.