]> git.pld-linux.org Git - packages/aide.git/commitdiff
- fix build
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 16 Feb 2013 23:33:59 +0000 (00:33 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 16 Feb 2013 23:33:59 +0000 (00:33 +0100)
aide-Werror.patch [new file with mode: 0644]
aide-lex.patch [new file with mode: 0644]
aide.spec

diff --git a/aide-Werror.patch b/aide-Werror.patch
new file mode 100644 (file)
index 0000000..91e4f5b
--- /dev/null
@@ -0,0 +1,20 @@
+--- aide-0.15.1/src/db_file.c~ 2010-08-08 19:39:31.000000000 +0200
++++ aide-0.15.1/src/db_file.c  2013-02-17 00:30:25.921433489 +0100
+@@ -702,7 +702,7 @@
+   }
+   if(tmpstr){
+-    retval=dofprintf(tmpstr);
++    retval=dofprintf("%s", tmpstr);
+     free(tmpstr);
+     return retval;
+   }else {
+@@ -741,7 +741,7 @@
+   tmpstr=encode_base64((byte *)ptr,strlen(ptr));
+-  retval=dofprintf(tmpstr);
++  retval=dofprintf("%s", tmpstr);
+   free(tmpstr);
+   free(ptr);
diff --git a/aide-lex.patch b/aide-lex.patch
new file mode 100644 (file)
index 0000000..ecb4675
--- /dev/null
@@ -0,0 +1,22 @@
+--- aide-0.15.1/src/conf_lex.l~        2010-08-08 19:39:31.000000000 +0200
++++ aide-0.15.1/src/conf_lex.l 2013-02-17 00:28:27.265336729 +0100
+@@ -12,7 +12,7 @@
+ %{
+-#define YYDEBUG
++#define YYDEBUG 1
+ /*
+  * Copyright (C) 1999-2002,2004-2006,2010 Rami Lehti, Pablo Virolainen, Richard
+--- aide-0.15.1/src/db_lex.l~  2010-08-08 19:39:31.000000000 +0200
++++ aide-0.15.1/src/db_lex.l   2013-02-17 00:32:07.953812738 +0100
+@@ -45,7 +45,7 @@
+ #define YY_DECL int db_scan(void)
+-#define YYDEBUG
++#define YYDEBUG 1
+ #include "aide.h"
+ #include "conf_yacc.h"
index 1c8beee51f6ec7c1da002722cfab0d1959099301..e241bff61714985e08f2d3f975efcbd44fb56467 100644 (file)
--- a/aide.spec
+++ b/aide.spec
@@ -16,6 +16,8 @@ Source4:      %{name}.sysconfig
 Patch0:                %{name}-autoconf.patch
 Patch1:                %{name}-NLS.patch
 Patch2:                %{name}-no_md.patch
+Patch3:                %{name}-lex.patch
+Patch4:                %{name}-Werror.patch
 URL:           http://www.cs.tut.fi/~rammer/aide.html
 BuildRequires: autoconf
 BuildRequires: automake
@@ -59,6 +61,10 @@ detectar violações de integridade pelo uso de hashes como MD5.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
+
+rm src/conf_lex.c src/db_lex.c
 
 %build
 %{__gettextize}
This page took 0.084795 seconds and 4 git commands to generate.