]> git.pld-linux.org Git - packages/aethera.git/blob - aethera.spec
- tabs in preamble
[packages/aethera.git] / aethera.spec
1 # TODO: optflags
2 %define         _rel    0.3
3 Summary:        Aethera - Email and PIM application
4 Summary(pl.UTF-8):      Aethera - aplikacja poczty elektronicznej i zarządcy informacji osobistej (PIM)
5 Name:           aethera
6 Version:        1.2.1
7 Release:        050331.%{_rel}
8 License:        GPL
9 Group:          X11/Applications
10 Source0:        %{name}-%{version}.tar.gz
11 Patch0:         %{name}-libs.patch
12 Patch1:         %{name}-includes.patch
13 Patch2:         %{name}-install.patch
14 Patch3:         %{name}-fpic.patch
15 Patch4:         %{name}-typo.patch
16 # Source0-md5:  f3efd064b5e9884bd7adf49bf763e213
17 URL:            http://www.thekompany.com/projects/aethera/
18 BuildRequires:  korelib-devel
19 BuildRequires:  qmake
20 BuildRequires:  qt-devel
21 #Requires: thekompany-support
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Aethera is a pim application, i.e. it handles all kinds of personal
26 information: email, contacts, notes, tasks, todos, journals.
27
28 %description -l pl.UTF-8
29 Aethera jest aplikacją zarządcy informacji osobistej (PIM). Obsługuje
30 wszystkie rodzaje informacji osobistych: pocztę elektroniczną,
31 kontakty, notatki, zadania, sprawy do załatwienia, dzienniki.
32
33 %package devel
34 Summary:        Header files for Aethera libraries
35 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Aethery
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for Aethera libraries.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe bibliotek Aethery.
44
45 %prep
46 %setup -q
47 %patch0 -p1
48 %patch1 -p1
49 %patch2 -p1
50 %ifarch %{x8664}
51 %patch3 -p1
52 %endif
53 %patch4 -p1
54
55 mkdir -p include/aethera
56 ln -sf ../../aethera/libs/clientskel/clientrmi.h include/aethera
57 ln -sf ../../aethera/libs/clientskel/vfsmodule.h include/aethera
58
59 %build
60 export QTDIR=/usr
61 export QMAKE_STRIP=:
62
63 # Use the new libraries in building process
64 export LD_LIBRARY_PATH=$dir/lib:$LD_LIBRARY_PATH
65 dir=$(pwd)
66
67 # Compile tkcBase
68 cd tkcbase
69 cat <<EOF > defines.pri
70 TKCBASE_LIB=%{_libdir}
71 TKCBASE_INCLUDE=%{_includedir}/tkcbase
72 CONFIG += release thread
73 EOF
74 qmake desktop.pro
75 %{__make}
76
77 # Compile tkcSSL
78 cd ../tkcssl
79 cat <<EOF > defines.pri
80 TKCSSL_LIB=%{_libdir}
81 TKCSSL_INCLUDE=%{_includedir}/tkcssl
82 INCLUDEPATH += $dir/tkcbase
83 DEPENDPATH += $dir/tkcbase
84 CONFIG += release thread
85 EOF
86 qmake tkcssl.pro
87 %{__make}
88
89 # Compile webdav
90 cd ../webdav
91 cat <<EOF > defines.pri
92 WEBDAV_LIB=%{_libdir}
93 WEBDAV_INCLUDE=%{_includedir}/tkcbase
94 CONFIG += release thread
95 EOF
96 qmake webdav.pro
97 %{__make}
98
99 # Compile Aethera
100 cd ../aethera
101 cat <<EOF > defines.pri
102 AETHERA_DIR=%{_libdir}/aethera
103 AETHERA_BIN=%{_bindir}
104 AETHERA_LIB=%{_libdir}
105 AETHERA_INCLUDE=%{_includedir}/aethera
106 TINO_LIB=%{_libdir}
107 TINO_INCLUDE=%{_includedir}/tino
108 INCLUDEPATH += $dir/include
109 INCLUDEPATH += $dir/tkcbase
110 DEPENDPATH += $dir/tkcbase
111 INCLUDEPATH += $dir/tkcssl
112 DEPENDPATH += $dir/tkcssl
113
114 CONFIG += qt warn_on release thread
115 EOF
116
117 qmake aethera.pro
118 %{__make}
119
120 # Compile KOrganizer plugin
121 cd ../koplugin
122 cat <<EOF > defines.pri
123 AETHERA_DIR = %{_libdir}/aethera
124
125 INCLUDEPATH += $dir/include
126 INCLUDEPATH += $dir/tkcbase
127 DEPENDPATH += $dir/tkcbase
128
129 INCLUDEPATH += $dir/tkcssl
130 DEPENDPATH += $dir/tkcssl
131
132 INCLUDEPATH += $dir/aethera/libs
133 DEPENDPATH += $dir/aethera/libs
134
135 INCLUDEPATH += $dir/aethera/libs/aethera
136 DEPENDPATH += $dir/aethera/libs/aethera
137
138 INCLUDEPATH += $direbdav/webdav
139 DEPENDPATH += $dir/webdav/webdav
140
141 INCLUDEPATH += $dir/aethera/libs/clientskel
142 DEPENDPATH += $dir/aethera/libs/clientskel
143
144 INCLUDEPATH += $dir/include/aethera/libs/plugins/kommailplugin
145 DEPENDPATH += $dir/include/aethera/libs/plugins/kommailplugin
146
147 INCLUDEPATH += $dir/include/aethera/libs/plugins/komcontactsplugin
148 DEPENDPATH += $dir/include/aethera/libs/plugins/komcontactsplugin
149
150 INCLUDEPATH += $dir/include/tino
151 DEPENDPATH += $dir/include/tino
152
153 CONFIG += qt warn_on release thread
154 DEFINES += AETHERA_KOLAB
155 EOF
156
157 qmake KOPlugin.pro
158 %{__make}
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162 install -d $RPM_BUILD_ROOT%{_libdir}/aethera
163
164 export QTDIR=/usr
165 %{__make} -C tkcbase install \
166         INSTALL_ROOT=$RPM_BUILD_ROOT
167 %{__make} -C tkcssl install \
168         INSTALL_ROOT=$RPM_BUILD_ROOT
169 %{__make} -C webdav install \
170         INSTALL_ROOT=$RPM_BUILD_ROOT
171 %{__make} -C aethera install \
172         INSTALL_ROOT=$RPM_BUILD_ROOT
173 %{__make} -C koplugin install \
174         INSTALL_ROOT=$RPM_BUILD_ROOT
175
176 # x86 binary
177 rm $RPM_BUILD_ROOT%{_libdir}/aethera/bin/sox
178 # unneccessary wrappers
179 rm $RPM_BUILD_ROOT%{_libdir}/aethera/bin/aethera_sound
180 rm $RPM_BUILD_ROOT%{_prefix}/local/bin/aethera
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %post   -p /sbin/ldconfig
186 %postun -p /sbin/ldconfig
187
188 %files
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_bindir}/aethera
191 %attr(755,root,root) %{_libdir}/libaethera.so.1.0.1
192 %attr(755,root,root) %{_libdir}/libfilebrowser.so.1.0.0
193 %attr(755,root,root) %{_libdir}/libtino.so.1.0.0
194 %attr(755,root,root) %{_libdir}/libtkcbase.so.1.0.0
195 %attr(755,root,root) %{_libdir}/libtkcssl.so.1.0.0
196 %dir %{_libdir}/aethera
197 %dir %{_libdir}/aethera/plugins
198 %attr(755,root,root) %{_libdir}/aethera/plugins/libhomeplugin.so.1.0.0
199 %attr(755,root,root) %{_libdir}/aethera/plugins/libkomcontactsplugin.so.1.0.0
200 %attr(755,root,root) %{_libdir}/aethera/plugins/libkommailplugin.so.1.0.0
201 %attr(755,root,root) %{_libdir}/aethera/plugins/libkomnotesplugin.so.1.0.0
202 %attr(755,root,root) %{_libdir}/aethera/plugins/libkorganizer.so.1.0.0
203 %attr(755,root,root) %{_libdir}/aethera/plugins/libmailimport.so.1.0.0
204 %{_libdir}/aethera/help
205 %{_libdir}/aethera/pics
206 %{_libdir}/aethera/sound
207 %{_libdir}/aethera/data
208 %dir %{_libdir}/aethera/i18n
209 # XXX: are *.ts (translation sources) needed in binary package?
210 %lang(de) %{_libdir}/aethera/i18n/aethera_de.qm
211 %lang(de) %{_libdir}/aethera/i18n/aethera_de.ts
212 %lang(de) %{_libdir}/aethera/i18n/koplugin_de.ts
213 %lang(en) %{_libdir}/aethera/i18n/aethera_en.ts
214 %lang(en) %{_libdir}/aethera/i18n/koplugin_en.ts
215 %lang(fr) %{_libdir}/aethera/i18n/aethera_fr.qm
216 %lang(fr) %{_libdir}/aethera/i18n/aethera_fr.ts
217 %lang(fr) %{_libdir}/aethera/i18n/koplugin_fr.qm
218 %lang(fr) %{_libdir}/aethera/i18n/koplugin_fr.ts
219 %lang(pt) %{_libdir}/aethera/i18n/aethera_pt.qm
220 %lang(pt) %{_libdir}/aethera/i18n/aethera_pt.ts
221 %lang(pt) %{_libdir}/aethera/i18n/koplugin_pt.qm
222 %lang(pt) %{_libdir}/aethera/i18n/koplugin_pt.ts
223 %lang(pt) %{_libdir}/aethera/i18n/qt_pt.qm
224 %lang(pt) %{_libdir}/aethera/i18n/qt_pt.ts
225 %lang(ru) %{_libdir}/aethera/i18n/aethera_ru.qm
226 %lang(ru) %{_libdir}/aethera/i18n/aethera_ru.ts
227 %{_desktopdir}/aethera.desktop
228 %{_iconsdir}/hicolor/*/apps/aethera.png
229 %{_pixmapsdir}/*.png
230
231 %files devel
232 %defattr(644,root,root,755)
233 %{_libdir}/libtkwidgets.a
234 %{_libdir}/libwebdav.a
235 %{_includedir}/aethera
236 %{_includedir}/tino
237 %{_includedir}/tkcbase
238 %{_includedir}/tkcssl
This page took 0.129842 seconds and 3 git commands to generate.